Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox does not display all web sites in HTML, furthermore sites keep getting "this site is not secure message." I've tried everything. Updates, clear cache,

  • 13 uphendule
  • 1 inale nkinga
  • 12 views
  • Igcine ukuphendulwa ngu jscher2000

more options

Firefox does not display all web sites in HTML, furthermore sites keep getting "this site is not secure message." I've tried everything. Updates, clear cache, reinstalling, even tried to load an older version...but it updated to the new version. Simple sites like Yahoo.com come up ... but when I do a search I get a text only page. I even get this weird ancient text only no html looking page on Mozilla site itself!!! I need help....Firefox works on all my other computers...what is happening??

All Replies (13)

more options

Hi starz222, when you had a similar problem before, you marked tweaking your ESET software settings as the solution. Did you try that this time, or did you change your security software in between?

Firefox is resolving youtube.com and firefox support site as a "text" page...not full page

If you marked that accidentally and you do not use ESET security software, please review the following article about a range of software that operate as a "man in the middle" and cause secure connection problems until Firefox is set up to work with them:

How to troubleshoot security error codes on secure websites

more options

Hi Jscher2000. Yes I do use ESET. I did "tweak" security settings at the time...but then discovered that it really did not fix the problem! So..I'm looking for a solution to this problem still. Any suggestions from here?

more options

Okay, let's investigate further. You mentioned that

I even get this weird ancient text only no html looking page on Mozilla site itself!!!

The style sheets used by this support site are stored on a different server. This is pretty common because more users can be served fresh content more quickly if browsers can retrieve certain infrequently changing files from another source (often a content distribution network or CDN).

Could you check whether a file on one of these servers is accessible in your Firefox, or is blocked?

https://support.cdn.mozilla.net/static/build/common-min.e8b3c24a8874.css -- page of text starting with:

/*! normalize.css v3.0.2 | MIT License | git.io/normalize

Also, can you successfully view the "About" page here, or do you get an error?

https://www.mozilla.org/about/

more options

I went to https://support.cdn.mozilla.net/static/build/common-min.e8b3c24a8874.css and got the Page Not Secured window. I went to https://www.mozilla.org/about/ and the page opened fine...graphics and all. PS: attached are some screen shots

more options

On that error page, could you click the Advanced button? Usually a more detailed explanation of the problem will be displayed. If you see a link with an error code, please click that and copy/paste the information into a reply. Thanks.

more options

see screen shot...advanced page now opened.

more options

See the blue part SEC_ERROR_UNKNOWN_ISSUER? Click that to open a panel with the certificate in encoded form, and copy/paste that gibberish into a reply.

more options

Hi Jscher2000 don't know if you see the post above with the screen shot of the advance page that said: Error code: SEC_ERROR_UNKNOWN_ISSUER

if that helps understand the problem?   Please let me know.
more options

When you click SEC_ERROR_UNKNOWN_ISSUER on the error page, a new panel should appear below it with the information I need. Did you click it? And please copy/paste that section when it appears. A screenshot is useless for this purpose.

more options

Hi jscher2000 When I hit SEC_ERROR_UNKNOWN_ISSUER Only a "copy to clipboard" box appears....when I copy it then paste....nothing is there...see screen shot.


I did click Learn More and was able to cut and paste these instruction from a page at Mozilla.

What does "Your connection is not secure" mean?

When Firefox connects to a secure website (the URL begins with "https://"), it must verify that the certificate presented by the website is valid and that the encryption is strong enough to adequately protect your privacy. If the certificate cannot be validated or if the encryption is not strong enough, Firefox will stop the connection to the website and instead show an error page.

On some websites there is an option to report secure connection errors to Mozilla for statistical purposes:

report tls error

To troubleshoot secure connection problems with the error message Secure Connection Failed, see the Troubleshoot the "Secure Connection Failed" error message article.

When Firefox connects to a secure website (the URL begins with "https://"), it must verify that the certificate presented by the website is valid and that the encryption is strong enough to adequately protect your privacy. If the certificate cannot be validated or if the encryption is not strong enough, Firefox will stop the connection to the website and instead show an error page:

Fx44 Insecure Connection

   To troubleshoot secure connection problems with the error message Secure Connection Failed, see the Troubleshoot the "Secure Connection Failed" error message article.
more options

Sorry, I don't know how you ended up on the Health Report page. I am looking for the information for the page I linked to earlier where you got the error before:

https://support.cdn.mozilla.net/static/build/common-min.e8b3c24a8874.css

more options

When I click SEC_ERROR_UNKNOWN_ISSUER on the error page, a new panel does not appear below it with the information you need. All that appears is the "copy to clipboard" button...which when pressed captures nothing!?! I tried copying then pasting into a box...and there's nothing there!

In the meantime, I heard back from ESET. They told me to go into advanced features and turn off Protocol Filtering. (See screen shot.) I tried this...then returned to a page that is problematic...like youtube.com and yahoo.com So far both are behaving correctly. But, and that's a big but, I've been down this path before...where after shutdown and startup I"m back to the problem again. So...I'm experimenting now and will see if this fix corrects the problem permanently. Again...sorry that I can not get the code you are looking for....it's just not displaying it.

more options

Thanks for checking, and that's fine, it's obvious that ESET is the culprit.

If you ever used Firefox's Refresh feature, that will break trust with ESET and treat it's fake "man in the middle" certificates as untrustworthy. That could explain how after working for a long time it stopped working. Then you would need to set it up again as you did in the earlier thread.

It's also possible that after updating to a new major version of ESET you need to clear out an old saved ESET certificate and import the new one. You can check for that in the Certificate Manager. Here's a rough idea how (I don't have ESET software so can't say for sure):

"3-bar" menu button (or Tools menu) > Options

In the left column, click Advanced. Then on the right side, click the Certificates mini-tab along the top. Then click the "View Certificates" button.

This should open the Certificate Manager. Click the "Authorities" tab. There is a very long list here, with some indicated as "Builtin" and others added by Firefox as you encounter them or import them.

Can you spot any related to ESET? You could try removing those and then using the disable/reenable method to re-add it and see whether that works this time.