搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

unable to upload images from my computer to blogger

  • 8 回覆
  • 0 有這個問題
  • 62 次檢視
  • 最近回覆由 zeroknight

more options

Hello, On 18th Oct this year, blogger would not let me upload picture files from my computer - it gives the message 'Allow google.com to use cookies - you will not be able to access your files if necessary cookies are turned off'. I click Accept but nothing happens, so I click close and the window goes away without solving the problem. Uploading and publishing blogs with images was working with no problem two days earlier. I was still logged into my gmail account and had not made any changes. This is what I have tried. 1 - Switched off enhanced tracking protection for this site, as suggested by Firefox. It allowed me to upload 1 image into a draft post but this had disappeared the next time I opened the draft. Since then I have been getting the error message and not been able to upload images. 2 - cleared the cookies from google, as suggested by firefox. No effect 3 - cleared the cache and site data as suggested. No effect. I followed this with closing Firefox and reloading, logging back in to gmail, and still the problem persists. Can you help please? best wishes

Hello, On 18th Oct this year, blogger would not let me upload picture files from my computer - it gives the message 'Allow google.com to use cookies - you will not be able to access your files if necessary cookies are turned off'. I click Accept but nothing happens, so I click close and the window goes away without solving the problem. Uploading and publishing blogs with images was working with no problem two days earlier. I was still logged into my gmail account and had not made any changes. This is what I have tried. 1 - Switched off enhanced tracking protection for this site, as suggested by Firefox. It allowed me to upload 1 image into a draft post but this had disappeared the next time I opened the draft. Since then I have been getting the error message and not been able to upload images. 2 - cleared the cookies from google, as suggested by firefox. No effect 3 - cleared the cache and site data as suggested. No effect. I followed this with closing Firefox and reloading, logging back in to gmail, and still the problem persists. Can you help please? best wishes

被選擇的解決方法

It is now ok. There were several suggestions and this is what worked - I disabled total cookie protection for the site (blogger) that was having the problem. Many thanks to zeroknight and cor-el!

https://support.mozilla.org/en-US/kb/total-cookie-protection-and-website-breakage-faq#w_can-i-disable-total-cookie-protection-without-disabling-enhanced-tracking-protection

從原來的回覆中察看解決方案 👍 0

所有回覆 (8)

more options

Does it still happen in Troubleshoot Mode?

more options

No it didn't - I also restarted my laptop and loaded FIrefox in Troubleshoot mode, and that didn't work either. I did try on another person's laptop, by accessing the blog as a public user and then logging in. The same window came up, and when I clicked 'allow' a message dropped down/popped up asking 'allow docs.google.com to use cookies on draft.blogger.com?' (as it had on mine, I had forgotten). I clicked on allow, and then it behaved just as it did on mine. Both use the latest version of Firefox.

more options

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.

more options
more options

Thank you, but it only worked while the blogger window was open. It asked to allow cookies, and nothing happened - but I realised I had turned enhanced tracking protection back on, so turned it off again and then it allowed me to add images to the post. By the way, blogger has changed the dialogues for inserting images, which may be the root cause of the problem? Anyway, I finished uploading my photos and published the post (which I had not had time to do until now). That has worked. Then I closed the window (when this problem first arose the circumstances meant I had to shut down the laptop after use, so I thought I had better do the same here). And when I reloaded blogger (enhanced tracking now off) it failed again in the same way.

more options

You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings) or click the padlock icon (Clear cookies and site data) for the domain in the selected tab.

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can check for issues with Enhanced Tracking Protection. Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages like blocked content.

more options

選擇的解決方法

It is now ok. There were several suggestions and this is what worked - I disabled total cookie protection for the site (blogger) that was having the problem. Many thanks to zeroknight and cor-el!

https://support.mozilla.org/en-US/kb/total-cookie-protection-and-website-breakage-faq#w_can-i-disable-total-cookie-protection-without-disabling-enhanced-tracking-protection

more options

NB Bonjour said

I disabled total cookie protection for the site (blogger)

You can't disable Total Cookie Protection for a specific site. It would be better to disable Tracking Protection for blogger rather than weaken it everywhere and use uBlock Origin to do the tracker blocking.