搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Autoplay is blocked when opening link in New Tab without switching to it

  • 18 回覆
  • 1 有這個問題
  • 29 次檢視
  • 最近回覆由 icywiddow

more options

So, despite selecting "Allow Audio and Video" in the Site Preferences, "AUTOPLAY BLOCKED" continues to show on a tab, and it only goes away once I access the tab. This particularly happens on Youtube media.

You may find attached to this question an image of my about:config settings.

What further can be done to fix this?

So, despite selecting "Allow Audio and Video" in the Site Preferences, "AUTOPLAY BLOCKED" continues to show on a tab, and it only goes away once I access the tab. This particularly happens on Youtube media. You may find attached to this question an image of my about:config settings. What further can be done to fix this?
附加的畫面擷圖

所有回覆 (18)

more options

What youtube link is doing this? Link so others can verify what your getting.

有幫助嗎?

more options

For a specific website you can check the autoplay setting in "Tools -> Page Info -> Permissions".

有幫助嗎?

more options

Dropa said

What youtube link is doing this? Link so others can verify what your getting.

It's every video on YouTube. Attached is the little notice that appears on EVERY tab under the video title.

有幫助嗎?

more options

cor-el said

For a specific website you can check the autoplay setting in "Tools -> Page Info -> Permissions".

Did that. It had the settings I already enabled.

有幫助嗎?

more options

What if you set media.autoplay.allow-extension-background-pages = true ?

有幫助嗎?

more options

cor-el said

What if you set media.autoplay.allow-extension-background-pages = true ?

Set it. Still didn't work.

有幫助嗎?

more options

icywiddow said

Dropa said

What youtube link is doing this? Link so others can verify what your getting.

It's every video on YouTube. Attached is the little notice that appears on EVERY tab under the video title.

Where is that image showing in your browser. I have YT set to not autoplay and I've never seen that. Please provide a better screenshot.

有幫助嗎?

more options

Isn't it by design that even with autoplay enabled, if you open a page with media in a new tab then the media won't start autoplaying until the tab is first focussed?

This avoids the situation where if you open say a bunch of google results by ctrl+clicking items in the search results page, then any media on these pages starts playing all at once?

Or so you can open a folder of youtube videos in your bookmarks library without them all starting playing at once? Each video will only start autoplaying when you first switch to its tab?

Sorry, can't be more helpful as I don't know how to change this behaviour, just saying that I believe it is intentional and not a question of the settings not working as intended?

Someone can correct me if I am wrong here.

由 TechHorse 於 修改

有幫助嗎?

more options

I just want to see where it shows "AUTOPLAY BLOCKED" for him because this is all I've ever seen. see screenshot His screenshot looks like an add-on.

由 jonzn4SUSE 於 修改

有幫助嗎?

more options

The screenshot looks as though it's from about:config.

有幫助嗎?

more options

jonzn4SUSE said

I just want to see where it shows "AUTOPLAY BLOCKED" for him because this is all I've ever seen. see screenshot His screenshot looks like an add-on.

Just using some videos on the front page of Youtube, I accessed them using "Open Link in New Tab." They don't play in the background, hence the "AUTOPLAY BLOCKED" below the tab title. Only plays once I access the tab. My autoplay permission is showed.

My only add-on is uBlock Origin.

有幫助嗎?

more options

Much better screenshots!!!  ;-)) Have you tried with Firefox in Safe Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#search That AUTOPLAY BLOCKED is something I've never seen before in any version of Firefox.

由 jonzn4SUSE 於 修改

有幫助嗎?

more options

OMG!!! I guess because of the amount of tabs I have open I couldn't see it, but now I do.  ;-))

I also just noticed that when I click on the tab that message goes away.

由 jonzn4SUSE 於 修改

有幫助嗎?

more options

Okay, sorry it took a minute, but because of the number of tabs I run I never saw that message. I am able to replicate his issue in Nightly. I set YT to allow autoplay, but still see the blocked message. When I click on the tab the video does auto play.

由 jonzn4SUSE 於 修改

有幫助嗎?

more options

Too much coffee!!!  ;-))

有幫助嗎?

more options

jonzn4SUSE said

Much better screenshots!!!  ;-)) Have you tried with Firefox in Safe Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#search That AUTOPLAY BLOCKED is something I've never seen before in any version of Firefox.

Problem continued in Troubleshoot Mode.

有幫助嗎?

more options

With Allow Audio & Video Set - media.block-autoplay-until-in-foreground = false

有幫助嗎?

more options

RobertJ said

With Allow Audio & Video Set - media.block-autoplay-until-in-foreground = false

This worked! Problem solved.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題