X
Tap here to go to the mobile version of the site.

Support Forum

"Block autoplay" function only works when opening a video in a new tab, can I get it to work all the time?

Posted

I like how videos now no longer automatically start playing when I open a video (on youtube, for example) in a new tab. However, when I click on a video to open in the current tab, it still autoplays. Can I get this "block autoplay" feature to block videos from playing in my current tab?

Ideally, no video would play unless I specifically click the "play" button.

I like how videos now no longer automatically start playing when I open a video (on youtube, for example) in a new tab. However, when I click on a video to open in the current tab, it still autoplays. Can I get this "block autoplay" feature to block videos from playing in my current tab? Ideally, no video would play unless I specifically click the "play" button.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17414 solutions 157300 answers

You can look at these prefs on the about:config page to see if these values work for you.

  • media.autoplay.default = 1 [0=Allowed, 1=Blocked, 2=Prompt]
  • media.autoplay.allow-muted = false
  • media.autoplay.enabled.user-gestures-needed = false

For user-gestures-needed you can try false and true to see what works for you.

You can look at this extension. Disable HTML5 Autoplay https://addons.mozilla.org/firefox/addon/disable-autoplay/

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

You can look at these prefs on the about:config page to see if these values work for you. *media.autoplay.default = 1 [0=Allowed, 1=Blocked, 2=Prompt] *media.autoplay.allow-muted = false *media.autoplay.enabled.user-gestures-needed = false For user-gestures-needed you can try false and true to see what works for you. You can look at this extension. Disable HTML5 Autoplay https://addons.mozilla.org/firefox/addon/disable-autoplay/ You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.