X
點擊此處開啟此網站的行動版。

技術支援討論區

Inconsistent UI display language

已張貼

After updating, various interface elements are shown in German (see attached screenshot), despite Firefox UI display language being set to English.

After updating, various interface elements are shown in German (see attached screenshot), despite Firefox UI display language being set to English.

被選擇的解決方法

The problem has been resolved by restarting in safe mode and then restarting Firefox normally.

thank you all for your patience and help.

從原來的回覆中察看解決方案 1
引用

提出問題者

Screenshot documenting the UI errors.

Screenshot documenting the UI errors.
這篇文章有幫助嗎?
引用
FredMcD
  • Top 10 Contributor
4188 個解決方法 58463 個答案

Install the proper language from; Download Firefox For All languages And Systems {web link}

Install the proper language from; '''[http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems]''' {web link}
這篇文章有幫助嗎?
引用

提出問題者

Hi Fred, I've installed the English language version of Firefox (which had already been installed anyways) but the issue has not been resolved. Despite English being designated as the "language used to display menus, messages, and notifications" - areas of the UI continue to be shown in German, as documented in the attached screenshot. These areas include menus opened by right click, the Firefox menu, bookmarks and assorted textual elements as documented above.

Hi Fred, I've installed the English language version of Firefox (which had already been installed anyways) but the issue has not been resolved. Despite English being designated as the "language used to display menus, messages, and notifications" - areas of the UI continue to be shown in German, as documented in the attached screenshot. These areas include menus opened by right click, the Firefox menu, bookmarks and assorted textual elements as documented above.
這篇文章有幫助嗎?
引用
FredMcD
  • Top 10 Contributor
4188 個解決方法 58463 個答案

Do you have any language packs installed? Remove them.

What is your location? Are you outside an English area? Some doing an install of a language have problems when they are outside of that language area.

Do you have any language packs installed? Remove them. What is your location? Are you outside an English area? Some doing an install of a language have problems when they are outside of that language area.
這篇文章有幫助嗎?
引用

提出問題者

I am in Germany. I only have the English language packs installed. Removing them did nothing. This issue only came up after the recent update to Firefox 67.

I am in Germany. I only have the English language packs installed. Removing them did nothing. This issue only came up after the recent update to Firefox 67.
這篇文章有幫助嗎?
引用
FredMcD
  • Top 10 Contributor
4188 個解決方法 58463 個答案

I called for more help.

I called for more help.
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8575 個解決方法 70112 個答案

Do you want to try installing the U.S. English version of Firefox? I think that may remove some multilingual functionality, so if that is important, never mind.

The U.S. English installer (and any other language) is available on the following page:

https://www.mozilla.org/firefox/all/

Do you want to try installing the U.S. English version of Firefox? I think that may remove some multilingual functionality, so if that is important, never mind. The U.S. English installer (and any other language) is available on the following page: https://www.mozilla.org/firefox/all/
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17340 個解決方法 156761 個答案

Do you possibly have a Language tab on the about:addons page?

What does it say under "Internationalization & Localization" on the "Help -> Troubleshooting Information" (about:support) ?

Do you possibly have a Language tab on the about:addons page? What does it say under "Internationalization & Localization" on the "Help -> Troubleshooting Information" (about:support) ? *https://support.mozilla.org/en-US/kb/use-troubleshooting-information-page-fix-firefox
這篇文章有幫助嗎?
引用

提出問題者

@jscher2000 - this was already attempted as per the suggestion above by FredMcD and did not resolve the issue.

@core-el - the only language tab open under about:addons is the English language dictionary "as shipped with Firefox 60".

Below are the "Internationalization & Localization" infos:

Requested Locales ["en-US","de"] Available Locales ["en-US"] App Locales ["en-US"] Regional Preferences ["en-DE"] Default Locale "en-US" Operating System System Locales ["en-US"] Regional Preferences ["en-DE"]

@jscher2000 - this was already attempted as per the suggestion above by FredMcD and did not resolve the issue. @core-el - the only language tab open under about:addons is the English language dictionary "as shipped with Firefox 60". Below are the "Internationalization & Localization" infos: Requested Locales ["en-US","de"] Available Locales ["en-US"] App Locales ["en-US"] Regional Preferences ["en-DE"] Default Locale "en-US" Operating System System Locales ["en-US"] Regional Preferences ["en-DE"]
這篇文章有幫助嗎?
引用

選擇的解決方法

The problem has been resolved by restarting in safe mode and then restarting Firefox normally.

thank you all for your patience and help.

The problem has been resolved by restarting in safe mode and then restarting Firefox normally. thank you all for your patience and help.
這篇文章有幫助嗎? 1
引用
cor-el
  • Top 10 Contributor
  • Moderator
17340 個解決方法 156761 個答案

This isn't about dictionaries found under "Extensions -> dictionaries", but about possible language packs found under "Extensions -> Languages" that Firefox may have installed automatically based upon the locale settings you posted above. If this only happens randomly then you might have multiple profiles where only one profile has a German language pack.

You can check the about:profiles page for other possible profile folders. You can open "about:" pages via the location/address bar

  • "about:" is a protocol to access special pages
This isn't about dictionaries found under "Extensions -> dictionaries", but about possible language packs found under "Extensions -> Languages" that Firefox may have installed automatically based upon the locale settings you posted above. If this only happens randomly then you might have multiple profiles where only one profile has a German language pack. *https://support.mozilla.org/en-US/kb/use-firefox-interface-other-languages-language-pack You can check the about:profiles page for other possible profile folders. You can open "<b>about:</b>" pages via the location/address bar *"about:" is a protocol to access special pages
這篇文章有幫助嗎?
引用
FredMcD
  • Top 10 Contributor
4188 個解決方法 58463 個答案

That was very good work. Well done.

That was very good work. Well done.
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題