Tìm kiếm hỗ trợ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox saying Java outdated plugin however Java confirms I have most recent version.

  • 10 trả lời
  • 55 gặp vấn đề này
  • 14297 lượt xem
  • Trả lời mới nhất được viết bởi Jgrossman

more options

1. I saw that Firefox saying that Java Deployment Toolkit 7.0.510.13NPRuntime Script Plug-in Library for Java(TM) Deploy vulnerable Update Now Java(TM) Platform SE 7 U51Next Generation Java Plug-in 10.51.2 for Mozilla browsers

2. I attempted to update. Got message saying that Java update already installed. Message seemed to be a Windows message. Unfortunately, I overrode the message and reinstalled both of the above updates.

3. Now showing the above Javas twice for plugins on Firefox (once in already installed plugins and once in updated plugin.

4. I went to Java. Ran the uninstall older versions of Java from Windows successfully.

5. Firefox continues to say that above Javas are vulnerable and need to be updated.

6. In the past, the updating was seamless. Now not so.

7. What do I need to do or is this a Firefox issue.

8. Both Javas in my plugins (both the ones in recent updates and the ones in regular plugins) are saying "Ask to Activate".

9. Thanks.

Giải pháp được chọn

Hi Jgrossman, the plugin checker site does not currently distinguish between the latest available version (Java 8, for developers) and the one Oracle recommends for your computer (Java 7, for everyone else). This is a limitation of that site. A new site is in progress due to changes in Firefox 29, and that works is taking priority for now, so problems with the current site either will have to wait or will become irrelevant after the new site launches.

Đọc câu trả lời này trong ngữ cảnh 👍 4

Tất cả các câu trả lời (10)

more options

check this

more options

Oracle has released the Java 8 version and the Mozilla plugin check page recognizes this Java version as up-to-date and signals the 7U51 Java version as outdated.

You can find the latest 32 bit Java 8 version on the Oracle website.

See Java Platform > Java SE 8 (JRE 8 Download;32 bit for Windows)

more options

Just a concern. In light of all the issues/bugs with Java in the past, wouldn't it be wise to not download Java 8 from Oracle until the bugs are worked out? Then, at that point, Firefox would indicate Java 8 is ready to download and then it can be downloaded right from the Firefox plug-in, etc. section. Not sure here. Just looking to stay safe with Java on an ongoing basis, based on what I went through last time when it was full of bugs. Thanks.

more options
more options
more options

Java 8 is not supported on WinXP though.

Được chỉnh sửa bởi James vào

more options

Java 8 - Minimum requirement is Windows vIsta

Java 7 - Minimum requirement is Windows XP SP3

more options

Why Does Firefox not know that I am running am OS on my PC that does not support Java 8?

why does it keep suggesting I update when i cannot, and furthermore. Why is the link wrong? The link brings me to a previous version of Java, not to Java 8 link for update which is found in the thread.

more options

Giải pháp được chọn

Hi Jgrossman, the plugin checker site does not currently distinguish between the latest available version (Java 8, for developers) and the one Oracle recommends for your computer (Java 7, for everyone else). This is a limitation of that site. A new site is in progress due to changes in Firefox 29, and that works is taking priority for now, so problems with the current site either will have to wait or will become irrelevant after the new site launches.

more options

Thanks for the info. sounds like it will get fixed shortly

Thanks much