X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

My minimum size window is 4*2 inches; use to be 2*2; how do I get back to the smaller size?

Được đăng

Several months ago, my smallest window size was less than 2 * 2 inches. Then for no reason, the smallest size became about 2*2 inches. This was larger than I wanted but couldn't figure out why the change occurred or how to change it. So I learned to live with it.

Yesterday (12/19/13) when I logged into Firefox, the minimum size became 4*2 inches. This is too wide for me for many of the views that I want. I have not updated Firefox or Java recently. I don't know why this change occurred and would like to know how to redefine the minimum size window on Firefox.

The minimum size window for my IE browser and my Chrome browser is still 2*2. So the problem with the minimum 4*2 window is with Firefox only.

I'm working with a DELL Desktop DV051 with XP operating system 2002 Service Pack 3; 2.79 GHz; 1.99 GB Ram; Avast security

Several months ago, my smallest window size was less than 2 * 2 inches. Then for no reason, the smallest size became about 2*2 inches. This was larger than I wanted but couldn't figure out why the change occurred or how to change it. So I learned to live with it. Yesterday (12/19/13) when I logged into Firefox, the minimum size became 4*2 inches. This is too wide for me for many of the views that I want. I have not updated Firefox or Java recently. I don't know why this change occurred and would like to know how to redefine the minimum size window on Firefox. The minimum size window for my IE browser and my Chrome browser is still 2*2. So the problem with the minimum 4*2 window is with Firefox only. I'm working with a DELL Desktop DV051 with XP operating system 2002 Service Pack 3; 2.79 GHz; 1.99 GB Ram; Avast security

Giải pháp được chọn

Hi swogden, I'm not sure what the x6 location represents. Perhaps it is an extension? I think you can ignore that one.

I hadn't paid attention to the rule itself before now since it was successful in the earlier thread, but now that I think about it... You often you need to add !important to a custom rule so that Firefox can resolve the conflict between the two directly conflicting rules in favor of your rule. Here's where it goes:

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#main-window:not([chromehidden~="toolbar"]) { 
  min-width: 200px !important;
} 

Does that help?

Đọc câu trả lời này trong ngữ cảnh 2

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 11.9 r900
  • Google Update
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • 2.23.1.0 - The WorldWinner plug-in allows you to enjoy online casual games with the thrill of playing for cash and prizes
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • MetaStream 3 Plugin r4

Ứng dụng

  • Firefox 26.0
  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 5.1; rv:26.0) Gecko/20100101 Firefox/26.0
  • URL hỗ trợ: https://support.mozilla.org/1/firefox/26.0/WINNT/en-US/

Tiện ích mở rộng

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • avast! Online Security 9.0.2006.53 (wrc@avast.com) (không hoạt động)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (không hoạt động)

Javascript

  • incrementalGCEnabled: True

Đồ họa

  • adapterDescription: Intel(R) 82915G/GV/910GL Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x2582
  • adapterDeviceID2:
  • adapterDrivers: ialmrnt5
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'6.1400.1000.5218']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 10-14-2005
  • driverDate2:
  • driverVersion: 6.14.10.4410
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'6.1400.1000.5218']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'6.1400.1000.5218']
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Thay đổi cài đặt

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131205075310
  • browser.startup.homepage_override.buildID: 20131205075310
  • browser.startup.homepage_override.mstone: 26.0
  • extensions.lastAppVersion: 26.0
  • gfx.blacklist.direct2d: 3
  • gfx.blacklist.layers.direct3d10: 3
  • gfx.blacklist.layers.direct3d10-1: 3
  • gfx.blacklist.layers.direct3d9: 3
  • gfx.blacklist.layers.opengl: 3
  • gfx.blacklist.stagefright: 3
  • gfx.blacklist.suggested-driver-version: 6.1400.1000.5218
  • gfx.blacklist.webgl.angle: 3
  • gfx.blacklist.webgl.msaa: 3
  • gfx.blacklist.webgl.opengl: 3
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1387562070
  • places.history.expiration.transient_current_max_pages: 53427
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1387562069

Linh tinh

  • Người dùng JS: Không
  • Có thể tiếp cận: Không
cor-el
  • Top 10 Contributor
  • Moderator
17516 giải pháp 158398 câu trả lời
Được đăng

Câu trả lời hữu ích

See:

See: *[[/questions/980992#answer-513927]] Window size won't go below 410px in v.26

Người tạo câu hỏi

I've read the recommended answer. I tried to find the referenced chrome.... file, but no luck. I assume it should be buried in the Firefox version 26 folder.

Even if I found it, I'd be reluctant to introduce the change by adding coding since I don't do coding and would likely create other problems. Is there some other way to introduce this change (change in settings box)?

The problem is limited to my Firefox browser so I'll be shifting to IE and Chrome for pages that I need smaller windows. Hopefully, Firefox will adjust the minimum size to 100 from 410 in future revisions.

I've read the recommended answer. I tried to find the referenced chrome.... file, but no luck. I assume it should be buried in the Firefox version 26 folder. Even if I found it, I'd be reluctant to introduce the change by adding coding since I don't do coding and would likely create other problems. Is there some other way to introduce this change (change in settings box)? The problem is limited to my Firefox browser so I'll be shifting to IE and Chrome for pages that I need smaller windows. Hopefully, Firefox will adjust the minimum size to 100 from 410 in future revisions.

Người tạo câu hỏi

•chrome://browser/content/browser.css

Where should this file be located?

•chrome://browser/content/browser.css Where should this file be located?
cor-el
  • Top 10 Contributor
  • Moderator
17516 giải pháp 158398 câu trả lời
Được đăng

That is an internal Firefox file and stored in one of the omni.ja archives in the Firefox program folder.

  • resource://gre/
  • resource:///
  • resource:///chrome/browser/content/browser/

You can open this file for inspection via the location bar just like opening a web page. •chrome://browser/content/browser.css

That is an internal Firefox file and stored in one of the omni.ja archives in the Firefox program folder. *resource://gre/ *resource:/// *resource:///chrome/browser/content/browser/ You can open this file for inspection via the location bar just like opening a web page. •chrome://browser/content/browser.css

Người tạo câu hỏi

Okay. I found the browser.css file; opened it and saw the line showing the 390 that I would like to be 100.

I assume that I can't just change the 390 to 100 -- that the file I'm looking at is for display purposes and is not actually the internal code.

I do not understand the next steps -- tho I understand that it involves creating a user profile file and then adding various lines to introduce the lower size. Sorry, there ought to be an easier way for non-techies.

I'm not sure it's worth your time ( or mine) to pursue this. Just have the next version of Firefox have a smaller default size (100)


"You can use an overriding rule in the userChrome.css file with a lower min-width.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

  1. main-window:not([chromehidden~="toolbar"]) {
 min-width: 200px;

}

Add code to the userChrome.css file below the default @namespace line.

   http://kb.mozillazine.org/userChrome.css 

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

   http://kb.mozillazine.org/Editing_configuration
Okay. I found the browser.css file; opened it and saw the line showing the 390 that I would like to be 100. I assume that I can't just change the 390 to 100 -- that the file I'm looking at is for display purposes and is not actually the internal code. I do not understand the next steps -- tho I understand that it involves creating a user profile file and then adding various lines to introduce the lower size. Sorry, there ought to be an easier way for non-techies. I'm not sure it's worth your time ( or mine) to pursue this. Just have the next version of Firefox have a smaller default size (100) "You can use an overriding rule in the userChrome.css file with a lower min-width. @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ #main-window:not([chromehidden~="toolbar"]) { min-width: 200px; } Add code to the userChrome.css file below the default @namespace line. http://kb.mozillazine.org/userChrome.css The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder. http://kb.mozillazine.org/Editing_configuration
jscher2000
  • Top 10 Contributor
8757 giải pháp 71649 câu trả lời
Được đăng

I'll lay it out in more detail:

(1) Find (or create) the chrome folder. This is a folder in your currently active Firefox settings folder, also known as your Firefox profile folder.

  • Open the your profile folder using: Help > Troubleshooting Information
    • Windows: Click the "Show Folder" button
    • Mac: Click the "Show in Finder" button

Windows users: pause to see whether Windows is showing file extensions such as .js, .css, etc. on files. If not, to avoid grief, turn on viewing of file extensions as described in this support article: http://support.microsoft.com/kb/865219.

  • Check for a chrome folder.
    • If it exists: double-click it to open it.
    • If it does not exist: create a chrome folder, then double-click it to open it.

(2) Create or Edit a userChrome.css file by adding your style rule.

  • Check for a userChrome.css file in the chrome folder.
    • If it exists: open it in a text editor. Check that it has this first line:

      @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);

      Then add the following lines at the end and save the file:

      #main-window:not([chromehidden~="toolbar"]) {
        min-width: 200px;
      }
       
    • If it does not exist: create a new text file named userChrome.css. (In Windows, right-click and choose New > Text Document and change the name to userChrome.css.) Then see the previous step for what to place in the file.

The rule change should take effect the next time you start Firefox.

Note: I find it easier to use the Stylish extension for adding custom style rules, but if you don't want yet another extension, then userChrome.css makes the most sense.

I'll lay it out in more detail: (1) Find (or create) the chrome folder. This is a folder in your currently active Firefox settings folder, also known as your Firefox profile folder. * Open the your profile folder using: Help > Troubleshooting Information ** Windows: Click the "Show Folder" button ** Mac: Click the "Show in Finder" button ''Windows users: pause to see whether Windows is showing file extensions such as .js, .css, etc. on files. If not, to avoid grief, turn on viewing of file extensions as described in this support article: [http://support.microsoft.com/kb/865219].'' * Check for a chrome folder. ** If it exists: double-click it to open it. ** If it does not exist: create a chrome folder, then double-click it to open it. (2) Create or Edit a userChrome.css file by adding your style rule. * Check for a userChrome.css file in the chrome folder. ** If it exists: open it in a text editor. Check that it has this first line:<br><br>@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);<br><br>Then add the following lines at the end and save the file:<br><br>#main-window:not([chromehidden~="toolbar"]) {<br>&nbsp;&nbsp;min-width: 200px;<br>}<br> &nbsp; ** If it does not exist: create a new text file named userChrome.css. (In Windows, right-click and choose New > Text Document and change the name to userChrome.css.) Then see the previous step for what to place in the file. The rule change should take effect the next time you start Firefox. Note: I find it easier to use the Stylish extension for adding custom style rules, but if you don't want yet another extension, then userChrome.css makes the most sense.

Người tạo câu hỏi

Thank you for the more detailed instructions. I was surprise that I could follow most of them -- even tho they didn't result in the hoped for result.

I found the Profile Folder. When I clicked on Show Folder (windows xp), I had several folders (none were chrome) and many files.

I created a chrome folder and double clicked it; of course it was empty. I created the userChrome.css file using the right click new Text file routine. Right clicked and copied the 2 lines above onto the notepad; saved it. Closed my firefox windows and tried it -- no change; closed my PC and tried again -- still no change.

Went back in the Profile folder and searched the existing files and found a chrome folder buried in the Storage/persistent folder. There was no userChrome.cc file so I created one by right clicking my mouse - new -Text file routing. Right clicked and copied the 2 lines:

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);

  1. main-window:not([chromehidden~="toolbar"]) {
 min-width: 200px;

}

onto the userChrome.cc notepad and saved it. (Is this the correct way to create and insert instructions?)

Could I change the 200px to 100px?

Unfortunately, the change did not go into effect when I restarted Firefox. Should the userChrome.cc file be in lower case? ie userchrome.cc

Appreciate your willingness to work with me on this. Hope you can figure out what I'm not doing correctly.

Thank you for the more detailed instructions. I was surprise that I could follow most of them -- even tho they didn't result in the hoped for result. I found the Profile Folder. When I clicked on Show Folder (windows xp), I had several folders (none were chrome) and many files. I created a chrome folder and double clicked it; of course it was empty. I created the userChrome.css file using the right click new Text file routine. Right clicked and copied the 2 lines above onto the notepad; saved it. Closed my firefox windows and tried it -- no change; closed my PC and tried again -- still no change. Went back in the Profile folder and searched the existing files and found a chrome folder buried in the Storage/persistent folder. There was no userChrome.cc file so I created one by right clicking my mouse - new -Text file routing. Right clicked and copied the 2 lines: @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); #main-window:not([chromehidden~="toolbar"]) { min-width: 200px; } onto the userChrome.cc notepad and saved it. (Is this the correct way to create and insert instructions?) Could I change the 200px to 100px? Unfortunately, the change did not go into effect when I restarted Firefox. Should the userChrome.cc file be in lower case? ie userchrome.cc Appreciate your willingness to work with me on this. Hope you can figure out what I'm not doing correctly.

Người tạo câu hỏi

I noticed all my userChrome.css references show as userchrome.cc in the above reply. Believe I created the file with the css extension

I noticed all my userChrome.css references show as userchrome.cc in the above reply. Believe I created the file with the css extension
jscher2000
  • Top 10 Contributor
8757 giải pháp 71649 câu trả lời
Được đăng

Let's check the details on the folder and file naming.

Start back at the top level of your profile folder (the level where you find prefs.js and places.sqlite). If you are not already using the Details view, change to the Details view using one of those icons above the file list. Typically this gives you at least 4 columns including Name and Type.

Click the Name column heading once or twice to sort alphabetically, folders at the top. The chrome folder at this level is the one Firefox will use. Note that the word chrome needs to be all lower case.

Click into the chrome folder and look for userChrome.css. This needs to be all lower case except for the C in the middle.

What Type does Windows show for this file? You should see something like "CSS File" or "Cascading Style Sheet". What you would rather not see is "Text document" since that could indicate there is a (hidden?) .txt extension on the file.

Does that check out so far?

Let's check the details on the folder and file naming. Start back at the top level of your profile folder (the level where you find prefs.js and places.sqlite). If you are not already using the Details view, change to the Details view using one of those icons above the file list. Typically this gives you at least 4 columns including Name and Type. Click the Name column heading once or twice to sort alphabetically, folders at the top. The chrome folder at this level is the one Firefox will use. Note that the word chrome needs to be all lower case. Click into the chrome folder and look for userChrome.css. This needs to be all lower case except for the C in the middle. What Type does Windows show for this file? You should see something like "CSS File" or "Cascading Style Sheet". What you would rather not see is "Text document" since that could indicate there is a (hidden?) .txt extension on the file. Does that check out so far?
cor-el
  • Top 10 Contributor
  • Moderator
17516 giải pháp 158398 câu trả lời
Được đăng

You should avoid creating a text file in Windows because that is likely to make Windows add a hidden .txt file extension ending you up with a not working userChrome.css.txt file.

You can check the file type via the Properties in the right-click context menu.

Safest is to create a new file in the text editor and make sure to select type "All files" when using "Save as" to save that file to disk.

You should avoid creating a text file in Windows because that is likely to make Windows add a hidden .txt file extension ending you up with a not working userChrome.css.txt file. You can check the file type via the Properties in the right-click context menu. Safest is to create a new file in the text editor and make sure to select type "All files" when using "Save as" to save that file to disk. *http://kb.mozillazine.org/Editing_configuration/Troubleshooting

Người tạo câu hỏi

jscher: I deleted the userChrome.css file that I had placed in the storage/persistent/chrome file and created a new chrome folder at the top level.

I created a new userChrome.css file in the new chrome folder by right clicking my mouse and selecting New and text. This brought up a notepad. I copy/pasted the 2 lines of code onto the notepad and closed the notepad. When I closed the notepad, it gave me the option of saving what I had entered. It was saved as a text file (txn extension).

I did not have the option of using a File Save As "all files" which cor-el suggested I use.

If I use the text editor to add the wording into the userChrome.css file, how do I avoid having it saved as a text file (in Windows) when I close the notepad?

jscher: I deleted the userChrome.css file that I had placed in the storage/persistent/chrome file and created a new chrome folder at the top level. I created a new userChrome.css file in the new chrome folder by right clicking my mouse and selecting New and text. This brought up a notepad. I copy/pasted the 2 lines of code onto the notepad and closed the notepad. When I closed the notepad, it gave me the option of saving what I had entered. It was saved as a text file (txn extension). I did not have the option of using a File Save As "all files" which cor-el suggested I use. If I use the text editor to add the wording into the userChrome.css file, how do I avoid having it saved as a text file (in Windows) when I close the notepad?
jscher2000
  • Top 10 Contributor
8757 giải pháp 71649 câu trả lời
Được đăng

Hi swogden, once the file is created, you will need to rename it. If Windows does not show extensions on the file name (e.g., .css, .js, .docx are missing from file names) you can turn on display of extensions to work with file names more accurately. See: http://support.microsoft.com/kb/865219.

Hi swogden, once the file is created, you will need to rename it. If Windows does not show extensions on the file name (e.g., .css, .js, .docx are missing from file names) you can turn on display of extensions to work with file names more accurately. See: [http://support.microsoft.com/kb/865219].

Người tạo câu hỏi

I opened the userChrome.css -- which is shown as a text document in the details listing.

I found the File Save As link on the notepad and Saved the file as an "All Files" type.

The file still shows up as a text document.

When I copy/pasted the 2 lines, I noticed that the "1." did not copy. Is that notation necessary in the userChrome.css file? Why didn't it copy?

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

   main-window:not([chromehidden~="toolbar"]) { 
min-width: 200px;

}

I opened the userChrome.css -- which is shown as a text document in the details listing. I found the File Save As link on the notepad and Saved the file as an "All Files" type. The file still shows up as a text document. When I copy/pasted the 2 lines, I noticed that the "1." did not copy. Is that notation necessary in the userChrome.css file? Why didn't it copy? @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ main-window:not([chromehidden~="toolbar"]) { min-width: 200px; }
jscher2000
  • Top 10 Contributor
8757 giải pháp 71649 câu trả lời
Được đăng

Hi swogden, you should have two options:

(1) Rename the file in the file list. Right-click it and choose Rename. Delete the .txt extension and make sure the name is exactly userChrome.css (and the type shows as a CSS File).

(2) Save As. In the editor (Notepad?), use File > Save As. Place quotation marks around the name to avoid having .txt added at the end. In other words, use the name

"userChrome.css"

with the quotation marks. Windows will not include the quotation marks in the name, but adding them in the Save As dialog prevents Windows from adding .txt to the end of the name.

Regarding the 1., that is a byproduct of the wiki software used in this forum. If you start a line with # it turns into a number. The correct code starts with # and not 1. Please see: https://support.mozilla.org/en-US/que.../981035#answer-516739.

Hi swogden, you should have two options: (1) Rename the file in the file list. Right-click it and choose Rename. Delete the .txt extension and make sure the name is exactly userChrome.css (and the type shows as a CSS File). (2) Save As. In the editor (Notepad?), use File > Save As. Place quotation marks around the name to avoid having .txt added at the end. In other words, use the name "userChrome.css" with the quotation marks. Windows will not include the quotation marks in the name, but adding them in the Save As dialog prevents Windows from adding .txt to the end of the name. Regarding the 1., that is a byproduct of the wiki software used in this forum. If you start a line with # it turns into a number. The correct code starts with # and not 1. Please see: [https://support.mozilla.org/en-US/questions/981035#answer-516739].
cor-el
  • Top 10 Contributor
  • Moderator
17516 giải pháp 158398 câu trả lời
Được đăng

It is best not to create a text file on Windows because that will make Windows add a .txt file extension, but create a new file in the editor and make sure that "All files" is selected when you use "Save as" to save the file as userChrome.css.

It is best not to create a text file on Windows because that will make Windows add a .txt file extension, but create a new file in the editor and make sure that "All files" is selected when you use "Save as" to save the file as userChrome.css.

Người tạo câu hỏi

I have a chrome folder at the top level; I have a file with the title userChrome.css with a type of Cascading Style Sheet Document.

When I open the file this is what shows:

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

   #main-window:not([chromehidden~="toolbar"]) { 
min-width: 200px;

}

This still doesn't change the minimum size of my Firefox window. It's still 400px (5 in). I logged off and came back on and it's still 400px.

When I changed the extension of the userChrome.css file using the File Save As option using quote marks around the name of the file, a new file was created, but the name was userChrome without the extension. The type was Cascading Style Sheet Document.

I then renamed the file to userChrome.css to get the final configuration.

I deleted the userChrome.css file with the text type.

Please note that there are spaces at the start of the 2nd line (in front of the #main-window). Is this okay? Or should I eliminate the spaces? There are also spaces between the { } where the min-width is defined. Is that okay or should the spaces be eliminated?

Can I change the 200px to 100px?

Thanks for your patience.

I have a chrome folder at the top level; I have a file with the title userChrome.css with a type of Cascading Style Sheet Document. When I open the file this is what shows: @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ #main-window:not([chromehidden~="toolbar"]) { min-width: 200px; } This still doesn't change the minimum size of my Firefox window. It's still 400px (5 in). I logged off and came back on and it's still 400px. When I changed the extension of the userChrome.css file using the File Save As option using quote marks around the name of the file, a new file was created, but the name was userChrome without the extension. The type was Cascading Style Sheet Document. I then renamed the file to userChrome.css to get the final configuration. I deleted the userChrome.css file with the text type. Please note that there are spaces at the start of the 2nd line (in front of the #main-window). Is this okay? Or should I eliminate the spaces? There are also spaces between the { } where the min-width is defined. Is that okay or should the spaces be eliminated? Can I change the 200px to 100px? Thanks for your patience.
jscher2000
  • Top 10 Contributor
8757 giải pháp 71649 câu trả lời
Được đăng

Hi swogden, did you turn on the display of file extensions in Windows? You cannot work accurate with file naming until you turn that on. I have posted the link to Microsoft's support article twice.

Hi swogden, did you turn on the display of file extensions in Windows? You cannot work accurate with file naming until you turn that on. I have posted the link to Microsoft's support article twice.

Người tạo câu hỏi

No, I had not turned on the display of the file extensions in Windows. I was using the Detail option under the View icon.

After turning on the display of the file extension, I noticed that the name of my userChrome file was userChrome.css.css. So I renamed it userChrome.css. It now shows with that name (only one css). However, this did not result in a smaller window.

I read the article about troubleshooting (which Cor-el provided) and one of the first comments was to make sure that I was placing the chrome file in the right location:

"Check that you found the profile that is actually being used by the application, not some other profile, and not the application's installation directory."

The location of my chrome file is: C:\Documents and Settings\Sue\Application Data\Mozilla\Firefox\Profiles\x6drtjpe.default-1387561233609\chrome

Since this is the profile that came up when I clicked on the Show Folder, I assume it is the correct location.

There is another chrome folder at a lower level: \x6...\ storage\persistent\chrome. There are files and other folders within this chrome folder (but not a userChrome.css file) I assume the system uses the files within this chrome folder so I have left it alone.

At your direction, I created a new chrome folder at the first level in \x6.... but the system seems to be ignoring it. Are we putting the chrome folder in the right place? Or is it still for format/naming problem?

No, I had not turned on the display of the file extensions in Windows. I was using the Detail option under the View icon. After turning on the display of the file extension, I noticed that the name of my userChrome file was userChrome.css.css. So I renamed it userChrome.css. It now shows with that name (only one css). However, this did not result in a smaller window. I read the article about troubleshooting (which Cor-el provided) and one of the first comments was to make sure that I was placing the chrome file in the right location: "Check that you found the profile that is actually being used by the application, not some other profile, and not the application's installation directory." The location of my chrome file is: C:\Documents and Settings\Sue\Application Data\Mozilla\Firefox\Profiles\x6drtjpe.default-1387561233609\chrome Since this is the profile that came up when I clicked on the Show Folder, I assume it is the correct location. There is another chrome folder at a lower level: \x6...\ storage\persistent\chrome. There are files and other folders within this chrome folder (but not a userChrome.css file) I assume the system uses the files within this chrome folder so I have left it alone. At your direction, I created a new chrome folder at the first level in \x6.... but the system seems to be ignoring it. Are we putting the chrome folder in the right place? Or is it still for format/naming problem?
jscher2000
  • Top 10 Contributor
8757 giải pháp 71649 câu trả lời
Được đăng

Giải pháp được chọn

Hi swogden, I'm not sure what the x6 location represents. Perhaps it is an extension? I think you can ignore that one.

I hadn't paid attention to the rule itself before now since it was successful in the earlier thread, but now that I think about it... You often you need to add !important to a custom rule so that Firefox can resolve the conflict between the two directly conflicting rules in favor of your rule. Here's where it goes:

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#main-window:not([chromehidden~="toolbar"]) { 
  min-width: 200px !important;
} 

Does that help?

Hi swogden, I'm not sure what the x6 location represents. Perhaps it is an extension? I think you can ignore that one. I hadn't paid attention to the rule itself before now since it was successful in the earlier thread, but now that I think about it... You often you need to add !important to a custom rule so that Firefox can resolve the conflict between the two directly conflicting rules in favor of your rule. Here's where it goes: @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ #main-window:not([chromehidden~="toolbar"]) { min-width: 200px '''!important'''; } Does that help?

Người tạo câu hỏi

That worked. I had to restart my computer to have the change take effect. Thank you!

That worked. I had to restart my computer to have the change take effect. Thank you!