X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

A bunch of ads have been appearing in my firefox browser; when I view the same page with other browsers they do not appear.

Được đăng

I can provide a screenshot to help illustrate my problem. Every page I load has numerous ad boxes embedded into the page from "Ads by Browse to Save". Does anyone else have this problem? Is this something that firefox added to their browser or do I have a malware problem? (I see no option to post a screenshot of the problem, as is advised on the community help homepage. Maybe I will have that option once my question is posted.)

I can provide a screenshot to help illustrate my problem. Every page I load has numerous ad boxes embedded into the page from "Ads by Browse to Save". Does anyone else have this problem? Is this something that firefox added to their browser or do I have a malware problem? (I see no option to post a screenshot of the problem, as is advised on the community help homepage. Maybe I will have that option once my question is posted.)

Giải pháp được chọn

Hi franklr, many sites use Flash both for actual content as well as ads. It's hard to use much of the web if you have the Shockwave Flash plugin disabled.

In case there is an extension involved, did you also check this list:

orange Firefox button (or Tools menu) > Add-ons > Extensions category

Đọc câu trả lời này trong ngữ cảnh 6

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 11.6 r602
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • 5.1.20125.0
  • VLC media player Web Plugin 2.0.2
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.6
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Ứng dụng

  • Firefox 20.0.1
  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
  • URL hỗ trợ: http://support.mozilla.org/1/firefox/20.0.1/WINNT/en-US/

Tiện ích mở rộng

  • Browse22save 3.8 (ccw.2oeue@h-oahbhm.net)
  • SearchNewTab 1.0 (awzr@ncby.edu)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Đồ họa

  • adapterDescription: ATI Mobility Radeon HD 4200 Series
  • adapterDescription2:
  • adapterDeviceID: 0x9712
  • adapterDeviceID2:
  • adapterDrivers: atiu9p64 aticfx64 aticfx64 atiu9pag aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 256
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'10.6']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 3-15-2010
  • driverDate2:
  • driverVersion: 8.712.2.1000
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Mobility Radeon HD 4200 Series )
  • windowLayerManagerType: Direct3D 9

Thay đổi cài đặt

  • accessibility.blockautorefresh: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.startup.homepage: about:home
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0.1
  • gfx.blacklist.suggested-driver-version: 10.6
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1368139714
  • places.history.expiration.transient_current_max_pages: 100551
  • places.history.expiration.transient_optimal_database_size: 160880230
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.downloads: False
  • privacy.clearOnShutdown.formdata: False
  • privacy.clearOnShutdown.history: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.promptOnSanitize: False
  • privacy.sanitize.sanitizeOnShutdown: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

Linh tinh

  • Người dùng JS: Không
  • Có thể tiếp cận: Không
jscher2000
  • Top 10 Contributor
8700 giải pháp 71112 câu trả lời
Được đăng

Câu trả lời hữu ích

I think I see where it is from your system details:

orange Firefox button (or Tools menu) > Add-ons > Extensions category

If there is no Remove button, then it is an externally added extension and you may need to visit the Windows Control Panel to get rid of it. (But go ahead and at least disable it now.)

Does that work?

I think I see where it is from your system details: orange Firefox button (or Tools menu) > Add-ons > Extensions category If there is no Remove button, then it is an externally added extension and you may need to visit the Windows Control Panel to get rid of it. (But go ahead and at least disable it now.) Does that work?

Người tạo câu hỏi

That worked! I can't thank you enough. Never would have found that on my own. Problem totally solved.

That worked! I can't thank you enough. Never would have found that on my own. Problem totally solved.
jscher2000
  • Top 10 Contributor
8700 giải pháp 71112 câu trả lời
Được đăng

Câu trả lời hữu ích

Thank you for installing the Troubleshooting extension that gathered that information. In the old days, we would be asking you to poke around on your own and this made it much easier to resolve it quickly.

Thank you for installing the Troubleshooting extension that gathered that information. In the old days, we would be asking you to poke around on your own and this made it much easier to resolve it quickly.
franklr 0 giải pháp 2 câu trả lời
Được đăng

I have also been getting these unwanted ads. I went to "Add-ons manager" in Firefox where I found about ten add-ons. First I disabled all of the add-ons, and went to a page where the ads had appeared; The ads were now gone. Next, I enabled each add-on, one at a time, until the ads re-appeared on that page. I assumed that this last add-on was the culprit. I alternately disabled and enabled this add-on to verify that it was the only one that caused the ads to appear. The only add-on that caused the ads to appear in my Firefox browser ver. 22.0 was "Shockwave Flash ver. 11.7.700.224".

I have also been getting these unwanted ads. I went to "Add-ons manager" in Firefox where I found about ten add-ons. First I disabled all of the add-ons, and went to a page where the ads had appeared; The ads were now gone. Next, I enabled each add-on, one at a time, until the ads re-appeared on that page. I assumed that this last add-on was the culprit. I alternately disabled and enabled this add-on to verify that it was the only one that caused the ads to appear. The only add-on that caused the ads to appear in my Firefox browser ver. 22.0 was "Shockwave Flash ver. 11.7.700.224".
jscher2000
  • Top 10 Contributor
8700 giải pháp 71112 câu trả lời
Được đăng

Giải pháp được chọn

Hi franklr, many sites use Flash both for actual content as well as ads. It's hard to use much of the web if you have the Shockwave Flash plugin disabled.

In case there is an extension involved, did you also check this list:

orange Firefox button (or Tools menu) > Add-ons > Extensions category

Hi franklr, many sites use Flash both for actual content as well as ads. It's hard to use much of the web if you have the Shockwave Flash plugin disabled. In case there is an extension involved, did you also check this list: orange Firefox button (or Tools menu) > Add-ons > Extensions category
franklr 0 giải pháp 2 câu trả lời
Được đăng

Thanks for the suggestion. I had only checked for ads that appeared in news articles on BBC.com. I re-enabled Shock Wave flash, went to extensions and "disabled" all of them that gave me the option. The ads returned. I guess I'll just keep Flash disabled until I run up against an application that needs it.

-franklr

Thanks for the suggestion. I had only checked for ads that appeared in news articles on BBC.com. I re-enabled Shock Wave flash, went to extensions and "disabled" all of them that gave me the option. The ads returned. I guess I'll just keep Flash disabled until I run up against an application that needs it. -franklr
bettywest 0 giải pháp 1 câu trả lời
Được đăng

I tried the extension link from Toolbar and disabled one extension found there. Then I went to a website where these ads/boxes have been appearing and sure enough...there they are. they make one absolutely batty and I'm desperate to be rid of them! I'm going to try to post a screen shot of them. Red boxes are mine added in photo editing software. Disabling Shock wave flash did nothing to eliminate these irritating boxes.

I tried the extension link from Toolbar and disabled one extension found there. Then I went to a website where these ads/boxes have been appearing and sure enough...there they are. they make one absolutely batty and I'm desperate to be rid of them! I'm going to try to post a screen shot of them. Red boxes are mine added in photo editing software. Disabling Shock wave flash did nothing to eliminate these irritating boxes.

Được chỉnh sửa bởi bettywest vào

jscher2000
  • Top 10 Contributor
8700 giải pháp 71112 câu trả lời
Được đăng

Hi bettywest, you only have one extension -- or you only felt comfortable disabling one of them?


Could you also try Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?


Can you check that your proxy settings have not been changed? You can view those here:

(WIN) orange Firefox button (or Tools menu) > Options > Advanced
(MAC) Firefox menu > Preferences > Advanced

On the Network mini-tab, click the "Settings" button. If it's not currently set on No Proxy, try that.

Hi bettywest, you only have one extension -- or you only felt comfortable disabling one of them? ---- Could you also try Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using Help > Restart with Add-ons Disabled In the dialog, click "Start in Safe Mode" (''not'' Reset) Any difference? ---- Can you check that your proxy settings have not been changed? You can view those here: (WIN) orange Firefox button (or Tools menu) > Options > Advanced<br> (MAC) Firefox menu > Preferences > Advanced On the Network mini-tab, click the "Settings" button. If it's not currently set on No Proxy, try that.
encycster 0 giải pháp 2 câu trả lời
Được đăng

I have the same problem and has been trying to block it, and it slows down my browsing.

I have the same problem and has been trying to block it, and it slows down my browsing.
jscher2000
  • Top 10 Contributor
8700 giải pháp 71112 câu trả lời
Được đăng

Hi encycster, did you try Firefox's Safe Mode as described in an earlier post?

Hi encycster, did you try Firefox's Safe Mode as described in an earlier post?
encycster 0 giải pháp 2 câu trả lời
Được đăng

Jscher, I tried to do the other thing, initially the ads vanished, but as I tried to reopen the browser, these ads are really giving me frustrations. it slowed down my surfing time.

safe mode not yet, because safe mode also has other problems. i cannot risk my laptop to do that as my software

Jscher, I tried to do the other thing, initially the ads vanished, but as I tried to reopen the browser, these ads are really giving me frustrations. it slowed down my surfing time. safe mode not yet, because safe mode also has other problems. i cannot risk my laptop to do that as my software
cor-el
  • Top 10 Contributor
  • Moderator
17482 giải pháp 157984 câu trả lời
Được đăng

Not Windows Safe Mode is meant, but Firefox Safe Mode.

Firefox Safe Mode is meant for troubleshooting purposes and disables all extensions and disables a few other features as well.

This won't affect your computer.

You can use one of these to start Firefox in Safe Mode:

  • On Windows, hold down the Shift key while starting Firefox with a double-click on the Firefox desktop shortcut
  • On Mac, hold down the Options key while starting Firefox
  • Help > Restart with Add-ons Disabled
Not Windows Safe Mode is meant, but Firefox Safe Mode. Firefox Safe Mode is meant for troubleshooting purposes and disables all extensions and disables a few other features as well.<br /> *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes This won't affect your computer. You can use one of these to start Firefox in <u>Safe Mode</u>: *On Windows, hold down the Shift key while starting Firefox with a double-click on the Firefox desktop shortcut *On Mac, hold down the Options key while starting Firefox *Help > Restart with Add-ons Disabled *https://support.mozilla.org/kb/Safe+Mode