Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox 108.0 Socks5 proxy has stopped working

  • 1 trả lời
  • 0 gặp vấn đề này
  • 2 lượt xem
  • Trả lời mới nhất được viết bởi Alan.Griffiths.2013

more options

Hi,

I have for some time (over a year) been using a remote server as a SOCKS5 proxy for Firefox so I can bypass my local ISPs filtering.

The proxy connection is setup using an SSH tunnel like this:

ssh -D 8080 -q -C -N -f root@<remote server> That sets up port 8080 on my local machine to listen for connections which will be forwarded to ssh on the remote server acts as aSOCKS4/SOCKS5 proxy.

    -D [bind_address:]port
            Specifies a local “dynamic” application-level port forwarding.  This works by allocating a socket
            to listen to port on the local side, optionally bound to the specified bind_address.  Whenever a
            connection is made to this port, the connection is forwarded over the secure channel, and the
            application protocol is then used to determine where to connect to from the remote machine. 
            Currently the SOCKS4 and SOCKS5 protocols are supported, and ssh will act as a SOCKS
            server. 

Tried it today and it doesn't work any more. I've attached a picture of my Firefox Proxy settings and a picture of the Firefox version I am currently running. plus a picture of the error I get when I try to access the BBC website using Firefox via the proxy.

I've tried all combinations of "Proxy DNS when using SOCKS v5" and "Enable DNS over HTTPS" with no effect. I've also tried it from "Troubleshooting Mode" and the same thing happens.

I also tried accessing https://www.bbc.co.uk through the same proxy by using the command:

curl --silent --location --socks5 localhost:8080 https://www.bbc.co.uk

and it worked perfectly.

I'd be grateful if you could have a look at it and let me know what is wrong.

Thanks, Alan

Hi, I have for some time (over a year) been using a remote server as a SOCKS5 proxy for Firefox so I can bypass my local ISPs filtering. The proxy connection is setup using an SSH tunnel like this: '''ssh -D 8080 -q -C -N -f root@<remote server> ''' That sets up port 8080 on my local machine to listen for connections which will be forwarded to ssh on the remote server acts as aSOCKS4/SOCKS5 proxy. -D [bind_address:]port Specifies a local “dynamic” application-level port forwarding. This works by allocating a socket to listen to port on the local side, optionally bound to the specified bind_address. Whenever a connection is made to this port, the connection is forwarded over the secure channel, and the application protocol is then used to determine where to connect to from the remote machine. Currently the SOCKS4 and SOCKS5 protocols are supported, and ssh will act as a SOCKS server. Tried it today and it doesn't work any more. I've attached a picture of my Firefox Proxy settings and a picture of the Firefox version I am currently running. plus a picture of the error I get when I try to access the BBC website using Firefox via the proxy. I've tried all combinations of "Proxy DNS when using SOCKS v5" and "Enable DNS over HTTPS" with no effect. I've also tried it from "Troubleshooting Mode" and the same thing happens. I also tried accessing https://www.bbc.co.uk through the same proxy by using the command: '''curl --silent --location --socks5 localhost:8080 https://www.bbc.co.uk''' and it worked perfectly. I'd be grateful if you could have a look at it and let me know what is wrong. Thanks, Alan
Đính kèm ảnh chụp màn hình

Giải pháp được chọn

Panic over. Today's Windows Update reboot seems to have fixed the issue for me. Sorry to have wasted anyone's time.

Regards, Alan

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (1)

more options

Giải pháp được chọn

Panic over. Today's Windows Update reboot seems to have fixed the issue for me. Sorry to have wasted anyone's time.

Regards, Alan