On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

igHome and Google Calendar

  • 4 trả lời
  • 1 gặp vấn đề này
  • 36 lượt xem
  • Trả lời mới nhất được viết bởi jterps52

more options

I am using the latest Firefox version 102.0 and I have igHome set as my home page. Yesterday the Google Calendar Gadget would no longer display the calendar but would display this message:

Firefox Can’t Open This Page To protect your security, accountsgooglecom will not allow Firefox to display the page if another site has embedded it. To see this page, you need to open it in a new window.

If I click on the “Open Site in New Window” button it does open the calendar. (See attached screenshot.) I have tried login out and back into igHome and my Google account but it doesn’t fix the issue. This is happening on both my laptop and desktop computers running Windows 10 Home. All Windows updates are up to date. I opened Firefox in Troubleshooting Mode and the calendar still does not show. When I use the Google Chrome browser with the same igHome home page the Calendar works fine. Is this something Firefox can fix, or do I need to contact Google?

I am using the latest Firefox version 102.0 and I have igHome set as my home page. Yesterday the Google Calendar Gadget would no longer display the calendar but would display this message: ''Firefox Can’t Open This Page To protect your security, accountsgooglecom will not allow Firefox to display the page if another site has embedded it. To see this page, you need to open it in a new window.'' If I click on the “Open Site in New Window” button it does open the calendar. (See attached screenshot.) I have tried login out and back into igHome and my Google account but it doesn’t fix the issue. This is happening on both my laptop and desktop computers running Windows 10 Home. All Windows updates are up to date. I opened Firefox in Troubleshooting Mode and the calendar still does not show. When I use the Google Chrome browser with the same igHome home page the Calendar works fine. Is this something Firefox can fix, or do I need to contact Google?
Đính kèm ảnh chụp màn hình

Được chỉnh sửa bởi jterps52 vào

Giải pháp được chọn

This could be about third party cookie partitioning (cookie isolation) that prevents the Google Calendar page from getting the Google session ID cookies casing you to get the Google account login page.

You can try to set network.cookie.cookieBehavior = 4 to disable partitioning if this pref is currently set to 5 to see if that has effect. See "How do I know if the site breakage is caused by Total Cookie Protection?":

You may have to clear existing cookies for the Google account.

You can open the about:config page via the location/address bar. Clear cookies the button to "Accept the Risk and Continue".

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (4)

more options

This happens if a website prohibits via CSP rules of otherwise via a X-FRAME-OPTIONS header in the HTTP response headers to be embedded on an other webpage like happens if you include this page on your igHome page. Google might be more forgiving in such a case and allow this or maybe it uses another link.

Hữu ích?

more options

Thank you cor-el for your response but all that information is way over my head. Is there a way that I can fix this so that I can see the Google Calendar again in my igHome window on Firefox?

Hữu ích?

more options

Giải pháp được chọn

This could be about third party cookie partitioning (cookie isolation) that prevents the Google Calendar page from getting the Google session ID cookies casing you to get the Google account login page.

You can try to set network.cookie.cookieBehavior = 4 to disable partitioning if this pref is currently set to 5 to see if that has effect. See "How do I know if the site breakage is caused by Total Cookie Protection?":

You may have to clear existing cookies for the Google account.

You can open the about:config page via the location/address bar. Clear cookies the button to "Accept the Risk and Continue".

Được chỉnh sửa bởi cor-el vào

Hữu ích?

more options

cor-el. Thank you so much for your help. I followed the instructions in the first link above and set my Total Cookie Protection to "Custom/Cross-Site Tracking Cookies" and it fixed the problem. I can now see the Google Calendar again.

Here are the instructions I followed.

Can I disable Total Cookie Protection without disabling Enhanced Tracking Protection?

Yes. To disable Total Cookie Protection follow these steps:

   Select the Custom setting under your Enhanced Tracking Protection settings.
   Set the drop-down menu next to Cookies to Cross-Site Tracking Cookies. 

This will disable Total Cookie Protection but keep Enhanced Tracking Protection enabled.

Được chỉnh sửa bởi jterps52 vào

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.