Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Light theme but dark menus/pulldowns FF 100.0.2

more options

For the last several FF versions, although I choose a light theme, the pull downs/menus always wind up dark with white text. It also shows up when I am editing options in FF itself. How do I stop this? I want a light background with black/dark text.

For the last several FF versions, although I choose a light theme, the pull downs/menus always wind up dark with white text. It also shows up when I am editing options in FF itself. How do I stop this? I want a light background with black/dark text.
Đính kèm ảnh chụp màn hình

Tất cả các câu trả lời (12)

more options

You can check the website appearance setting.

  • Settings -> General -> Language and Appearance -> Website Appearance

You can select a theme that has dark text on the tabs (toolbars) if you currently use a theme with light text to prevent Firefox from using a dark background for webpages.

You can change this pref on the about:config page from 3 to 2 to revert to the Firefox 94 behavior regarding to prefer dark or light background for webpages. You can use 0 (dark) or 1 (light) to set a specific state.

  • about:config => layout.css.prefers-color-scheme.content-override [dark:0, light:1, system:2, browser:3]

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Hữu ích?

more options

As you can see from the screen shots, I selected a light theme, but wind up with dark background/light text on the pull down menus, etc. So I've already picked what I want, but FF is not giving it to me.

Unfortunately, I don't understand what you are telling me in the second instance. I'm just a user, not a software expert.

All I want is to have a light theme with dark text. I don't want the reverse to keep happening.

Hữu ích?

more options

Hello, sorry for the inconvenience caused. This can be solved by clicking on the 'hamburger' menu at the top right corner and then selecting "Add-ons and themes" or simply pressing [ Ctrl + Shift + A ] on the keyboard. The "Add-ons Manager" tab opens and then select "Themes" at the left section. You should now see the Light theme on the right hand side. Click enable and you are good to go. You now have a light theme with dark text on your menus.

Hope this was able to solve your issue.

Hữu ích?

more options

bmd016, if you look in my screenshots, you'll see that I had already chosen a light theme. In fact, I've disabled & re-enabled it several times hoping that it would solve the issue. It doesn't.

Hữu ích?

more options

submarinerr, you need to go to Add-ons to do that not under the preferences section

Hữu ích?

more options

Yes, it was already selected in the Theme in the Add on Section. (See attached screen shot.)

It will show up the same in both areas.

Hữu ích?

more options

Still looking for an answer to this issue.

Hữu ích?

more options

This issue persists in the current version of FF: 103.

Is there no help on this?

Hữu ích?

more options

submarinerr said

Yes, it was already selected in the Theme in the Add on Section. (See attached screen shot.) It will show up the same in both areas.

submarinerr said

Still looking for an answer to this issue.

Thank you for your understanding and my apologies for any inconvenience this may have caused you. Fortunately, this can be fixed by clicking on the hamburger menu in the top right corner of the screen, and then selecting "Add-ons and themes" or by pressing [ Ctrl + Shift + A ] on the keyboard to make this happen. Upon opening the "Add-ons Manager" tab, select "Themes" at the left section of the window. Right now, you should be able to see the Light theme on the right hand side of the screen. Simply click on the enable button and you'll be good to go. In addition to having a light theme on your menu[s], you also have a dark theme on your background.

Được chỉnh sửa bởi cor-el vào

Hữu ích?

more options

I have already tried this & it doesn't work. Please read the ENTIRE thread.

Được chỉnh sửa bởi submarinerr vào

Hữu ích?

more options

cor-el said

You can select a theme that has dark text on the tabs (toolbars) if you currently use a theme with light text to prevent Firefox from using a dark background for webpages. You can change this pref on the about:config page from 3 to 2 to revert to the Firefox 94 behavior regarding to prefer dark or light background for webpages. You can use 0 (dark) or 1 (light) to set a specific state.
  • about:config => layout.css.prefers-color-scheme.content-override [dark:0, light:1, system:2, browser:3]
You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Let me try to re-word this for you.

In the address bar, enter about:config and press Enter. Accept the warning and click "I accept the risk!" to continue. In the search bar at the top of the page enter layout.css.prefers-color-scheme.content-override At the right end of that entry is an Edit button Click that and the value in the center will highlight in a text box Enter a 1 and click the green check box You will see the change take effect right away.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

Hữu ích?

more options

Oops -

Just close the tab when you are finished.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.