Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

How to Disable "Did You Mean to Go To http:?"

more options

I use the firefox URL bar as a search bar, however recently when I use it this way, firefox automatically gives a notification asking "did you mean to go to http://example/?". I'm unsure if/how I can disable this, as I find it annoying and unnecessary.

I use the firefox URL bar as a search bar, however recently when I use it this way, firefox automatically gives a notification asking "did you mean to go to http://example/?". I'm unsure if/how I can disable this, as I find it annoying and unnecessary.
Đính kèm ảnh chụp màn hình

Giải pháp được chọn

You can try to set this pref to '0' on the about:config page/

  • about:config => browser.urlbar.dnsResolveSingleWordsAfterSearch = 0

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

Đọc câu trả lời này trong ngữ cảnh 👍 6

Tất cả các câu trả lời (2)

more options

Giải pháp được chọn

You can try to set this pref to '0' on the about:config page/

  • about:config => browser.urlbar.dnsResolveSingleWordsAfterSearch = 0

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

more options

For more background, when you submit a single word search, Firefox follows that with a DNS lookup in the background in case, for example, pasta (or whatever) is the name of a server on your local network.

Some DNS services dishonestly tell Firefox there is a server by that name so they can show a page of paid ad links. cor-el gave you the fastest workaround. Another option is to look at that links page and see whether you can disable this "service" completely.