Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Certain websites appear in some sort of "dark mode" when dark themes are enabled

  • 9 trả lời
  • 5 gặp vấn đề này
  • 1368 lượt xem
  • Trả lời mới nhất được viết bởi Andrew Nefedkin

more options

I've been using Elijah Lopez's Matte Black (Red) theme for months. Recently, I think because I added the ClearURLs extension or some other change, certain websites enter some sort of "dark mode" when accessed.

Websites that do this include Twitter, an independent blog, and Youtube.

The website appears normally with the default light theme enabled. In the second photo, the website appears in the "dark mode" with the black Firefox theme enabled.

I have deleted cookies and cache, reinstalled Firefox, and reinstalled Extensions. I think this problem only occurs with dark themes, and nothing else. The moment I change to dark theme, the problem comes back. It is strange because the dark theme was working just fine for months until recently.

How can I keep the dark theme, preferably the same Elijah Lopez's dark theme, while using websites normally and not in this weird "dark theme" style adaptation?

I've been using Elijah Lopez's Matte Black (Red) theme for months. Recently, I think because I added the ClearURLs extension or some other change, certain websites enter some sort of "dark mode" when accessed. Websites that do this include Twitter, an independent blog, and Youtube. The website appears normally with the default light theme enabled. In the second photo, the website appears in the "dark mode" with the black Firefox theme enabled. I have deleted cookies and cache, reinstalled Firefox, and reinstalled Extensions. I think this problem only occurs with dark themes, and nothing else. The moment I change to dark theme, the problem comes back. It is strange because the dark theme was working just fine for months until recently. How can I keep the dark theme, preferably the same Elijah Lopez's dark theme, while using websites normally and not in this weird "dark theme" style adaptation?

Giải pháp được chọn

If you want to have different color scheme preference for FF UI and sites, you can change "layout.css.prefers-color-scheme.content-override" in 'about:config' to:

  Dark (0), light (1), system (2) or browser (3)

For 94 default was 2, in version 95 it is 3. You can either fallback to 2 or just use 0/1 to change color preference for sites.

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator.]

Đọc câu trả lời này trong ngữ cảnh 👍 8

Tất cả các câu trả lời (9)

more options

Giải pháp được chọn

If you want to have different color scheme preference for FF UI and sites, you can change "layout.css.prefers-color-scheme.content-override" in 'about:config' to:

  Dark (0), light (1), system (2) or browser (3)

For 94 default was 2, in version 95 it is 3. You can either fallback to 2 or just use 0/1 to change color preference for sites.

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator.]

Được chỉnh sửa bởi Chris Ilias vào

Hữu ích?

more options

Thank you so much, this was driving me crazy

Hữu ích?

more options

TyDraniu, thanks a lot!

Hữu ích?

more options

Changing the option, from 3 to 1 reverted the web pages, back to where it was, prior to the update to v95.

Hữu ích?

more options

Thanks so much! Glad I am finally rid of that dark mode and pages I couldn't read!

Hữu ích?

more options

Changing the option from 3-1 still did not work for me to get rid of this dark mode. I have tried all the sugeestions - isn't there anyone who can help??

Hữu ích?

more options
Somehow, changing this option from 3 to 2 or 1 don't work as expected anymore which many reports since few days when this happend. It changes background of sites, but contex menus and tabs are still in dark theme. What to do?

TyDraniu said

If you want to have different color scheme preference for FF UI and sites, you can change "layout.css.prefers-color-scheme.content-override" in 'about:config' to: Dark (0), light (1), system (2) or browser (3) For 94 default was 2, in version 95 it is 3. You can either fallback to 2 or just use 0/1 to change color preference for sites. WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect. [Warning added by moderator.]

Được chỉnh sửa bởi Hedrox vào

Hữu ích?

more options

Hedrox said

Somehow, changing this option from 3 to 2 or 1 don't work as expected anymore which many reports since few days when this happend. It changes background of sites, but contex menus and tabs are still in dark theme. What to do?

Looks like you've chosen a dark theme. If you see white text on your tab bar, theme is dark. Please switch to a light theme to have bright context menus.

See Use themes to change the look of Firefox or Built-in themes in Firefox - alternative to complete themes to learn more about themes.

Hữu ích?

more options

TyDraniu сказал(а)

If you want to have different color scheme preference for FF UI and sites, you can change "layout.css.prefers-color-scheme.content-override" in 'about:config' to: Dark (0), light (1), system (2) or browser (3) For 94 default was 2, in version 95 it is 3. You can either fallback to 2 or just use 0/1 to change color preference for sites.

Wow, this really helps!!! What a pity to suddenly have a change in default colors even without an UI option to customize!

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.