Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Creating a Desktop Shortcut on Windows 10 that opens in New Window

  • 5 trả lời
  • 1 gặp vấn đề này
  • 105 lượt xem
  • Trả lời mới nhất được viết bởi hikmetbaturalp

more options

I want to create a desktop shortcut on Windows 10 that opens a URL in new window.

I saw [https://support.mozilla.org/en-US/que.../1287367|this] question but it is not working on my computer.

In step 1, I successfully created a desktop shortcut using [https://support.mozilla.org/en-US/kb/create-desktop-shortcut-website|this] guide.

When I right click the desktop shortcut, I see the attached screenshot. (I added "-new-window" at the end but it did not work, neither adding to the beginning of URL work)

What can I do?

I want to create a desktop shortcut on Windows 10 that opens a URL in new window. I saw [[https://support.mozilla.org/en-US/questions/1287367|this]] question but it is not working on my computer. In step 1, I successfully created a desktop shortcut using [[https://support.mozilla.org/en-US/kb/create-desktop-shortcut-website|this]] guide. When I right click the desktop shortcut, I see the attached screenshot. (I added "-new-window" at the end but it did not work, neither adding to the beginning of URL work) What can I do?
Đính kèm ảnh chụp màn hình

Giải pháp được chọn

You would have to use a copy of the Firefox desktop shortcut instead of a 'simple' internet shortcut if you want to add extra parameters.
An internet shortcut only specify the URL.
If you use a Firefox shortcut then you can add the URL and extra parameters to the target (command) line.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (5)

more options

try just -newwindow at the end like you have it.

more options

Also make sure you have quotes around the URL, then outside the quotes, put -newwindow -- I see that the other question you linked says "-new-window" so it might be Correct but the lack of quotes around the URL is causing it to not work, so try a couple different combinations

Được chỉnh sửa bởi Eve vào

more options

Giải pháp được chọn

You would have to use a copy of the Firefox desktop shortcut instead of a 'simple' internet shortcut if you want to add extra parameters.
An internet shortcut only specify the URL.
If you use a Firefox shortcut then you can add the URL and extra parameters to the target (command) line.

more options

Thank you for the reply.

In the "URL:" box, I tried writing

https://music.youtube.com/ "-new-window" https://music.youtube.com/ "-newwindow" https://music.youtube.com/ -new-window https://music.youtube.com/ -newwindow

All gave equal results, opening the correct URL in a new tab instead of a new window.


When I put quotes around the URL and write "https://music.youtube.com/" -new-window

Windows automatically converts the text in the "URL:" box to: http://"https://music.youtube.com/" -new-window

In sum, none of these work. This opens a new window but not the desired URL.

more options

cor-el said

You would have to use a copy of the Firefox desktop shortcut instead of a 'simple' internet shortcut if you want to add extra parameters.
An internet shortcut only specify the URL.
If you use a Firefox shortcut then you can add the URL and extra parameters to the target (command) line.

This solved the problem. Thanks!

Since I don't have a desktop shortcut, I go to

"C:\Program Files\Mozilla Firefox"

and create a shortcut from "firefox.exe" to the desktop. In the Target box, I wrote:

"C:\Program Files\Mozilla Firefox\firefox.exe" -new-window https://music.youtube.com/

and it worked.

The only downside of this is not having the icon of the target website, instead shortcut have the Firefox icon (which can be changeable with some effort).