Tìm kiếm hỗ trợ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Change Addon Popup Zoom Level

  • 8 trả lời
  • 1 gặp vấn đề này
  • 30 lượt xem
  • Trả lời mới nhất được viết bởi helium6072

more options

I have a high DPI monitor, and I've set the Windows UI scaling factor to 125%. However, at 125% the web pages appears a bit too zoomed in (images and fonts too large) for me, so I set the default zoom level to 80% in the settings page. But apparently add-on popups (e.g. uBlock origin) doesn't use the default zoom level so they are comically large compared to web pages. I tried setting layout.css.devPixelsPerPx to 1, but then Firefox UI became too small. I wonder if I can set the zoom level for add-on popups to 80% without changing the size of the browser UI?

Giải pháp được chọn

You may want to file a new bug if you don't find one on file.

When I try to hack the problem with custom style rules I can't figure out how to apply counter-scaling just to the drop-down panels. I can inject a rule into the popup window to scale down its contents, and that is mostly successful, but the box is now oversized. I didn't find a good overall solution. Hopefully someone on r/FirefoxCSS has a better idea for a short term fix.


Rule for userContent.css file:

/*** BUGGY: Proportionally shrink content of extension popups ***/
@-moz-document url-prefix(moz-extension){
  html {
    transform: scale(0.8,0.8);
    transform-origin: 0 0;
  }
}
Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (8)

more options

Follow these steps

In order to add a custom zoom level,

(a) simply open the toolbar panel UI, 

(b) change the zoom slider to adjust the magnifying scale, (c) then change the other two sliders for X and Y positions, (d) and finally click on the save button. The settings will be saved for the page you selected (the URL for each page will be automatically added to the popup UI once you open it, however you can change it to your desired value).

Note: in order to report bugs, please visit add-on's homepage and fill the bug report form.

Hữu ích?

more options

yogyta kalwar said

Follow these steps In order to add a custom zoom level, (a) simply open the toolbar panel UI, (b) change the zoom slider to adjust the magnifying scale, (c) then change the other two sliders for X and Y positions, (d) and finally click on the save button. The settings will be saved for the page you selected (the URL for each page will be automatically added to the popup UI once you open it, however you can change it to your desired value). Note: in order to report bugs, please visit add-on's homepage and fill the bug report form.

Hi, I think you are referring to this add-on? I'm not confused about using that particular add-on (in fact I don't have it installed). I wish to change the zoom level for add-on popups in general, such as the HTTPs Everywhere popup. Are you suggesting I should try the Custom Page Zoom add-on?

Được chỉnh sửa bởi helium6072 vào

Hữu ích?

more options

Page from extensions use the moz-extension:// and the builtin zoom probably only applies to https:// and http://.
You would need code in userContent.css to handle moz-extension:// and other builtin about pages.


Try to ask advice at this forum.

Hữu ích?

more options

On a regular old Full HD monitor, the extension popup text size is very similar to the text size in toolbars. But on yours it is more like double that?

Does it make any difference if you hardcode the following setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the in-page search box, type or paste devp and pause while the list is filtered

(3) The layout.css.devPixelsPerPx usually has a value of -1 and follows your system Text Size setting, which you said is 125%. Double-click the preference to open an editing field, and change the value to 1.25 to hardcode 125%. Click the blue checkmark or press Enter to save the change.

If necessary to reset, there should be a button at the right end of the row that looks like a "back" arrow.

Any difference?

Hữu ích?

more options

jscher2000 said

On a regular old Full HD monitor, the extension popup text size is very similar to the text size in toolbars. But on yours it is more like double that? Does it make any difference if you hardcode the following setting: (1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful. (2) In the in-page search box, type or paste devp and pause while the list is filtered (3) The layout.css.devPixelsPerPx usually has a value of -1 and follows your system Text Size setting, which you said is 125%. Double-click the preference to open an editing field, and change the value to 1.25 to hardcode 125%. Click the blue checkmark or press Enter to save the change. If necessary to reset, there should be a button at the right end of the row that looks like a "back" arrow. Any difference?

Hi, I want my browser UI at 125% but regular website text at 100%. I set my Windows scaling to 125% in display settings (that sets my browser UI to 125%) and in chrome I can just set default zoom level to 80% and that makes the website text and popups 1.25 * 80% = 100% again. The same works for Firefox, except for the add-on popups. The problem is those popups do not respect the default zoom level (80%). When I force them to show in tabs using the moz-extension:// urls, they are correctly sized (80%), but when in side bar or in popups, they are still 100% (with 1.25 scaling making them 125% in effect).

Since I've set UI scaling to 125% in Win10 OS settings, setting layout.css.devPixelsPerPx to 1.25 does not do anything. if I set layout.css.devPixelsPerPx to 1, then the browser UI is too small (again I want my browser UI at 125% but regular website text & popups at 100%). I guess my use case is a wired one. Hopefully I made my problem clear :)

Được chỉnh sửa bởi helium6072 vào

Hữu ích?

more options

Giải pháp được chọn

You may want to file a new bug if you don't find one on file.

When I try to hack the problem with custom style rules I can't figure out how to apply counter-scaling just to the drop-down panels. I can inject a rule into the popup window to scale down its contents, and that is mostly successful, but the box is now oversized. I didn't find a good overall solution. Hopefully someone on r/FirefoxCSS has a better idea for a short term fix.


Rule for userContent.css file:

/*** BUGGY: Proportionally shrink content of extension popups ***/
@-moz-document url-prefix(moz-extension){
  html {
    transform: scale(0.8,0.8);
    transform-origin: 0 0;
  }
}

Hữu ích?

more options

Hữu ích?

more options

jscher2000 said

You may want to file a new bug if you don't find one on file. When I try to hack the problem with custom style rules I can't figure out how to apply counter-scaling just to the drop-down panels. I can inject a rule into the popup window to scale down its contents, and that is mostly successful, but the box is now oversized. I didn't find a good overall solution. Hopefully someone on r/FirefoxCSS has a better idea for a short term fix.

Rule for userContent.css file:

/*** BUGGY: Proportionally shrink content of extension popups ***/
@-moz-document url-prefix(moz-extension){
  html {
    transform: scale(0.8,0.8);
    transform-origin: 0 0;
  }
}

Thanks for your css solution! I guess I'll file a bug report when I have time.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.