Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Add-Ons removed from Toolbar (& stop working) when I ask Firefox to Never Remember History

  • 7 trả lời
  • 1 gặp vấn đề này
  • 34 lượt xem
  • Trả lời mới nhất được viết bởi k.gerstenhaber

more options

As the Title suggests.

My Add-Ons are all removed from my Toolbar and stop functioning whenever I set my History settings to "Never Remember History."

I have tried uninstalling and re-installing the Add-On's, refreshing Firefox, uninstalling/reinstalling Firefox. But none of this works.

I want to be able to use my Add-On's AND have Firefox not remember my history. It used to work before, but now it just won't let me.

Any suggestions?

Giải pháp được chọn

You need to make sure you allow those extensions to run in Private Browsing mode via their details page on about:addons (Run in Private Windows), otherwise they will be hidden.
You will notice a purple mask to indicate that the extension is enabled in PB mode.

Đọc câu trả lời này trong ngữ cảnh 👍 2

Tất cả các câu trả lời (7)

more options

Anyone? :/

Hữu ích?

more options

Removing history should not affect your add-ons.

It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":


You will have to approve the updating one last time.

Hữu ích?

more options

Giải pháp được chọn

You need to make sure you allow those extensions to run in Private Browsing mode via their details page on about:addons (Run in Private Windows), otherwise they will be hidden.
You will notice a purple mask to indicate that the extension is enabled in PB mode.

Được chỉnh sửa bởi cor-el vào

Hữu ích?

more options

Thankyou so much to you both! I shall try both ideas and see what works and then let you know what happens!

Sorry for the late reply, it's been quite a busy few days for me.

Hữu ích?

more options

Hello,

In Never Remember History, You will always face this problem unless you go to manage add ons and enable it to run in private window.

However, to fix this, You can try this:-

  • Type about:preferences#privacy in URL bar and press enter.
  • In History option, Choose Custom Settings for Privacy.
  • Uncheck Always use Private Browsing Mode.
  • And Check all the three options below.

It will Surely fix your problem. Thank You.

Hữu ích?

more options

To fix the problem I had was to in fact to allow the Add-Ons to run in Private Mode, as mentioned above by others.

For those who may have this problem, this is how you fix it!

  1. Go to Add-Ons
  2. You will see a list of the Add-Ons you have, next to them there is a button with three dots (...)
  3. Click it, then click Manage
  4. Scroll to the bottom of the page to where it says Run in Private Windows, and then click the circle that says Allow.
  5. Now your Add-Ons will (or SHOULD) function even when you History is set to never be remembered!

Thanks everyone for your support, and I hope this helps anyone else in future with the same problem! ^_^

Được chỉnh sửa bởi penndumonium vào

Hữu ích?

more options

I was going in circles trying to resolve this and am so grateful to find this post. Your explanation worked perfectly. Add-on's immediately reappeared.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.