X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Firefox asks for master password on startup

Được đăng

For the last few months (starting with an upgrade to new version), Firefox has asked for my master password immediately upon startup (or as soon as startup is complete), regardless of what web page I am viewing. This does not seem right; it should prompt for master password only when a site that I visit requires a site password.

Another recent post on the support forums advises going to security settings, and disabling the option for "use master password." That's not right, either.

For the last few months (starting with an upgrade to new version), Firefox has asked for my master password immediately upon startup (or as soon as startup is complete), regardless of what web page I am viewing. This does not seem right; it should prompt for master password only when a site that I visit requires a site password. Another recent post on the support forums advises going to security settings, and disabling the option for "use master password." That's not right, either.

Giải pháp được chọn

If you use Sync then you can see the email address used for the Firefox account at the top of the "3-bar" Firefox menu button drop-down list.

This could possibly also happen if the startup page(s) include a page you have saved a login username and password.

Are you reopening pages from the previous session (Restore Previous Session)?

  • Options/Preferences -> General -> Startup
Đọc câu trả lời này trong ngữ cảnh 0

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 18.0 r0

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

Thông tin chi tiết

FFus3r 50 giải pháp 757 câu trả lời
Được đăng

try to go to Options > Privacy & Security then uncheck Remember logins and passwords for websites.

try to go to '''Options''' > '''Privacy & Security''' then uncheck '''Remember logins and passwords for websites'''.
cor-el
  • Top 10 Contributor
  • Moderator
17470 giải pháp 157874 câu trả lời
Được đăng

Are you using Sync?

Sync stores its credentials in the Password Manager and you need to enter the master password to make it possible for Sync to login.

Are you using Sync? Sync stores its credentials in the Password Manager and you need to enter the master password to make it possible for Sync to login.

Người tạo câu hỏi

As far as I know, I'm not using Sync.

As far as I know, I'm not using Sync.
cor-el
  • Top 10 Contributor
  • Moderator
17470 giải pháp 157874 câu trả lời
Được đăng

Giải pháp được chọn

If you use Sync then you can see the email address used for the Firefox account at the top of the "3-bar" Firefox menu button drop-down list.

This could possibly also happen if the startup page(s) include a page you have saved a login username and password.

Are you reopening pages from the previous session (Restore Previous Session)?

  • Options/Preferences -> General -> Startup
If you use Sync then you can see the email address used for the Firefox account at the top of the "3-bar" Firefox menu button drop-down list. This could possibly also happen if the startup page(s) include a page you have saved a login username and password. Are you reopening pages from the previous session (Restore Previous Session)? *Options/Preferences -> General -> Startup

Người tạo câu hỏi

I think cor-el has the right explanation. Although I don't use Sync, I do save pages from the previous session, and my firefox user name appears on the "3-bar" menu (thanks, I was wondering what that thing is called).

So, I just visited every tab (every saved page) in my browser, and none of them are prompting me for a site login. So, firefox should not be asking for my master password at startup time (and it frequently, but not always does). It is a security risk to unlock the password vault when it isn't necessary.

Yes, I can just "cancel" the prompt for master password, but I shouldn't have to.

I think cor-el has the right explanation. Although I don't use Sync, I do save pages from the previous session, and my firefox user name appears on the "3-bar" menu (thanks, I was wondering what that thing is called). So, I just visited every tab (every saved page) in my browser, and none of them are prompting me for a site login. So, firefox should not be asking for my master password at startup time (and it frequently, but not always does). It is a security risk to unlock the password vault when it isn't necessary. Yes, I can just "cancel" the prompt for master password, but I shouldn't have to.
cor-el
  • Top 10 Contributor
  • Moderator
17470 giải pháp 157874 câu trả lời
Được đăng

You say that you see an email address in the "3-bar" Firefox menu button drop-down list.

Did you check "Options/Preferences -> Firefox Account"?

You say that you see an email address in the "3-bar" Firefox menu button drop-down list. Did you check "Options/Preferences -> Firefox Account"?

Người tạo câu hỏi

Okay, I looked under "Options -> Firefox Account." I'm not sure what I should change there. I have only one connected device (my Windows 7 computer), and the following items are checked under Sync Settings: bookmarks open tabs logins add-ons options

Okay, I looked under "Options -> Firefox Account." I'm not sure what I should change there. I have only one connected device (my Windows 7 computer), and the following items are checked under Sync Settings: bookmarks open tabs logins add-ons options
cor-el
  • Top 10 Contributor
  • Moderator
17470 giải pháp 157874 câu trả lời
Được đăng

Câu trả lời hữu ích

If you use and want to continue using Sync then you will have to accept that Firefox will ask for the master password on each startup. Note that Sync isn't meant to be used as a backup, so if you only have this single device then you can consider to stop using Sync.

See also:

If you use and want to continue using Sync then you will have to accept that Firefox will ask for the master password on each startup. Note that Sync isn't meant to be used as a backup, so if you only have this single device then you can consider to stop using Sync. See also: *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles

Được chỉnh sửa bởi cor-el vào

Người tạo câu hỏi

Thanks, I never really intended to use Sync, so I will "disconnect" from Sync, and see if that resolves the problem.

Thanks, I never really intended to use Sync, so I will "disconnect" from Sync, and see if that resolves the problem.
nbv-mozilla 0 giải pháp 1 câu trả lời
Được đăng

Câu trả lời hữu ích

Had the same issue - for me Kaspersky has included some new options under Setting=>Additional=>Network=>Mozilla Firefox and Thunderbird. The change the default Scan secure traffic from Windows cert store to Mozilla cert store and don't get the password prompt on start up. No changes made to Firefox setup!

Had the same issue - for me Kaspersky has included some new options under Setting=>Additional=>Network=>Mozilla Firefox and Thunderbird. The change the default Scan secure traffic from Windows cert store to Mozilla cert store and don't get the password prompt on start up. No changes made to Firefox setup!
thepiggieinthemiddle 0 giải pháp 1 câu trả lời
Được đăng

^^ I tried nbv-mozilla's kaspersky fix for this issue and it worked for me!

The chosen solution did not work or did not apply.

^^ I tried nbv-mozilla's kaspersky fix for this issue and it worked for me! The chosen solution did not work or did not apply.
LLM-314159 0 giải pháp 1 câu trả lời
Được đăng

nbv-mozilla said

Had the same issue - for me Kaspersky has included some new options under Setting=>Additional=>Network=>Mozilla Firefox and Thunderbird. The change the default Scan secure traffic from Windows cert store to Mozilla cert store and don't get the password prompt on start up. No changes made to Firefox setup!

This worked for me. Fixed the problem in FireFox AND Thunderbird. I was about to post this problem, until I saw this.

''nbv-mozilla [[#answer-1185881|said]]'' <blockquote> Had the same issue - for me Kaspersky has included some new options under Setting=>Additional=>Network=>Mozilla Firefox and Thunderbird. The change the default Scan secure traffic from Windows cert store to Mozilla cert store and don't get the password prompt on start up. No changes made to Firefox setup! </blockquote> This worked for me. Fixed the problem in FireFox AND Thunderbird. I was about to post this problem, until I saw this.