Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

bookmarks do not sync across devices

  • 4 trả lời
  • 1 gặp vấn đề này
  • 24 lượt xem
  • Trả lời mới nhất được viết bởi Tonnes

more options

Firefox no longer seems to be syncing my bookmarks among devices. In particular, the bookmarks I add on my work iMac do not sync to my android phone or my home macbook pro. I have done the following things to attempt to get things working:

1. Turned off firefox sync on all devices and then back on. 2. Deleted my firefox sync account and recreated it. 3. Deleted and reinstalled firefox on both my android phone and my macbook pro

I have also gone to about:sync-log and see that I seem to have lots of sync errors. I've attached a screenshot of the sync-log screen. I can't seem to attach the txt file of the latest error log, so I'm attaching two screen shots of it as well.

If anyone can help me out, I'd certainly appreciate it!

Edit: Here's a pastebin link of the error log: https://pastebin.mozilla.org/9086433

Firefox no longer seems to be syncing my bookmarks among devices. In particular, the bookmarks I add on my work iMac do not sync to my android phone or my home macbook pro. I have done the following things to attempt to get things working: 1. Turned off firefox sync on all devices and then back on. 2. Deleted my firefox sync account and recreated it. 3. Deleted and reinstalled firefox on both my android phone and my macbook pro I have also gone to about:sync-log and see that I seem to have lots of sync errors. I've attached a screenshot of the sync-log screen. I can't seem to attach the txt file of the latest error log, so I'm attaching two screen shots of it as well. If anyone can help me out, I'd certainly appreciate it! Edit: Here's a pastebin link of the error log: https://pastebin.mozilla.org/9086433
Đính kèm ảnh chụp màn hình

Được chỉnh sửa bởi hartfordmove vào

Giải pháp được chọn

Thanks for the help. I deleted the places.sqlite files, which did not seem to help. But following your links, I saw that sometimes it is necessary to also delete the bookmarkbackups .json files. This gets rid of all of your bookmarks, but I had a saved copy, so I was able to import them back, and now sync seems to be up and running.


Tonnes said

Perhaps an issue in your places database file (places.sqlite) on the work iMac prevents the bookmarks sync step. Check the integrity of the database by opening Help > Troubleshooting Information (about:support) and clicking Verify Integrity under Places Database. If you can’t manage to fix any errors reported there, move the places.sqlite and other places.* files outside of your profile folder when Firefox is closed in order to let it restore a recent bookmarks backup, then check its integrity too. Keep the original file as a backup, and test using one of the other backups until there is no issue if needed, then retry the Sync step. See this question for more info. Note that the add-on described there is not available for Quantum, but you shouldn’t need it. This bug could be related.
Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (4)

more options

Perhaps an issue in your places database file (places.sqlite) on the work iMac prevents the bookmarks sync step.

Check the integrity of the database by opening Help > Troubleshooting Information (about:support) and clicking Verify Integrity under Places Database.

If you can’t manage to fix any errors reported there, move the places.sqlite and other places.* files outside of your profile folder when Firefox is closed in order to let it restore a recent bookmarks backup, then check its integrity too. Keep the original file as a backup, and test using one of the other backups until there is no issue if needed, then retry the Sync step.

See this question for more info. Note that the add-on described there is not available for Quantum, but you shouldn’t need it.

This bug could be related.

more options

Giải pháp được chọn

Thanks for the help. I deleted the places.sqlite files, which did not seem to help. But following your links, I saw that sometimes it is necessary to also delete the bookmarkbackups .json files. This gets rid of all of your bookmarks, but I had a saved copy, so I was able to import them back, and now sync seems to be up and running.


Tonnes said

Perhaps an issue in your places database file (places.sqlite) on the work iMac prevents the bookmarks sync step. Check the integrity of the database by opening Help > Troubleshooting Information (about:support) and clicking Verify Integrity under Places Database. If you can’t manage to fix any errors reported there, move the places.sqlite and other places.* files outside of your profile folder when Firefox is closed in order to let it restore a recent bookmarks backup, then check its integrity too. Keep the original file as a backup, and test using one of the other backups until there is no issue if needed, then retry the Sync step. See this question for more info. Note that the add-on described there is not available for Quantum, but you shouldn’t need it. This bug could be related.
more options

Hi,Glad to hear that your problem has been resolved. If you haven't already,

  • Please select the answer that solves the problem

This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.

more options

hartfordmove said

I deleted the places.sqlite files, which did not seem to help. But following your links, I saw that sometimes it is necessary to also delete the bookmarkbackups .json files.

Right. I could have mentioned you may need to remove all backups but figured you would understand after checking the Integrity of any backups first in case they also showed corruption (if they did, since corruptions of any backups is likely), which may have been helpful info for developers. Exporting current bookmarks to a HTML file would be a first step to create one.