Tìm kiếm hỗ trợ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Wrong startup page

  • 9 trả lời
  • 1 gặp vấn đề này
  • 23 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

I get a bing page whenever I startup firefox. I have read some suggested answers that do not work.

THere is nothing after firefox.exe on the shortcut I use to start Firefox 34.0.5 .

I have two active addons: Lastpass and Hotspot Shield. I have one inactive addon, Norton Toolbar. Could one of these cause the problem?

Now I have three, firefox troubleshooter

Tất cả các câu trả lời (9)

more options

Well you've probably read this solution, but you could try going to menu>preferences>general>home page. I doubt that your add ons are the problem. See attached screenshot if the directions don't make sense.

more options

I don't have "menu" or "preferences" on Firefox. I do have tools>options>general>startup. It's set to "show my home page" and https://my.yahoo.com/ .

more options

Lets see what you have . write url: about:config and continue carefully search for browser.startup What does browser.startup.homepage say? If its wrong change it to https://my.yahoo.com/ By the way is that url correct?

more options

It says https://my.yahoo.com. And that's a good URL.

There are a couple of lines of browser.startup.homepage.override though

browser.startup.homepage_override.buildID;20141126041045 browser.startup.homepage_override.mstone;34.0.5

more options

The browser.startup.homepage_override prefs are correct and you can leave them alone. You do have browser.startup.homepage: https://my.yahoo.com/ and that sets the home page to Yahoo.

What home page do you want instead or what else is wrong?


You can use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).


Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts.

  • User JS: Yes

The user.js file is only present if you or other software has created this file and normally it wouldn't be there. You can check its content with a plain text editor (right-click: Open with) if you didn't create this file yourself.

The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

See also:

You can use this button to go to the currently used Firefox profile folder:

more options

It's the startup page that's wrong. When I click on the "home" icon I get the desired startup page, my.yahoo.com. When Firefox starts, I get a Bing search result page.

I looked at prefs.js and it has the correct startup page. There are many lines from Fastpass in the file so I'm guessing they are the ones who added the prefs.js.

more options

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.

more options

Did that this morning before my first post. Nothing after firefox.exe

more options

Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also: