Rozwiązywanie problemów z wtyczkami

Jeśli masz problemy ze stronami używającymi do wyświetlania swojej zawartości wtyczek, takich jak Adobe Flash, Java i innych, sprawdź czy czasami wtyczka nie powoduje tych problemów.

Ważne! Firefox dla 64-bitowego systemu Windows aktualnie obsługuje jedynie wtyczkę Adobe Flash. By poznać szczegóły przeczytaj ten wpis na blogu Mozilli.
Ważne! Firefox dla 64-bitowego systemu Windows aktualnie obsługuje jedynie wtyczki Adobe Flash oraz Microsoft Silverlight.

Typowe problemy spowodowane przez wtyczki to:

W tym artykule opisano, jak rozwiązywać problemy z wtyczkami. Jeśli masz problemy z rozszerzeniem lub motywem, zobacz artykuł: Rozwiązywanie problemów z rozszerzeniami i motywami. Ogólne informacje na temat wtyczek znajdziesz w artykule: Używanie wtyczek w Firefoksie.

Określanie, czy wtyczka powoduje problem

Możesz wybiórczo wyłączać wtyczki w trakcie działania Firefoksa. Jeśli podejrzewasz, że problem powoduje konkretna wtyczka, wyłącz ją pierwszą i sprawdź, czy problem został rozwiązany. Jeśli nie wiesz, którą wtyczkę wyłączyć:

  1. Na górze okna Firefoksa naciśnij przycisk FirefoxNa pasku menu kliknij NarzędziaNa górze okna Firefoksa kliknij menu Narzędzia i wybierz Dodatki. Zostanie otworzona karta Menedżera dodatków.Kliknij przycisk menu New Fx Menu i wybierz Dodatki. Zostanie otworzona karta Menedżera dodatków.

  2. Na karcie Menedżera dodatków wybierz panel Wtyczki.
  3. Na liście wybierz wtyczkę i z listy rozwijanej wybierz Nigdy nie aktywuj . Powtarzaj tę czynność dla każdej wtyczki znajdującej się na liście. Nie ma potrzeby ponownego uruchamiania Firefoksa po wyłączeniu wtyczki.
  4. Sprawdź, czy problem nadal występuje. Jeśli nie występuje, wróć do karty Menedżera dodatków i włączaj wtyczki po kolei, używając z listy rozwijanej opcji Zawsze aktywuj, do czasu aż znajdziesz tę, która powoduje problem.

Gdy stwierdzisz, że wyłączenie danej wtyczki rozwiązuje problem, wykonaj czynności opisane w dalszej części artykułu.

Aktualizacja lub ponowna instalacja wtyczek

Wiele problemów z wtyczkami może zostać rozwiązane poprzez aktualizację wtyczek do najnowszej wersji. Aby sprawdzić, czy używane wtyczki są aktualne, odwiedź stronę narzędzia sprawdzającego aktualność wtyczek.

Jeśli aktualizacja do najnowszej wersji lub ponowna instalacja wtyczki nie przyniosła pożądanego efektu, możesz pozostawić wtyczkę wyłączoną.

Ręczna dezinstalacja wtyczki

Jeśli nie możesz użyć specjalnego programu do dezinstalacji wtyczki, możesz usunąć ją ręcznie:

  1. W pasku adresu wprowadź about:plugins i naciśnij przycisk EnterReturn, by wyświetlić stronę z wykazem zainstalowanych wtyczek.
  2. Dla każdej wtyczki w pozycji Plik: podana jest nazwa pliku. Uruchom Eksplorator Windows i przejdźPrzejdź do folderu wtyczki, którą chcesz usunąć.
  3. Zmień nazwę pliku na inną, np. npswf32 zmień na Xnpswf32

Wtyczka zostanie usunięta.

Ponowne zainicjowanie bazy danych wtyczek

Może zdarzyć się, że nie będzie można zainstalować wtyczki. Ponowne zainicjowanie bazy danych wtyczek może rozwiązać problem:

  1. Otwórz folder profilu:

    Na górze okna Firefoksa naciśnij przycisk Firefox i kliknij menu PomocNa pasku menu, kliknij menu PomocNa górze okna Firefoksa, kliknij menu Pomoc, a następnie wybierz Informacje dla pomocy technicznej. Zostanie otwarta karta zawierająca informacje dla pomocy technicznej.Naciśnij przycisk New Fx Menu , następnie pomoc Help-29 i wybierz Informacje dla pomocy technicznej. Zostanie otwarta karta zawierająca informacje dla pomocy technicznej.

    W sekcji Informacje o aplikacji naciśnij przycisk Pokaż folderOtwórz folderPokaż w FinderzeOtwórz katalog. Zostanie otwarte okno zawierające plikifolder twojego profilu.
    Jeśli nie możesz otworzyć lub używać Firefoksa, postępuj według instrukcji zawartych w artykule: Odszukanie profilu bez otwierania Firefoksa.

  2. Na górze okna Firefoksa naciśnij przycisk Firefox i wybierz Zakończ.Na górze okna Firefoksa kliknij menu Plik i wybierz Zakończ.Na pasku menu kliknij menu Firefox i wybierz Zakończ program Firefox.Na górze okna Firefoksa kliknij menu Plik i wybierz Zakończ.

    Naciśnij przycisk menu New Fx Menu , a następnie Zakończ Close 29 .

  3. Usuń plik pluginreg.dat.
  4. Otwórz Firefoksa.
  5. W pasku adresu wprowadź about:plugins i naciśnij klawisz EnterReturn, by otworzyć listę zainstalowanych wtyczek.

Czy ten artykuł okazał się pomocny? Proszę czekać…

Osoby, które pomogły w tworzeniu tego artykułu: GmbH, teo951, TyDraniu, daroPL. Ty też możesz pomóc - sprawdź jak.