Dlaczego wtyczki Java, Silverlight, Adobe Acrobat i inne nie działają?

Wtyczki NPAPI w Firefoksie nie są już obsługiwane (za wyjątkiem Adobe Flash) od marca 2017, kiedy to pojawił się Firefox w wersji 52.Od dnia pojawienia się Firefoksa w wersji 52, wtyczki NPAPI nie są już obsługiwane, za wyjątkiem Adobe Flash. Java, Microsoft Silverlight i Adobe Acrobat to niektóre z wtyczek, które nie będą już obsługiwane. Więcej informacji na ten temat znajdziesz w tym dokumencie o kompatybilności.

Na przeciągu ostatnich kilku lat, do kodu Firefoksa stopniowo wprowadzone zostały ulepszenia, pozwalające stronom na działanie bez potrzeby stosowania specjalnych wtyczek, więc twoje przeglądanie sieci nie powinno ulec wielkiej zmianie po aktualizacji do wersji 52.

Dlaczego ta zmiana miała miejsce?

Internet jest pełen stron o bardziej skomplikowanej strukturze niż nieruchome obrazy i tekst - znajdziesz w nim wideo, dźwięk i gry. Wtyczki NPAPI, a w szczególności Flash, pomagały przeglądarkom wyświetlać takie strony w pełni. Ich efektem ubocznym było również spowalnianie działania przeglądarek, obniżanie ich poziomu bezpieczeństwa i powodowanie awarii.

Na przeciągu ostatnich kilku lat, kod Firefoksa został ulepszony poprzez zastąpienie tego rodzaju wtyczek kodem o nazwie WebAPI. Jego celem jest całkowite zastąpienie wtyczek bez negatywnego wpływu na bezpieczeństwo, stabilność i ogólną wydajność przeglądarek.

Do niedawna, kod WebAPI nie był jeszcze gotowy do użycia. Dlatego w Firefoksie wymagane było ręczne uruchamianie wtyczek (poprzez klikanie w odpowiednie obszary stron).

Teraz są gotowe do użycia. Wiele stron już z nich korzysta, więc większość twoich ulubionych stron działa dokładnie tak jak kiedyś, bez konieczności używania przestarzałych i niebezpiecznych wtyczek. Firefox dołączył do innych nowoczesnych przeglądarek takich jak Google Chrome i Microsoft Edge, które również nie obsługują wtyczek NPAPI.


Mam problemy z brakiem wtyczek NPAPI

Jeśli musisz z jakiegoś powodu korzystać z wtyczek NPAPI, wersja (Extended Support Release) Firefoksa 52 będzie je obsługiwała do 2018 roku. Kliknij tutaj by pobrać Firefoksa w wersji ESR.

Ważne: 64-bitowa wersja Firefoksa 52 ESR dla Windows wspiera jedynie wtyczki Adobe Flash oraz Microsoft Silverlight. Jeżeli potrzebujesz również wsparcia dla Javy lub innych wtyczek, wybierz wersję 32-bitową.

Domyślnie, Firefox 52 ESR korzysta z tej samej wersji danych profilu użytkownika co inne zainstalowane wersje Firefoksa. Zainstalowanie Firefoksa 52 ESR po korzystanie z Firefoksa 55 (lub nowszej wersji) może wywołać problemy takie jak komunikaty błędu, problemy w działaniu niektórych komponentów Firefoksa lub niektórych witryn. Zalecamy stworzenie nowego profilu do użytku z Firefoksem 52 ESR lub odświeżenie Firefoksa po zainstalowaniu Firefoksa 52 ESR.

Czy ten artykuł okazał się pomocny? Proszę czekać…

Osoby, które pomogły w tworzeniu tego artykułu: TyDraniu, vesper. Ty też możesz pomóc - sprawdź jak.