Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Irrational UI behaviour in FF10.0

  • 3 replies
  • 3 have this problem
  • 3 views
  • Last reply by Donnie

more options

Update: always check every addon, even when they don't change the UI. Facebook Disconnect messed up my UI for no reason.

After upgrading Firefox automatically to version 10.0 the top UI area (menu button, tabs, address bar, etc.) has been acting strange.

  • I need to toggle a few different settings for the menu button to settle properly. Otherwise the Firefox icon and current tab title is visible on a single line on the top (not wanted) with the menu button under it on a line of its own.
  • The current tab URL doesn't update to the address bar properly (same URL visible on all tabs).
  • Bookmarks toolbar is randomly disappearing.
  • Randomly not loading a page after typing an URL to the address bar and hitting Enter.

As I said if I toggle a few tool bars or click random buttons they settle to correct positions. The address bar issue is still quite irritating.

The only visible addon UI elements are Web Developer Toolbar, AdBlock Plus button, Firebug button and Ghostery button. Otherwise everything is the vanilla UI (except a few repositioned navigation buttons).

Is this happening to anyone else or should I try something special?

Modified by ojrask

Chosen solution

Narrowed the issue down to addons. Facebook Disconnect somehow messes up everything (even though it doesn't insert anything to the UI). Odd. Let's call this solved.

Read this answer in context 👍 0

All Replies (3)

more options

If you haven't already I suggest reading through the latest version's release notes & the latest Firefox issues.

See: Latest Firefox issues


See: http://www.mozilla.org/en-US/firefox/.../releasenotes/

more options

Chosen Solution

Narrowed the issue down to addons. Facebook Disconnect somehow messes up everything (even though it doesn't insert anything to the UI). Odd. Let's call this solved.

more options

Funny you should mention add-ons because I was just about to edit my original posting and suggest you restart in safe mode with add-on's disabled to determine if we could isolate it down to a faulty add-on. You'd be surprised how many times an addon or extension is the culprit of so many problems, lol