Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

No audio / video in Firefox 110 Ubuntu - Chrome 110 works fine

  • 10 replies
  • 0 have this problem
  • 3 views
  • Last reply by jonzn4SUSE

more options

These websites won't play audio or video in Firefox 110.0.1, they work in Chrome 110.0.5481.177

https://www.vrt.be/vrtnu/livestream/audio/stubru/ When I click the Play button I get an error "Oops, something went wrong, error code 200" which seems to be a general error code. In Chrome the music starts playing instantly.

https://f1tv.formula1.com/ I have a subscription but video won't play. I can press the Play button, sometimes I see a preloader but the screen stays black, no audio or video. In Chrome the content just starts playing, be it live or recorded content.

Steps I took to get audio/video working inb Firefox, but to no avail:

run above websites in private tabs download Firefox again and run it from its folder in Downloads start Firefox in Troubelshoot mode start Firefox in Troubleshoot mode and Refresh Firefox disabled / enabled Plugin Widevine Content Decryption Module provided by Google Inc disabled / enabled Play DRM-controlled content in Settings disabled / enabled Enhanced Tracking protection disablde / enabled allow media autoplay

In other discussions it was opted to remove the PulseAudio config by running the below command and rebooting rm ~/.config/pulse/*

Any help to get this working again would be greatly appreciated!

These websites won't play audio or video in Firefox 110.0.1, they work in Chrome 110.0.5481.177 '''https://www.vrt.be/vrtnu/livestream/audio/stubru/''' When I click the Play button I get an error "Oops, something went wrong, error code 200" which seems to be a general error code. In Chrome the music starts playing instantly. '''https://f1tv.formula1.com/''' I have a subscription but video won't play. I can press the Play button, sometimes I see a preloader but the screen stays black, no audio or video. In Chrome the content just starts playing, be it live or recorded content. Steps I took to get audio/video working inb Firefox, but to no avail: run above websites in private tabs download Firefox again and run it from its folder in Downloads start Firefox in Troubelshoot mode start Firefox in Troubleshoot mode and Refresh Firefox disabled / enabled Plugin Widevine Content Decryption Module provided by Google Inc disabled / enabled Play DRM-controlled content in Settings disabled / enabled Enhanced Tracking protection disablde / enabled allow media autoplay In other discussions it was opted to remove the PulseAudio config by running the below command and rebooting rm ~/.config/pulse/* Any help to get this working again would be greatly appreciated!

Chosen solution

Did you check ffmpegs see screenshot I'm on a rolling distro, so my versions may differ.

Read this answer in context 👍 0

All Replies (10)

more options

btw Firefox 110 runs on Ubuntu 22.04.2 LTS which has latest updates installed

more options

vrt works in windows, but F1 will be hard to reproduce without something free to test. Let me boot to linux. You may need to verify you have current ffmpegs.

Modified by jonzn4SUSE

more options

I have no issue with vrt live never stop party... Where are my glow sticks?!?!?! ;-)) This F1 site videos works for me. see screenshot

https://www.formula1.com/en/latest/video.qualifying-highlights-bahrain-grand-prix.1727746279678504877.html

Are you using X11 or Wayland?


Operating System: openSUSE Tumbleweed 20230301 KDE Plasma Version: 5.27.1 KDE Frameworks Version: 5.103.0 Qt Version: 5.15.8 Kernel Version: 6.2.0-1-default (64-bit) Graphics Platform: X11 Processors: 12 × Intel® Core™ i7-9850H CPU @ 2.60GHz Memory: 125.1 GiB of RAM Graphics Processor: Mesa Intel® UHD Graphics 630 Product Name: HP ZBook 17 G6

Modified by jonzn4SUSE

more options

Hi jonzn4SUSE, thanks for your help

Video doesn't play and when I open your link I get this error: "The media playback was aborted due to a corruption problem or because the media used features your browser did not support."

Digital Rights Management (DRM) Content is enabled and there aren't any content blockers active.

I'm running Ubuntu 22.0.4.2 with Wayland windowing system.

Audi and video uesed to work but I haven't been watching F1 the past 3 months. As videos won't play there I decided to try other websites. YouTube works but Studio Brussel / VRT radio doesn't. In the past I was able to listen to their radio shows as well. Glad you enjoyed them btw :-)

more options

Chosen Solution

Did you check ffmpegs see screenshot I'm on a rolling distro, so my versions may differ.

Modified by jonzn4SUSE

more options

Even my distro version 109 works. see screenshot

more options

Another computer with no issues. see screenshot

more options

It appears ffmpeg is not installed

I did ffmpeg -version

The results are: Command 'ffmpeg' not found, but can be installed with: sudo snap install ffmpeg # version 4.3.1, or sudo apt install ffmpeg # version 7:4.4.2-0ubuntu0.22.04.1 See 'snap info ffmpeg' for additional versions.

Should I install ffmpeg?

more options

I installed ffmpeg

ffmpeg -version now results in: ffmpeg version 4.4.2-0ubuntu0.22.04.1 Copyright (c) 2000-2021 the FFmpeg developers built with gcc 11 (Ubuntu 11.2.0-19ubuntu1)

..and guess what? F1 video and Studio Brussels audio play in Firefox! Even at the same time :-D This is awesome. Well not them playing at the same time.

How come ffmpeg is needed for Firefox to be able to play certain audio and video channels?

more options

Glad to hear the issue is resolved. You will have to read about ffmpeg. https://en.wikipedia.org/wiki/FFmpeg Mark it as resolved and have a nice day.  ;-)