Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Connect to remote Websocket from localhost doesn't send cookies

  • 1 reply
  • 0 have this problem
  • 4 views
  • Last reply by cor-el

more options

Hi, I am web developer. App I am working on need to connect to remote host by webscoket and send auth cookies to it (aws guard). The problem is when I run app on the local host (dev mode), it works fine in every Chrome based browser, and even Safari, but unable to connect in FF.

For example, my app runs on localhost:8080, and Websocket host is ws.dev.myapp.com For successeful coonection, handshake request should include cookies from .dev.myapp.com domain, or even .myapp.com. So, you can see on screenshots, cookies not included on request from localhost, and we get 403 error instead of 101 on second pic.

I guest this is some secutiry setting I can tweak, but I can't see what exactly. Or can it be a bug?

Hi, I am web developer. App I am working on need to connect to remote host by webscoket and send auth cookies to it (aws guard). The problem is when I run app on the local host (dev mode), it works fine in every Chrome based browser, and even Safari, but unable to connect in FF. For example, my app runs on localhost:8080, and Websocket host is ws.dev.myapp.com For successeful coonection, handshake request should include cookies from .dev.myapp.com domain, or even .myapp.com. So, you can see on screenshots, cookies not included on request from localhost, and we get 403 error instead of 101 on second pic. I guest this is some secutiry setting I can tweak, but I can't see what exactly. Or can it be a bug?
Attached screenshots

All Replies (1)

more options

Maybe the problem is "origin: http://localhost:8080" in the first screenshot (i.e. not coming from a secure connection).

Maybe try to ask advice on a web development oriented forum.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.