Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

New Responsive Design Mode broken

  • 2 replies
  • 2 have this problem
  • 9 views
  • Last reply by cor-el

more options

The newest iteration of Responsive Design Mode is completely broken. Inspector frequently shows as blank, middle click doesn't work, it constantly hitches or stops responding to clicks, it doesn't snap to 10px iterations when holding shift + resizing and, every now and then, it just shows as a blank white screen when entering.

Anyone know how to get the old, working one back?

The newest iteration of Responsive Design Mode is completely broken. Inspector frequently shows as blank, middle click doesn't work, it constantly hitches or stops responding to clicks, it doesn't snap to 10px iterations when holding shift + resizing and, every now and then, it just shows as a blank white screen when entering. Anyone know how to get the old, working one back?

All Replies (2)

more options

Please consider turning on send info to Mozilla before posting a question. This helps us help you.

Ah... no. No idea. Massive code changes am sure there is no old one.

Why not try Firefox Developer Edition  : https://www.mozilla.org/en-US/firefox/developer/

Can also run the page through the W3C.org (World Wide Web Consortium) in charge of standards and practises for browsers and webpages. HTML https://validator.w3.org/ CSS https://jigsaw.w3.org/css-validator/ UNICORN https://validator.w3.org/unicorn/

Note : Firefox 57 Quantum release date Nov 14th https://www.mozilla.org/en-US/firefox/quantum/ Note : Legacy Extensions will be disabled and or removed.

Please let us know if this solved your issue or if need further assistance.

Modified by Shadow110

more options

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window