Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

keeps switching to yaho9o search

  • 3 replies
  • 0 have this problem
  • Last reply by cor-el

more options

When I search in Firefox (my default searcher) it always switches to yahoo. This is unacceptabeble. If U can't change it I will stop using firefox

When I search in Firefox (my default searcher) it always switches to yahoo. This is unacceptabeble. If U can't change it I will stop using firefox

All Replies (3)

more options

Mozilla has nothing to do with Yahoo search engine now as it was removed as one of the defaults in Firefox six years ago. /forums/contributors/712925

If you are getting a Yahoo search now then it could have been added in a recent Extension install or update or perhaps by some malware on your system. https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware


Btw Firefox is a web browser. The DuckDuckGo, Bing, Google, Yahoo etc are Search Engines. https://support.mozilla.org/en-US/kb/add-or-remove-search-engine-firefox

Helpful?

more options

Thank you for sharing your add-ons list. I noticed that one of them is not from the Mozilla Add-ons site. Any idea where it came from or why you have it?

"name": "Browsing Safety by Safely", "version": "1.1.2", "id": "{8c9ec486-bd7b-40dd-ab49-1ca3ff452484}"

Turns out it was added to the Add-on block list four years ago (bug #1614707), so I'm surprised it was able to get or stay installed on your Firefox recently.

Maybe there is a problem with malicious add-on blocking in your Firefox, or maybe older blocked IDs fall off the list??

As a first step, definitely get rid of the hijacker.

As a second step, you probably should do some malware scans. See: Troubleshoot Firefox issues caused by malware.

As a third step, we should help you investigate whether blocklisting was somehow hacked on your Firefox.

Helpful?

more options

You can check extensions.blocklist.enabled in about:config and make sure it is default true to ensure that you are safe.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.