Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox displays html code on .xml page instead of rendering text

  • 9 replies
  • 1 has this problem
  • 141 views
  • Last reply by etcetera777

more options

Firefox displays text on the .xml page as html code instead of rendering is as normal text. The layout and images on the page look as they should.

There is nothing wrong with the page, as it is rendered perfectly in Chrome.

In addition, this page doesn't display at all on the phone. When I click on the link it asks me to download it and then asks me which app I want to open it with - instead of simply rendering the page.

I have seen some old threads on this topic, it looks like this issue haven't been resolved for few years.

My question is not just about fixing it in my browser but at the root cause. This page is the RSS feed of my podcast which many people want to access and many use Firefox as their browser. Unless I tell everyone to use Chrome instead.

Can someone help? thanks.

Firefox displays text on the .xml page as html code instead of rendering is as normal text. The layout and images on the page look as they should. '''There is nothing wrong with the page, as it is rendered perfectly in Chrome.''' In addition, this page doesn't display at all on the phone. When I click on the link it asks me to download it and then asks me which app I want to open it with - instead of simply rendering the page. I have seen some old threads on this topic, it looks like this issue haven't been resolved for few years. My question is not just about fixing it in my browser but at the root cause. This page is the RSS feed of my podcast which many people want to access and many use Firefox as their browser. Unless I tell everyone to use Chrome instead. Can someone help? thanks.

Chosen solution

Once again, we are not on the same page,

You are talking about the issues with the feed which is wrong and irrelevant.

If the feed had issues it would not render properly on Chrome. This point seems to escape you, not sure why.

Secondly, I can't make any changes to the feed, my podcast host has published it in accordance with the standard public feed rules.

for the last time - there are no issues with my feed.

The issue is that Mozilla developers haven't bothered to fix this issue for at least three years.

Since I'm not getting any sensible help and people are in denial that this is Mozilla's error, I am closing this thread.

Read this answer in context 👍 0

All Replies (9)

more options

Can you share an example link?

Helpful?

more options

Helpful?

more options

Your podcast should be accessed with a browser from https://rss.com/podcasts/quantum-living/ and it has a handy "Copy RSS feed" button for feed readers.

Helpful?

more options

Works fine for me with the current release. If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin), always make sure such extensions do not block content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings), click the padlock icon (Clear cookies and site data) for the domain in the selected tab.

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can check for issues with Enhanced Tracking Protection. Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages like blocked content.

Helpful?

more options

@zeroknight - thanks for your reply however it doesn't address the issue or my questions at all. It appears you didn't understand what the issue is.

@cor-el

I have written a very long reply - the whole thing took 1.5 of my time together with some of your troubleshooting - which I lost thanks to yet another Firefox FATAL ERROR

I can't repeat everything I wrote in detail to spend another hour on it so in summary:

- you clearly didn't understand the issue or my questions. What you claim as "works fine for me" shown in your attached screenshot of my webpage is exactly what is showing in the link I have provided. The text is STILL SHOWN IN HTML instead of rendered. Please read again closely my first post, I can't repeat everything here.

- nothing is blocking the content. I don't have any extensions. - your instruction to reload the page with ctrl+ F5 has shut down all my tabs and my programs (!!!!!!!) - that webpage does not have any cookies.

FIREFOX FATAL ERROR

While in the Manage Data window I saw many sites that left cookies I don't want - so I started removing them one by one by with REMOVE SELECTED button, while leaving those I need. Then I clicked on SAVE CHANGES which brought up a confirmation window listing all those removed sites. I confirmed.

When I reopened that window there was only a handful of sites I have already removed. Nothing else. I had no option but to click REMOVE ALL. which has signed me out of this forum and I lost my draft reply. And of course, I have lost cookies on several sites I need to be logged in to.

What on earth has happened?? Mozilla needs to fix this ASAP as it deletes everything instead of the selected sites.

Regarding the main issue - Firefox has an issue (error) with rendering .xml pages. As I said, I have seen many posts online including on this forum about THE VERY SAME ISSUE going back few years which clearly Mozilla hasn't bothered to fix. You did not address this at all.

If you understood the issue and believe that this .xml webpage renders fine in Firefox - please attach a screenshot showing this, as once again, the one you have attached is showing the same error.

At this point, since the error is with Firefox, I need to tell people to use Chrome to open my RSS feed not Firefox.

Helpful?

more options

Browsers are primarily for viewing html pages rather than xml. You can share the html link to the RSS feed I mentioned previously and users can copy the xml link from there.

Helpful?

more options

@zeroknight

Browsers are primarily for viewing html pages rather than xml.

This is may be so - but if Chrome can render it properly so should Firefox.

You can share the html link to the RSS feed I mentioned previously and users can copy the xml link from there.

This doesn't resolve anything. Whether the user clicks on the RSS link on my main podcast website or copies it from my native website you have mentioned or from anywhere else and opens it in FIREFOX - the result is exactly the same: text showing as html instead of being rendered properly. Try it and you will see.

The issue is not where to access my podcast feed but that Firefox is not rendering the page properly.

As I said earlier - this is an old issue I can see in many posts online including on this forum, so Mozilla devs are simply not paying attention to it and don't fix it.

Helpful?

more options

The standard practice is to link to xml feeds in the <head> section for discovery by RSS readers.

<link rel="alternate" type="application/rss+xml" title="RSS" href="feed.xml">


If you must link to the feed in the body, you can use the html link which has all the same information and displays properly. If you want to show the xml URL, you can make it plain text so the user can't click it and visit it by accident.

Helpful?

more options

Chosen Solution

Once again, we are not on the same page,

You are talking about the issues with the feed which is wrong and irrelevant.

If the feed had issues it would not render properly on Chrome. This point seems to escape you, not sure why.

Secondly, I can't make any changes to the feed, my podcast host has published it in accordance with the standard public feed rules.

for the last time - there are no issues with my feed.

The issue is that Mozilla developers haven't bothered to fix this issue for at least three years.

Since I'm not getting any sensible help and people are in denial that this is Mozilla's error, I am closing this thread.

Modified by etcetera777

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.