Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Show Google search URL in address bar, don't overwrite it with the original search string

  • 1 reply
  • 0 have this problem
  • 41 views
  • Last reply by pg_78

more options

Steps to reproduce:

1. Have Google as the default search engine.

2. Type a search string into the address bar.

3. The address bar briefly shows a URL for the Google Search results.

4. The address bar is very quickly overwritten with the original search string.

See screenshot for example.

How do I stop step #4 happening? I want the URL to remain in the address bar, for example to be able to give somebody a link which executes the google search.

I think this is new in FF121.

Steps to reproduce: 1. Have Google as the default search engine. 2. Type a search string into the address bar. 3. The address bar briefly shows a URL for the Google Search results. 4. The address bar is very quickly overwritten with the original search string. See screenshot for example. How do I stop step #4 happening? I want the URL to remain in the address bar, for example to be able to give somebody a link which executes the google search. I think this is new in FF121.
Attached screenshots

Chosen solution

I found the problem: I needed to uncheck "Show search terms instead of URL on default search engine results page" in Settings.

Not sure if the default for this changed, or if I had inadvertently changed it myself.

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

I found the problem: I needed to uncheck "Show search terms instead of URL on default search engine results page" in Settings.

Not sure if the default for this changed, or if I had inadvertently changed it myself.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.