Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

HTTPS-Only Mode seems to be permanently selected

  • 11 replies
  • 3 have this problem
  • 311 views
  • Last reply by sawbona1

more options

Firefox was working well on HTTP websites until a few days ago, but now HTTPS-Only Mode seems to be permanent. Despite changing settings to 'Don’t enable HTTPS-Only Mode', when HTTP sites are selected I get the same message as for 'HTTPS-Only Mode'. Also, if I select 'Enable HTTPS-Only Mode in all windows' and add exceptions, I get the same result.

Firefox was working well on HTTP websites until a few days ago, but now HTTPS-Only Mode seems to be permanent. Despite changing settings to 'Don’t enable HTTPS-Only Mode', when HTTP sites are selected I get the same message as for 'HTTPS-Only Mode'. Also, if I select 'Enable HTTPS-Only Mode in all windows' and add exceptions, I get the same result.

Chosen solution

I get the same message but after a few seconds it goes the actual site in HTTP mode. I am able to add http://www.bom.gov.au as an exception and it seems to take it. Might try going to Help -> Troubleshoot Mode and see what happens there in case some extension is interfering.

Read this answer in context 👍 0

All Replies (11)

more options

Thankyou. All of the sites are bookmarks from www.bom.gov.au. Screenshot attached shows the message I get when any of those bookmarks are selected. www.bom.gov.au has a very deep menu structure, and using the bookmarks for what I want is really the only efficient way for me. Please note that when I made my original post, I was getting the following message: ‘You’ve enabled HTTPS-Only Mode for enhanced security, and a HTTPS version of www.bom.gov.au is not available.’ I now get the message shown in the screenshot. Redirection to the http site does not happen as the message states, and if I manually follow the link it does not work and I again get the message in the screenshot. I have tried to disable HTTPS-Only Mode, and the Firefox security settings show that I have ‘Don’t enable HTTPS-Only Mode’ selected.

more options

Chosen Solution

I get the same message but after a few seconds it goes the actual site in HTTP mode. I am able to add http://www.bom.gov.au as an exception and it seems to take it. Might try going to Help -> Troubleshoot Mode and see what happens there in case some extension is interfering.

more options

Are you using Private browsing mode (i.e. Settings > Privacy > History > Always use private browsing mode)? Another user reports that de-selecting that enabled access to http sites.

https://support.mozilla.org/en-US/questions/1416122 https://support.mozilla.org/en-US/kb/private-browsing-use-firefox-without-history https://support.mozilla.org/kb/https-only-prefs

more options

MarkRH - I can only add exceptions if I enable HTTPS-Only Mode, and I have previously added http://www.bom.gov.au while in that mode; it made no difference to my problem.

Terry - No, not using Private Browsing mode.

more options

Further to my remarks above, I have tried the site with HTTPS-Only Mode enabled, and the site added as an exception. Screenshot shows the message this generates. The important part of that message is: 'If you continue, HTTPS-Only Mode will be turned off temporarily for this site.' When I hit 'Continue to HTTP Site', the page that shows is the screenshot I added in response to question from Dropa earlier. The difference is that the link shown in that message does work when clicked (not automatically), and the BOM home page opens. Once the BOM home page is open, all of my bookmarks work. It's a bit like going in circles.

more options

The redirect isn't instantly, but takes ten seconds via JavaScript setTimeout.

  • timerId = setTimeout('load_page()', 10000);
more options

Thank you for all the helpful inputs; it seems that the function of 'HTTPS-Only Mode enabled' is not in question. I can get what I want, even if only in a round about way. That leaves a question as to whether 'Don’t enable HTTPS-Only Mode' does anything helpful. I did not find it helpful, however, I will call my problem solved.

more options

Note that you can create an 'off' exception for http://www.bom.gov.au in Settings.

  • Settings -> Privacy & Security -> HTTPS-Only Mode -> Manage Exceptions
more options

Cor-el, thank you. I have realised that enabling HTTPS-Only Mode with exceptions is the way to go. Problem solved.

more options

Cor-el, thank you. I have realised that enabling HTTPS-Only Mode with exceptions is the way to go. Problem solved.

more options

Hello:

> ... enabling HTTPS-Only Mode with exceptions is the way to go. I beg to differ. It is not the way to go.

The way to go is to actually fix this problem.

> Problem solved. No. The problem is not solved. If having to resort to a permanent roundabout, the problem has not been solved. Not by a longshot.

Problem solved would be if FF worked as it did before whatever happened threw things off-course. ie: I tick the respective button and FF does not enable HTTPS-Only Mode, like it has been up to now.

Unless someone somewhere in Mozland decided that FF would work from now on in HTTPS-Only Mode and users would have to jump through loops to be able to use plain HTTP.

Best,

S.