Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hyperlinks are not working on Outlook (running Windows 7 Pro).

  • 6 replies
  • 0 have this problem
  • 41 views
  • Last reply by laura2u

more options

When I click on an article or any link in Outlook, I get an error message that says, Your organization's policies are preventing us from completing this action for you. For more info, please contact your help desk. I'm not an 'organization', just a user and obviously there's no help desk to contact, so I thought I'd reach out to see if someone might have a solution to this problem. I have already made sure that my default programs are set to Firefox for my browser and Outlook for my email and made sure all the defaults are selected. I have also run a full windows scan program which came up without any errors and I have run a registry scan that fixed every identified error. I'm still getting the same error message and the only way for me to open up an article or a link from an email is to 'copy hyperlink', open up a new tab in Firefox and select Paste and Go, which is driving me nuts and wasting a ton of time. I don't know what else to do at this point. I did find a document on the internet that has what it says is a method to resolve this exact error message problem, but the instructions are specific to Internet Explorer, not Firefox. I'm hesitant to find those same tools on Firefox (which is quite possible, though some of them are in different places on Firefox than they are on Internet Explorer). My concern comes with the fact that the final step will 'reset' every setting to it's default condition, so it seemed like a good idea to try to get some expert help before I perform such a drastic action. Also, I'm also making the assumption that if I did do a complete reset, I would be able to restore Firefox back via my most recent System Restore and it would bring back all my customizations, browers add-ons, personal settings, home pages history, cookies, privacy settings, etc. - but I'd like someone to weigh in on this. Thanks for any help anyone can provide.

When I click on an article or any link in Outlook, I get an error message that says, ''Your organization's policies are preventing us from completing this action for you. For more info, please contact your help desk.'' I'm not an 'organization', just a user and obviously there's no help desk to contact, so I thought I'd reach out to see if someone might have a solution to this problem. I have already made sure that my default programs are set to Firefox for my browser and Outlook for my email and made sure all the defaults are selected. I have also run a full windows scan program which came up without any errors and I have run a registry scan that fixed every identified error. I'm still getting the same error message and the only way for me to open up an article or a link from an email is to 'copy hyperlink', open up a new tab in Firefox and select Paste and Go, which is driving me nuts and wasting a ton of time. I don't know what else to do at this point. I did find a document on the internet that has what it says is a method to resolve this exact error message problem, but the instructions are specific to Internet Explorer, not Firefox. I'm hesitant to find those same tools on Firefox (which is quite possible, though some of them are in different places on Firefox than they are on Internet Explorer). My concern comes with the fact that the final step will 'reset' every setting to it's default condition, so it seemed like a good idea to try to get some expert help before I perform such a drastic action. Also, I'm also making the assumption that if I did do a complete reset, I would be able to restore Firefox back via my most recent System Restore and it would bring back all my customizations, browers add-ons, personal settings, home pages history, cookies, privacy settings, etc. - but I'd like someone to weigh in on this. Thanks for any help anyone can provide.

Chosen solution

This can occur if you remove your default browser without first changing your default browser to a different one. For example, if you uninstall Firefox from the 32-bit programs folder and then reinstall it in the 64-bit programs folder. Or if you remove Chrome when it was the default browser. For some reason, Office apps can be stupidly stubborn about looking in the old location.

Here's an old article with a Registry fix if needed: https://www.slipstick.com/problems/this-operation-has-been-cancelled-due-to-restrictions/

Read this answer in context 👍 1

All Replies (6)

more options

Can you attach a screenshot?

Helpful?

more options

Helpful?

more options

Chosen Solution

This can occur if you remove your default browser without first changing your default browser to a different one. For example, if you uninstall Firefox from the 32-bit programs folder and then reinstall it in the 64-bit programs folder. Or if you remove Chrome when it was the default browser. For some reason, Office apps can be stupidly stubborn about looking in the old location.

Here's an old article with a Registry fix if needed: https://www.slipstick.com/problems/this-operation-has-been-cancelled-due-to-restrictions/

Helpful?

more options

Below is an image I snipped showing the constant error message that pops up every time I try to open a hyperlink in Outlook. Again, I'm using Windows 7 Professional, and all the so-called 'solutions' to this precise problem seem to all be based on Internet Explorer and Windows 10.

Helpful?

more options

On the Tools menu, select Internet Options. Select Programs > Reset Web Settings. Under Internet programs, make sure that the correct email program is selected. Select the Internet Explorer should check to see whether it is the default browser check box.

Helpful?

more options

For anyone out there that has the same problem, I finally found a solution online that worked! Just in case anyone would like to give it a try:

https://www.slipstick.com/problems/this-operation-has-been-cancelled-due-to-restrictions/

Don't let the link scare you off, this thing really works. Below are the instructions in text only. I'm sorry I couldn't seem to snip the graphic boxes that showed screenshots, but if you go to the link, you can see the entire process.


If you use Outlook 2013 or newer, you'll receive following error message (instead of a "restrictions in effect error") message.

   Your organization's policies are preventing us from completing this action for you. For more info, please contact your help desk"

This is not "an Outlook error" and the solution will fix the error message in all Office applications.

It's due to a problem with the default browser configuration, often caused by uninstalling Chrome or Firefox while the browser is set as default. It's most common when another application installs Chrome and sets it as the default browser, then the user uninstalls it before setting Internet Explorer or Edge as their default browser. (Because, honestly, who would even think that would be necessary, right?)

Start with Edit Registry (below) if you uninstalled Chrome , Firefox, or another HTML rendering application, such as Maxthon or UltraEdit, and then received the error.

If you don't want to edit the registry (or use my reg file), Alan suggests reinstalling Chrome (or the offending program). Set Internet Explorer as default browser before uninstalling Chrome.


Edit Registry

If you received this error after uninstalling any application that takes over the HTML open command (including, but not limited to, Chrome & Firefox browsers) you may need to change the HTM/HTML association in the registry.

   Right click on the Start menu, click Run, type Regedit in the Open box, and then click OK.
   Browse to
   HKEY_CURRENT_USER\Software\Classes\.html
   If a default value (Default) has a value other than htmlfile or (value not set), right click on it and select Modify...
   Change the value from "ChromeHTML" to htmlfile (or from FireFoxHTML to htmlfile)
   Repeat for the .htm, shtml, .xht, .xhtml, .xhtm keys

Restart Outlook after trying this. You need to restart Windows for the change to take effect.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.