Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why is Walmart.com suddenly using huge amounts of CPU, memory and disk resources?

  • 5 replies
  • 0 have this problem
  • 30 views
  • Last reply by j.erbes

more options

When I open Firefox with a dozen tabs showing, Task Manager typically shows Firefox to be using 1.3% CPU, 715 MB Memory and 0.1 MB/s Disk. However, as soon as I open www.walmart.com in a new tab, Firefox CPU goes up to between 34% to 52%, Memory to 13,900 MB and Disk to 50 to 200 MB/s. If I reboot, it is repeatable. I have an AMD Ryzen 5 3600 with 16 GB. What's going on?

When I open Firefox with a dozen tabs showing, Task Manager typically shows Firefox to be using 1.3% CPU, 715 MB Memory and 0.1 MB/s Disk. However, as soon as I open www.walmart.com in a new tab, Firefox CPU goes up to between 34% to 52%, Memory to 13,900 MB and Disk to 50 to 200 MB/s. If I reboot, it is repeatable. I have an AMD Ryzen 5 3600 with 16 GB. What's going on?

Modified by j.erbes

Chosen solution

jscher2000 - Support Volunteer said

As an initial reality check, could you test in Firefox's Safe/Troubleshoot Mode? In that mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, Any improvement?

I went in to Extensions and disabled each of them them one-by-one. It turned out that the culprit was the extension FileCR Assistant. It has been deleted and reported to Firefox.

Read this answer in context 👍 0

All Replies (5)

more options

Hi, your Firefox reported itself to be version 88 from about 15 months ago. It may be difficult to replicate the problem in a recent version of Firefox so I'll give you a general suggestion:

As an initial reality check, could you test in Firefox's Safe/Troubleshoot Mode? In that mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running:

You can restart Firefox in Safe/Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

If Firefox is not running:

Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Any improvement?

Helpful?

more options

jscher2000 - Support Volunteer said

Your Firefox reported itself to be version 88 from about 15 months ago. As an initial reality check, could you test in Firefox's Safe/Troubleshoot Mode? In that mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem. Any improvement?

Normally, I upgrade to each new version. However, starting at v.90, the pull-down bookmark tabs began behaving very badly, with large spacing in the pull-down lists that could not be corrected.

Yes, when going into Troubleshoot Mode, Firefox seems to operate normally without excessive resource usage.

BTW, this issue does not come up on my HP Envy laptop using the same Firefox v.88

So, what next?

Modified by j.erbes

Helpful?

more options

Chosen Solution

jscher2000 - Support Volunteer said

As an initial reality check, could you test in Firefox's Safe/Troubleshoot Mode? In that mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, Any improvement?

I went in to Extensions and disabled each of them them one-by-one. It turned out that the culprit was the extension FileCR Assistant. It has been deleted and reported to Firefox.

Modified by j.erbes

Helpful?

more options

In the Firefox 92 release you can only reduce the menu spacing via userChrome.css. In Firefox 93 and later releases support for reducing the bookmarks spacing via "Density: Compact" on the Customize page has been added. Note that "Compact" is no longer present by default as a Density choice in Customize.

Helpful?

more options

cor-el said

In the Firefox 92 release you can only reduce the menu spacing via userChrome.css. In Firefox 93 and later releases support for reducing the bookmarks spacing via "Density: Compact" on the Customize page has been added. Note that "Compact" is no longer present by default as a Density choice in Customize.

Thank you, cor-el,

If I remember correctly, I believed I tried that some 15 months ago and the results were less than satisfactory. Some of my drop-down bookmark tabs have up to ~100 entries.

P.S. Are you any relation to Jor-El, superman's biological father??? If so, can you send me an autograph?

Modified by j.erbes

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.