Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox stays on Window mode

more options

So every time I open Firefox, it starts at Windowed mode, not in full screen mode. Right clicking the shortcut to select maximized in the Run section does not work for me. I would have to double click the top bar every time to get it to be full screen.

So every time I open Firefox, it starts at Windowed mode, not in full screen mode. Right clicking the shortcut to select maximized in the Run section does not work for me. I would have to double click the top bar every time to get it to be full screen.

All Replies (4)

more options

I have same problem. When I open Firefox it opens as a small window in the upper left of my screen, and then the second small window opens that is the one to enter the Firefox password. When I click the second window, it does let me enter the password. And I also have to do clicking on the small window to get it to go to full screen or to enter the password. If I have other apps open, the Firefox window almost gets hidden.

Currently running Windows 11 as of mid-December and Firefox version 96.0.1, and the problem seems to have started after the Win 11 update.

Helpful?

more options

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt xulstore.json file.

Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/Profiles
  • Linux: *~/.mozilla/firefox/Profiles
  • Windows: %AppData%\Mozilla\Firefox\Profiles
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles
  • Windows XP: C:\Documents and Settings\<user>\Application Data\Mozilla\Firefox\Profiles\

Close Firefox. Search for the above file. Then rename or delete it. Restart Firefox.

Helpful?

more options

This does not solve the problem. Maybe for others it does but not for mine. I did what you said and it still didn't work for me. Refreshing Firefox does not help either.

Modified by Sauceman64

Helpful?

more options

Sauceman64 said

So every time I open Firefox, it starts at Windowed mode, not in full screen mode. Right clicking the shortcut to select maximized in the Run section does not work for me. I would have to double click the top bar every time to get it to be full screen.

Did you enable the privacy.resistFingerprinting setting in about:config? It modifies window dimensions as one of its "blend in with the crowd" changes. I've been ignoring threads about this particular behavior, so I don't know whether there is a quick fix.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.