Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Error code SSL_ERROR_RX_MALFORMED_ALERT when connecting to Facebook only.

  • 6 replies
  • 1 has this problem
  • 4 views
  • Last reply by FredMcD

more options

Since late last night, I've been having issues connecting to Facebook when using Firefox. Through my own troubleshooting efforts, I've run multiple Virus and Malware scans via AVG, Malware Bytes, TDSS Killer and Microsoft Safety Scanner, to no avail. What doesn't help is that when checking Facebook in Chrome, the error code I get is NET::ERR_SSL_OBSOLETE_VERSION relating to TLS 1.0 and 1.1. Are there other things I should try on my end as to the cause of this issue?

To my knowledge, the issue is only with Facebook. Other websites I frequent are connecting with no issues.

Chosen solution

After a boot scan and a scan though SuperAntiSpyware to get rid of some cookies, it now works? I don't know what changed, but now it does. Problem solved? I just wish I knew what happened so it doesn't repeat.

Read this answer in context 👍 0

All Replies (6)

more options

ssl_error_rx_malformed_alert https://support.mozilla.org/en-US/questions/1024043 I used the malwareBytes' Anti-Malware, and it worked perfectly, it solved my Problem . .

Helpful?

more options

For me, Firefox makes a TLS 1.3 connection with Facebook, which is the latest level of the protocol. So it's strange that you get a message in Chrome that Facebook is preferring a lower protocol; seems very suspicious.

Before we get too arcane, have you tried doing a reboot on your router/cable modem? There may be a button for that, or it might required unplugging from power for several seconds and then plugging back in.

Do you know whether your browsing runs through a proxy server, a security software filter, or a parental controls program that could be influencing your ability to connect to Facebook?

In Firefox, there is a setting to try to bypass any system-level proxy server. You can check that here:

  • Windows: "3-bar" menu button (or Tools menu) > Settings (previously "Options")
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

Try "No proxy". Any difference?

Helpful?

more options

I did try no Proxy, and there was no difference for Firefox. Troubleshooting mode also came up with no difference unfortunately.

Helpful?

more options

I can also confirm that a router reset did not help, and a reinstall of Firefox didn't help either.

Helpful?

more options

Chosen Solution

After a boot scan and a scan though SuperAntiSpyware to get rid of some cookies, it now works? I don't know what changed, but now it does. Problem solved? I just wish I knew what happened so it doesn't repeat.

Helpful?

more options

That was very good work. Well Done.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.