Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Weird Screen font appearance problem

  • 4 replies
  • 1 has this problem
  • 25 views
  • Last reply by jscher2000

more options

This is a weird one. I would appreciate help. Please read carefully before responding....I am not a newb

Connected my new XPS laptop for the first time to my monitor. Everything looks fine (Windows 10, Chrome, other programs) EXCEPT for Firefox. In Firefox, all the text looks grainy, obviously not right. I disabled all my extensions, REFRESHED/RESET the browser, with no improvement.

But when I opened Firefox's troubleshooting mode, the browser immediately improved, became crystal clear. Also, when I took a screenshot to post here, the screenshot of the text appeared crystal clear as well. So it's definitely not the monitor.

Again, I've refreshed Firefox, and turned off all my extensions. Uninstalled and reinstalled. Still seeing grainy text. Troubleshoot mode says it turns off "extensions, themes, and custom settings" --what else does it turn off?

Any suggestions welcome.

Thanks, s.

Modified by SLG

Chosen solution

One of the key differences between regular and Troubleshoot is that hardware acceleration of graphics -- which is linked to ClearType text smoothing in Firefox -- is disabled. Which leads me to think either:

(A) Your current ClearType settings in Windows 10 cause text ugliness in Firefox (on one monitor?), or (B) Firefox is not fully compatible with your current graphics card/chipset driver software

If you need to disable hardware acceleration in normal mode, this article describes where to make that change: Firefox's performance settings. This will take effect the next time you exit Firefox and start it up again.

But you also might look at the ClearType tuner, which could have another name these days. If you type cleartype in the Windows system search box, it will suggest the relevant control panel. I don't know whether there could be different settings per display. ???

Read this answer in context 👍 1

All Replies (4)

more options

Update: just to clarify, Firefox looks great on the laptop itself. It's just on the monitor that it's super grainy. I also tried changing my display settings (100%, 150%) with no effect.

Helpful?

more options

Chosen Solution

One of the key differences between regular and Troubleshoot is that hardware acceleration of graphics -- which is linked to ClearType text smoothing in Firefox -- is disabled. Which leads me to think either:

(A) Your current ClearType settings in Windows 10 cause text ugliness in Firefox (on one monitor?), or (B) Firefox is not fully compatible with your current graphics card/chipset driver software

If you need to disable hardware acceleration in normal mode, this article describes where to make that change: Firefox's performance settings. This will take effect the next time you exit Firefox and start it up again.

But you also might look at the ClearType tuner, which could have another name these days. If you type cleartype in the Windows system search box, it will suggest the relevant control panel. I don't know whether there could be different settings per display. ???

Helpful?

more options

Yup! I unchecked the performance/acceleration setting and it looks fine now.

Thanks so much Jscher!

s.

Helpful?

more options

That works for now, but may degrade or disable certain graphics features used on sites like Google Maps. So it may be worth further research in the future.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.