Search Support

One-click search panel (multiple icons of search engines) disappeared from address bar.

  • 10 replies
  • 1 has this problem
  • 6 views
  • Last reply by 001

more options

I normally use multiple search engines by using the dropout panel with search engine icons (I think they're called one-click) on just one address bar (The red label on the image), but since last update they no longer appear on just one address bar (the blue label). I have attempted to enable the search bar, and there it seems to work so maybe its somehow hidden from the design... Is this a bug? I have browser.search.showOneOffButtons and browser.urlbar.oneOffSearches set on TRUE, and use no particular theme. Searching if someone had the same question I came with complaints asking for the panel to be removed so I wonder if its a design interface decision. Thank you in advance for your time.

Attached screenshots

Modified by 001

Chosen solution

Forgive me, I forgot to mention I had my phone synched with my computer...! The uninstall mentioned didnt solve my problem, yet I managed to solve it by disabling the option in my Firefox account of my configuration being synched, I then disconnected the device and a real clean uninstall before backing up my bookmarks in html. I hope this brief description helps other people with the issue. I truly dont understand what this new version brought to make these bugs appear but all is fine now. Good day.

Read this answer in context 👍 0

All Replies (10)

more options

The buttons should still be there, but only when you've typed something into the address bar. If you're clicking the drop-down arrow, they don't make so much sense, so they were removed.

You can search the site just by typing in the address bar and clicking the appropriate button.

Helpful?

more options

That is odd, so for you it works fine in address bar? I do understand I need to type something but it no longer shows on my address bar since last update when I do so. Maybe I didnt make myself clear, its the whole dropdown panel with icons that has vanished. To be precise, the image I marked in red in the screenshot.

Helpful?

more options

Oh, if you're not seeing any dropdown panel at all, that is a different matter...

Can you try this:

  • Restart Firefox
  • Go to the three-bar menu, select "Web Developer", the "Browser Console"
  • See if there's any errors there to being with, then also see if any errors appear when you try and interact with the address bar.

If there's no errors, try going into Options, and looking at the search panel - does that look ok?

Helpful?

more options

Im getting several errors, here is an image with them.

Helpful?

more options

Ok, they look a little strange. I'd suggest that you try Firefox Safe Modeto see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If that helps, then once you restart back into normal mode, you can selectively disable/enable your add-ons to try and find what's causing it.

Helpful?

more options

It does not seem to fix anything. And here I show you my browser console in safe mode without addons (I have a feeling those interface errors might be insightful as to what is going on).

Modified by 001

Helpful?

more options

The `Invalid chrome URI: /` messages are the most worrying, but it doesn't say where they're coming from which makes it difficult to know what's causing that.

Do you have a userChrome.css in your profile (it may be in a chrome/ sub-folder), that could be causing issues?

Also, have you changed any preferences via about:config?

Helpful?

more options

I do not have a userchrome.css file in my profile and within about:config I have merely changed:

signon.showAutoCompleteFooter signon.showAutoCompleteOrigins security.insecure_field_warning.contextual.enabled

I must say I also seem to have two profiles in my roaming folder: one named .default with just one file "times.json" and another one .default-release.

Edit: They might be related so I will say my browser no longer seems to remember to open with the window maximized even if I change the shortcut to do so. It's very odd, but both these things happen since last update.

Modified by 001

Helpful?

more options

I'm a little short on ideas here. It could be something in the profile, but I'm not sure what - I'd have expected safe mode to resolve it.

There may be others on the forum later that might be able to offer more ideas.

The other option you could try is to re-install Firefox. You might want to back up your computer first though (or at least your profiles).

The text below is our standard text about re-installing Firefox:


Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove your Firefox program files and then reinstall Firefox. This process does not remove your Firefox profile data (such as bookmarks and passwords), since that information is stored in a different location.

To do a clean reinstall of Firefox, please follow these steps: Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from mozilla.org (or choose the download for your operating system and language from this page) and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (or open the Firefox menu New Fx Menu and click the close button Close 29 ).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows: (Note: Check both folders.)
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

More information about reinstalling Firefox can be found here.

WARNING: Do not use a third party uninstaller as part of this process. Doing so could permanently delete your Firefox profile data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. These cannot be easily recovered unless they have been backed up to an external device! See Back up and restore information in Firefox profiles.

Please report back to say if this helped you!

Thank you.

Helpful?

more options

Chosen Solution

Forgive me, I forgot to mention I had my phone synched with my computer...! The uninstall mentioned didnt solve my problem, yet I managed to solve it by disabling the option in my Firefox account of my configuration being synched, I then disconnected the device and a real clean uninstall before backing up my bookmarks in html. I hope this brief description helps other people with the issue. I truly dont understand what this new version brought to make these bugs appear but all is fine now. Good day.

Modified by 001

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.