X
Tap here to go to the mobile version of the site.

Support Forum

interface language mixed between german and english

Ben
Posted

i have had this issue for a year now, with no end in sight. my interface language on my entire computer is english. everything english. the keyboard is a german keyboard because i bought my machine where i live, in austria. but my written language and all dictionaries are english. same with my preferences in firefox, english everywhere. but for some reason the language constantly switches back and forth between german and english. look at the video, it's insane. i've uninstalled and started over. i've wiped the entire computer and installed EVERYTHING fresh. no change. when i install and use firefox, it comes back. it only happens in firefox. argh. screen capture of the language switching: https://youtu.be/gq8hXs5pXm0

i have had this issue for a year now, with no end in sight. my interface language on my entire computer is english. everything english. the keyboard is a german keyboard because i bought my machine where i live, in austria. but my written language and all dictionaries are english. same with my preferences in firefox, english everywhere. but for some reason the language constantly switches back and forth between german and english. look at the video, it's insane. i've uninstalled and started over. i've wiped the entire computer and installed EVERYTHING fresh. no change. when i install and use firefox, it comes back. it only happens in firefox. argh. screen capture of the language switching: https://youtu.be/gq8hXs5pXm0

Chosen solution

Thank you for that! while those things didn't solve my problem directly, the firefox profile manager link led me to the Refresh Firefox - reset add-ons and settings option, which actually worked! it reset the default language as only german, so i added english, then moved the german down, since for whatever reason it doesn't allow me to remove it, and now everything stays in english.

the add on languages i have are only the US and British english, so that wasn't it either.

but HOORAY for refresh firefox: https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

Read this answer in context 0
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:71.0) Gecko/20100101 Firefox/71.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17876 solutions 161748 answers

Helpful Reply

This can happen if you have an old language pack installed that hasn't been updated for some reason. You can check this in "Addo-ons -> Languages". If you do not need this language pack then you can remove it. Do not confuse language packs that provide translations for strings (labels) in the user interface with dictionaries for the spell checker.

You can also check for issues with multiple profiles.

It is possible that a new default-release profile folder has been created. See "Determine if Firefox has created a new profile":

You can open the about:profiles page via the location bar to check whether multiple profiles are present and what profile Firefox currently is using.

This can happen if you have an old language pack installed that hasn't been updated for some reason. You can check this in "Addo-ons -> Languages". If you do not need this language pack then you can remove it. Do not confuse language packs that provide translations for strings (labels) in the user interface with dictionaries for the spell checker. You can also check for issues with multiple profiles. It is possible that a new default-release profile folder has been created. See "Determine if Firefox has created a new profile": *https://support.mozilla.org/en-US/kb/recover-lost-or-missing-bookmarks You can open the <b>about:profiles</b> page via the location bar to check whether multiple profiles are present and what profile Firefox currently is using. *Do NOT click any Remove button on this page. *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles *https://support.mozilla.org/en-US/kb/dedicated-profiles-firefox-installation
Was this helpful to you? 1
Quote

Chosen Solution

Thank you for that! while those things didn't solve my problem directly, the firefox profile manager link led me to the Refresh Firefox - reset add-ons and settings option, which actually worked! it reset the default language as only german, so i added english, then moved the german down, since for whatever reason it doesn't allow me to remove it, and now everything stays in english.

the add on languages i have are only the US and British english, so that wasn't it either.

but HOORAY for refresh firefox: https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

Thank you for that! while those things didn't solve my problem directly, the firefox profile manager link led me to the ''Refresh Firefox - reset add-ons and settings'' option, which actually worked! it reset the default language as only german, so i added english, then moved the german down, since for whatever reason it doesn't allow me to remove it, and now everything stays in english. the add on languages i have are only the US and British english, so that wasn't it either. but HOORAY for refresh firefox: https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings
Was this helpful to you?
Quote
vprocopan 0 solutions 1 answers

Ben said

Thank you for that! while those things didn't solve my problem directly, the firefox profile manager link led me to the Refresh Firefox - reset add-ons and settings option, which actually worked! it reset the default language as only german, so i added english, then moved the german down, since for whatever reason it doesn't allow me to remove it, and now everything stays in english. the add on languages i have are only the US and British english, so that wasn't it either. but HOORAY for refresh firefox: https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

Worked here, obviously, this is an architecture bug that needs to be fixed.

''Ben [[#answer-1271216|said]]'' <blockquote> Thank you for that! while those things didn't solve my problem directly, the firefox profile manager link led me to the ''Refresh Firefox - reset add-ons and settings'' option, which actually worked! it reset the default language as only german, so i added english, then moved the german down, since for whatever reason it doesn't allow me to remove it, and now everything stays in english. the add on languages i have are only the US and British english, so that wasn't it either. but HOORAY for refresh firefox: https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings </blockquote> Worked here, obviously, this is an architecture bug that needs to be fixed.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17876 solutions 161748 answers

You can of course also install the en-US Firefox version if you want the user interface in English and possibly install the German language pack in case you would want to check or use Firefox in German.

You can find the full version of the current Firefox release (74.0) in all languages and all operating systems here:

You can of course also install the en-US Firefox version if you want the user interface in English and possibly install the German language pack in case you would want to check or use Firefox in German. You can find the full version of the current Firefox release (74.0) in all languages and all operating systems here: *https://www.mozilla.org/en-US/firefox/all/#product-desktop-release *https://www.mozilla.org/en-US/firefox/74.0/releasenotes/
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.