Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to make firefox work with oculus rift?

  • 9 replies
  • 1 has this problem
  • 6455 views
  • Last reply by Jwsto

more options

So how exactly is firefox supposed to work with oculus rift?

If I click on the vr-button on https://aframe.io/a-saturday-night/ it just makes it fullscreen on my main monitor.

If I click the vr-button on a video it usually tells me to get a browser that supports vr.

I am using Firefox 64.0 on windows 10 desktop.

Chosen solution

All Replies (9)

more options

You can try using Firefox Reality, https://labs.mozilla.org/projects/firefox-reality/

more options

Tyler Downer said

You can try using Firefox Reality, https://labs.mozilla.org/projects/firefox-reality/

There is no Oculus rift version of it? Only Oculus go, google daydream and viveport.

more options

Problem here is if Oculus doesn't provide support for the Browser there is nothing firefox can do about it.

more options

WestEnd said

Problem here is if Oculus doesn't provide support for the Browser there is nothing firefox can do about it.

But here it says it's supported? https://webvr.rocks/

more options

Chosen Solution

perhaps this could help: View Virtual Reality with Firefox WebVR

Modified by Mick

more options

MickvdMeijde said

perhaps this could help: View Virtual Reality with Firefox WebVR

Thanks, never noticed that "Need help?" section on that site, lol. Asking there now! :)

more options

Jwsto said

Thanks, never noticed that "Need help?" section on that site, lol. Asking there now! :)

you're welcome :)

more options

@ jwsto :

Would you be so kind as to mark MickvdMeijde's post (the one that solved your problem) as Chosen Solution  ? ('Solved the problem' button to the right of that post)

Thank you in advance  !

more options

McCoy said

@ jwsto : Would you be so kind as to mark MickvdMeijde's post (the one that solved your problem) as Chosen Solution  ? ('Solved the problem' button to the right of that post) Thank you in advance  !

Sure thing!

I just managed to get it working too. I had checked nvidia control panel before but missed the right setting.

What I had to do was to choose a Power management mode: Maximum for firefox to get it working. The guide should maybe mention that too.