X
Tap here to go to the mobile version of the site.

Support Forum

Since upgrade to FF 61.0.1 Netflix stopped streaming

Posted

With the upgrade to FF 61, I finally got Fox News Channel streaming to work on FF. I have streamed Netflix on FF for years. Now I have to watch Netflix on Microsoft Edge. These continuing video issues with FF are getting tiresome. I get error code F7121-1331-P7 Solutions anyone?

With the upgrade to FF 61, I finally got Fox News Channel streaming to work on FF. I have streamed Netflix on FF for years. Now I have to watch Netflix on Microsoft Edge. These continuing video issues with FF are getting tiresome. I get error code F7121-1331-P7 Solutions anyone?

Chosen solution

I called Netflix support. They said that many Firefox users are having the same problem with the error message as I am. They said to use other browsers until Mozilla is able to address the problem. This post can be marked as the answer to my question.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 30.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; rv:61.0) Gecko/20100101 Firefox/61.0

More Information

Wesley Branton
  • Top 10 Contributor
589 solutions 4999 answers

According to the Netflix support website, this issue appears to be related to HTML5 video playback on your browser.

Try running a test using the YouTube HTML5 test page to see what formats are not supported. You should be able to have all formats enabled, although I don't think that WebM VP9 is enabled by default.

A common cause of video playback issues in Firefox is that the Media Feature Pack for Windows is not installed or was damaged by a recent Windows update. You can try downloading the Media Feature Pack for your system if not all of the formats are enabled in the YouTube test page.

More information about the Media Feature Pack for Windows can be found in the Fix video and audio playback problems on Firefox for Windows support documentation.

According to [https://help.netflix.com/en/node/61874 the Netflix support website], this issue appears to be related to HTML5 video playback on your browser. Try running a test using the [https://www.youtube.com/html5 YouTube HTML5 test page] to see what formats are not supported. You should be able to have all formats enabled, although I don't think that WebM VP9 is enabled by default. A common cause of video playback issues in Firefox is that the Media Feature Pack for Windows is not installed or was damaged by a recent Windows update. You can try downloading the Media Feature Pack for your system if not all of the formats are enabled in the YouTube test page. More information about the Media Feature Pack for Windows can be found in the [[Fix video and audio playback problems on Firefox for Windows]] support documentation.

Question owner

Wesley, Your post is too techy for me. Please explain to me in everyday language. I followed your first link to Netflix support, but it just said the problem is with HTML5. Like that helps! Then I followed your link to YouTube, but I do not know how to interpret the page. Does it mean FF supports HTML5 or not. I can't interpret the page. Then I followed your link to FF support. It seems to say update Windows 10. But Win 10 is up-to-date. Furthermore Edge streams Netflix without problem. So does IE11. So it seems it is FF that is broken not Windows 10. FF used to be a great browser.

Wesley, Your post is too techy for me. Please explain to me in everyday language. I followed your first link to Netflix support, but it just said the problem is with HTML5. Like that helps! Then I followed your link to YouTube, but I do not know how to interpret the page. Does it mean FF supports HTML5 or not. I can't interpret the page. Then I followed your link to FF support. It seems to say update Windows 10. But Win 10 is up-to-date. Furthermore Edge streams Netflix without problem. So does IE11. So it seems it is FF that is broken not Windows 10. FF used to be a great browser.
Wesley Branton
  • Top 10 Contributor
589 solutions 4999 answers

Ok, I'll do my best to explain :)

HTML5 is the program used to play videos online. The Netflix error code that you are receiving says that HTML5 is not supported by your browser, Firefox. However, that's not true because Firefox comes with support for HTML5, so there is an issue that is making it so that Netflix believes that HTML5 is not active on Firefox.

The YouTube page that I linked in my previous response will show you which HTML5 features are enabled and working on your browser currently. In most cases, the feature that is used is called H.264. On that test page on YouTube, you will see either a blue check mark or red exclamation point next to each HTML5 feature to show whether it's enabled or disabled. We need to know which of those features are disabled.

A lot of these features, including the commonly used H.264 feature, depend on software installed on your operating system, in this case Windows 10. There is a software called the Media Feature Pack. If there is something wrong with that software, videos may not play properly in HTML5. It's common for this software to get damaged when you update Windows 10 or when Windows 10 automatically updates in the background. Therefore, reinstalling that software usually fixes the issue.

I hope I explained it a little better for you. I know it can be complicated if it's not something that you deal with on a daily basis.

Ok, I'll do my best to explain :) HTML5 is the program used to play videos online. The Netflix error code that you are receiving says that HTML5 is not supported by your browser, Firefox. However, that's not true because Firefox comes with support for HTML5, so there is an issue that is making it so that Netflix believes that HTML5 is not active on Firefox. The YouTube page that I linked in my previous response will show you which HTML5 features are enabled and working on your browser currently. In most cases, the feature that is used is called ''H.264''. On that test page on YouTube, you will see either a blue check mark or red exclamation point next to each HTML5 feature to show whether it's enabled or disabled. We need to know which of those features are disabled. A lot of these features, including the commonly used ''H.264'' feature, depend on software installed on your operating system, in this case Windows 10. There is a software called the Media Feature Pack. If there is something wrong with that software, videos may not play properly in HTML5. It's common for this software to get damaged when you update Windows 10 or when Windows 10 automatically updates in the background. Therefore, reinstalling that software usually fixes the issue. I hope I explained it a little better for you. I know it can be complicated if it's not something that you deal with on a daily basis.

Question owner

He is a screenshot of the YouTube page that you wanted me to link to. You tell me what it means. What does YouTube have to do with Netflix anyway? Windows 10 is up-to-date version 1803. Latest cumulative update July 11.

He is a screenshot of the YouTube page that you wanted me to link to. You tell me what it means. What does YouTube have to do with Netflix anyway? Windows 10 is up-to-date version 1803. Latest cumulative update July 11.

Modified by loyall

Wesley Branton
  • Top 10 Contributor
589 solutions 4999 answers

To clarify, YouTube has nothing to do with Netflix. YouTube simply has an HTML5 testing tool that we often direct users to so that they can make sure that HTML5 is working.

Try the following:

  1. Type about:config in the Firefox address bar at the top of the screen
  2. Bypass the security warning that will appear
  3. In the search bar that is on that page, type med*ena

This should display all preferences in Firefox that say media.something.enabled. It's possible that some of these preferences were changed and are stopping video from working properly on Firefox.

If there are any bolded preferences listed on that screen, right click on them and select Reset.

Once you are done that, find the media.mediasource.webm.enabled preference and double click it to change it's value from false to true.

Once you have finished that, restart your computer and try running Netflix again. Also, return to the YouTube test page that I linked in my first response and see if the MSE & WebM VP9 feature now has a blue checkmark next to it.

Hope this helps.

To clarify, YouTube has nothing to do with Netflix. YouTube simply has an HTML5 testing tool that we often direct users to so that they can make sure that HTML5 is working. Try the following: #Type <code>about:config</code> in the Firefox address bar at the top of the screen #Bypass the security warning that will appear #In the search bar that is on that page, type <code>med*ena</code> This should display all preferences in Firefox that say <code>media.''something''.enabled</code>. It's possible that some of these preferences were changed and are stopping video from working properly on Firefox. If there are any bolded preferences listed on that screen, right click on them and select ''Reset''. Once you are done that, find the <code>media.mediasource.webm.enabled</code> preference and double click it to change it's value from <code>false</code> to <code>true</code>. Once you have finished that, restart your computer and try running Netflix again. Also, return to the YouTube test page that I linked in my first response and see if the ''MSE & WebM VP9'' feature now has a blue checkmark next to it. Hope this helps.

Question owner

Wesley, I am glad you are helping me. But why did you ignore my question? How do you interpret the YouTube screenshot that I posted? Remember, you told me to interpret it. Please tell me that before I launch into the steps you posted above.

Wesley, I am glad you are helping me. But why did you ignore my question? How do '''you''' interpret the YouTube screenshot that I posted? Remember, you told me to interpret it. Please tell me that before I launch into the steps you posted above.
Shadow110 1072 solutions 14836 answers

Hi, please look at the screen shot you provided and it will show a red box with a white exclamation mark.

Wesely has provided you the information to check if that is turn on or if it is off follow his instruction to turn it on, Restart Firefox after then return to the youtube page to check if the box is now checked like the others.

Hi, please look at the screen shot you provided and it will show a red box with a white exclamation mark. Wesely has provided you the information to check if that is turn on or if it is off follow his instruction to turn it on, Restart Firefox after then return to the youtube page to check if the box is now checked like the others.

Question owner

Pkshadow, If you don't mind, please stay out of my dialogue with Wesley. I think we are beginning to make progress.

Pkshadow, If you don't mind, please stay out of my dialogue with Wesley. I think we are beginning to make progress.

Question owner

I repeat Wesley, I am glad you are helping me. But why did you ignore my question? How do you interpret the YouTube screenshot that I posted? I interpret it to mean that HTML5 is working. Remember, you told me to interpret it. Please tell me that before I launch into the steps you posted above.

I repeat Wesley, I am glad you are helping me. But why did you ignore my question? How do you interpret the YouTube screenshot that I posted? I interpret it to mean that HTML5 is working. Remember, you told me to interpret it. Please tell me that before I launch into the steps you posted above.
Wesley Branton
  • Top 10 Contributor
589 solutions 4999 answers

The screenshot shows that all of the HTML5 features appear to be working in your Firefox browser, except for MSE & WebM VP9. This is usually normal, since not every system will have that feature enabled by default. The steps I posted above will attempt to get this feature working and hopefully resolve the issue that you are having with Netflix.

The screenshot shows that all of the HTML5 features appear to be working in your Firefox browser, except for MSE & WebM VP9. This is usually normal, since not every system will have that feature enabled by default. The steps I posted above will attempt to get this feature working and hopefully resolve the issue that you are having with Netflix.
cor-el
  • Top 10 Contributor
  • Moderator
17467 solutions 157838 answers

Do you have "Resist Fingerprinting" enabled?

You can check this pref on the about:config page to see if resist fingerprinting (RFP) is enabled and if this pref is user set (bold) reset to false via the right-click context menu.

  • privacy.resistFingerprinting = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Do you have "Resist Fingerprinting" enabled? You can check this pref on the <b>about:config</b> page to see if resist fingerprinting (RFP) is enabled and if this pref is user set (bold) reset to false via the right-click context menu. *privacy.resistFingerprinting = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config

Question owner

Wesley Branton said

The screenshot shows that all of the HTML5 features appear to be working in your Firefox browser, except for MSE & WebM VP9. This is usually normal, since not every system will have that feature enabled by default. The steps I posted above will attempt to get this feature working and hopefully resolve the issue that you are having with Netflix.

Wesley, I thank you for getting back. However, I am still not clear. The Netflix site said that the error message was due to HTML5. The YouTube site said that HTML5 was working. You confirmed that it is normal for the other video feature MSE not to be working. Why, if HTML5 is working, should I concern myself with MSE? When I accesss the YouTube test page in Edge MSE & WebM VP9 is also not working, and yet Netflix streams fine on Edge.

''Wesley Branton [[#answer-1134384|said]]'' <blockquote> The screenshot shows that all of the HTML5 features appear to be working in your Firefox browser, except for MSE & WebM VP9. This is usually normal, since not every system will have that feature enabled by default. The steps I posted above will attempt to get this feature working and hopefully resolve the issue that you are having with Netflix. </blockquote> Wesley, I thank you for getting back. However, I am still not clear. The Netflix site said that the error message was due to HTML5. The YouTube site said that HTML5 was working. You confirmed that it is normal for the other video feature MSE not to be working. Why, if HTML5 is working, should I concern myself with MSE? When I accesss the YouTube test page in Edge MSE & WebM VP9 is also not working, and yet Netflix streams fine on Edge.

Modified by loyall

Question owner

cor-el, I opened about:config as you directed, and I found that privacy.resistFingerprinting has the value false. Do you have any further thoughts about my Netflix video error message? Do you think Wesley is correct that I should be concerned about MSE & WebM VP9?

cor-el, I opened about:config as you directed, and I found that privacy.resistFingerprinting has the value false. Do you have any further thoughts about my Netflix video error message? Do you think Wesley is correct that I should be concerned about MSE & WebM VP9?
MattB62 0 solutions 4 answers

Same problem . . . none of the above proposed solutions work. Will be grateful for a solution.

Same problem . . . none of the above proposed solutions work. Will be grateful for a solution.
Wesley Branton
  • Top 10 Contributor
589 solutions 4999 answers

The YouTube test page showed that all HTML5 features are working properly, except for MSE & WebM VP9. It's not uncommon for that feature to be disabled by default on many computers.

However, if Netflix uses that specific feature (not sure if they do or not) or if Netflix checks to see if that feature is working properly, then it will fail and give you an error message.

The YouTube test page showed that all HTML5 features are working properly, except for MSE & WebM VP9. It's not uncommon for that feature to be disabled by default on many computers. However, if Netflix uses that specific feature (not sure if they do or not) or if Netflix checks to see if that feature is working properly, then it will fail and give you an error message.
Wesley Branton
  • Top 10 Contributor
589 solutions 4999 answers

Helpful Reply

I was discussing the issue with some of the other volunteers on this forum and there seems to be a bug that appeared starting in Firefox 60 with Netflix (see bug 1447085). Apparently, if you have your History setting in the Privacy & Security tab of the Firefox settings set to Never remember history, then Netflix will not work properly.

Please check your settings to see if that's what is causing your problem.

I was discussing the issue with some of the other volunteers on this forum and there seems to be a bug that appeared starting in Firefox 60 with Netflix ([https://bugzilla.mozilla.org/show_bug.cgi?id=1447085 see bug 1447085]). Apparently, if you have your ''History'' setting in the ''Privacy & Security'' tab of the Firefox settings set to ''Never remember history'', then Netflix will not work properly. Please check your settings to see if that's what is causing your problem.

Question owner

Ok Wesley, I am going to answer a number of questions that you have asked me so bear with me. You asked if FF was set to "Never remember history" No. It is set to remember. You asked me to go to about:config and check for bolded media preferences. There were none. You asked me to change the value of media.mediasource.webm.enabled from false to true. I did. The result was the Netflix login was messed up. It failed to ask who was watching. So I reset it to False. While it was set to true I went to the YouTube test site and MSE & WebM VP9 had a blue check. Now that it has been set back to false the Netflix login remains messed up. Now you have created another problem for me.

Ok Wesley, I am going to answer a number of questions that you have asked me so bear with me. You asked if FF was set to "Never remember history" No. It is set to remember. You asked me to go to about:config and check for bolded media preferences. There were none. You asked me to change the value of media.mediasource.webm.enabled from false to true. I did. The result was the Netflix login was messed up. It failed to ask who was watching. '''So I reset it to False'''. While it was set to true I went to the YouTube test site and MSE & WebM VP9 had a blue check. Now that it has been set back to false the Netflix login remains messed up. Now you have created another problem for me.

Question owner

Wesley, I fixed the Netflix login problem by deleting all the Netflix cookies. Error code F7121-1331-P7 still appears on FF but still not on MS Edge.

Wesley, I fixed the Netflix login problem by deleting all the Netflix cookies. Error code F7121-1331-P7 still appears on FF but still not on MS Edge.
Wesley Branton
  • Top 10 Contributor
589 solutions 4999 answers

Did you try Netflix with the media.mediasource.webm.enabled set to true? I know you had to reset it back to false because you understandably thought it caused the login screen issue, but did you try setting it back to true again to test.

That preference wouldn't cause the Netflix login page to have issues like that. It was purely a coincidence that the Netflix login page stopped working at the same time that you changed the preference.

Did you try Netflix with the <code>media.mediasource.webm.enabled</code> set to <code>true</code>? I know you had to reset it back to <code>false</code> because you understandably thought it caused the login screen issue, but did you try setting it back to <code>true</code> again to test. That preference wouldn't cause the Netflix login page to have issues like that. It was purely a coincidence that the Netflix login page stopped working at the same time that you changed the preference.
cor-el
  • Top 10 Contributor
  • Moderator
17467 solutions 157838 answers

Can you post a screenshot of the Web Console to see if there are media related messages?

You can find this item in the Web Developer sub menu or use the Ctrl+Shift+K keyboard shortcut.

  • "3-bar" menu button (or Tools menu) -> Web Developer
  • you can tap the Alt key or press the F10 key to show the hidden Menu Bar temporarily

More info:

Can you post a screenshot of the Web Console to see if there are media related messages? You can find this item in the Web Developer sub menu or use the Ctrl+Shift+K keyboard shortcut. *"3-bar" menu button (or Tools menu) -> Web Developer *you can tap the Alt key or press the F10 key to show the hidden Menu Bar temporarily More info: *https://developer.mozilla.org/en/Tools/Web_Console