Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I click under web browser firefox does not come up.

  • 3 replies
  • 1 has this problem
  • 21 views
  • Last reply by PAR47

more options

I followed instructions: settings, apps, default apps, click entry under web browser and when the window comes up there is no Firefox listed. Firefox is installed and updated. Now what?

Chosen solution

Nothing worked. Still get the window saying "Firefox not currently set as default browser" and the "Use Firefox as my default browser" to click on. Then same process. It won't set as my default.

Read this answer in context 👍 0

All Replies (3)

more options

You go to where you were and then if Click on Edge and if it does not show Firefox listed as something you can change to then there are 3 other options to choose how to setup default apps at the bottom of the same page.

Choose Default Apps by File Type HTML, HTTP, HTTPS Choose Default Apps by Protocol Set Defaults by App

Please let us know if this solved your issue or if need further assistance.

more options

Chosen Solution

Nothing worked. Still get the window saying "Firefox not currently set as default browser" and the "Use Firefox as my default browser" to click on. Then same process. It won't set as my default.

more options

Now I'm curious. Should I uninstall Firefox and re-install to see if that will make a difference?