Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

good for other web sites, but can't get "Bayareafasttrack.org" why

  • 1 reply
  • 1 has this problem
  • 54 views
  • Last reply by Happy112

more options

Been trying for weeks always the same results . Times out. can't find web site. Called them they have no answer no nothing. wont or cant transfer me to their It dept. Is Mozilla blocking this site ???? this is a regular site used by millions to pay bridge tolls for the Golden Gate Bridge. I have windows 10 and Norton are they somehow blocking access, and the latest Firefox version??

Been trying for weeks always the same results . Times out. can't find web site. Called them they have no answer no nothing. wont or cant transfer me to their It dept. Is Mozilla blocking this site ???? this is a regular site used by millions to pay bridge tolls for the Golden Gate Bridge. I have windows 10 and Norton are they somehow blocking access, and the latest Firefox version??

All Replies (1)

more options

Hi  !

I have no problem accessing that site, so would you follow these steps please :

You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. Hold down the Shift key and left-click the Reload button or press 'Ctrl + F5' or press 'Ctrl + Shift + R'

Another thing to try : Clear the cache and cookies only from websites that cause problems.

Clear the Cache:

3-bar menu => Options => Advanced => Network => Cached Web Content :
"Clear Now"

Remove Cookies from sites causing problems:

3-bar menu => Options => Privacy => Cookies : "Show Cookies"


If the above doesn't do the trick, then let's try Firefox in Safe Mode : If Firefox is not running : Hold down the Shift key when starting Firefox. If Firefox is running : 3-bar menu => ' ? ' (at the bottom of the dropdown) => 'Restart with Add-ons disabled'. Then OK the restart. A small dialog should appear. Click 'Start in Safe Mode' ( not 'Refresh' !)

See : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode


Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:


Your system details show that you need to update your Adobe Flash Player, so would you please uninstall your current version and install the latest version, which is 27.0.0.170

Uninstaller : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html

You can download te latest version from here : https://get.adobe.com/flashplayer/

Note : some 'extras' may be offered in the download.


Any luck  ?