X
Tap here to go to the mobile version of the site.

Support Forum

Firefox makes me redownload the flash game everytime

Posted

The problem is probably with the cache. If I clear it, for a while, everything works fine but after a while, when the cache stored on my pc has reached a certain amount (near the maximum), that problem happens again.

Clearing everytime and redownloading everything is honestly, really annoying.

Is there a way to make Firefox delete cache older than a certain amount of time on its own and keep recent ones only? Honestly, I'm using Firefox to play 2 games only and for some reasons, the cache continue to grow even though I do the same thing everytime and I find it weird. They are Japanese Flash games and don't seem to work that well on Chrome and I don't use IE so I use Firefox only for those 2 games... I think the way Firefox's cache works is weird...

The problem is probably with the cache. If I clear it, for a while, everything works fine but after a while, when the cache stored on my pc has reached a certain amount (near the maximum), that problem happens again. Clearing everytime and redownloading everything is honestly, really annoying. Is there a way to make Firefox delete cache older than a certain amount of time on its own and keep recent ones only? Honestly, I'm using Firefox to play 2 games only and for some reasons, the cache continue to grow even though I do the same thing everytime and I find it weird. They are Japanese Flash games and don't seem to work that well on Chrome and I don't use IE so I use Firefox only for those 2 games... I think the way Firefox's cache works is weird...

Chosen solution

Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.111 Safari/537.36

More Information

Question owner

Ah, sorry, I meant like the recycle bin.

When the cache is at its limit, the new cache overwrites the older one or something. Because the way Firefox works on default is really not convenient. I don't know why but when the cache is at its limit, it just kinda stops using what is stored on the pc or something. Like I said, I only use it for 2 games so I don't really have other cache on it and yet Firefox redownloads the whole game everytime once it reaches the limit.

Is there a way to make Firefox behave this way? Or any other solutions other than regularly delete cache or increasing size?

Ah, sorry, I meant like the recycle bin. When the cache is at its limit, the new cache overwrites the older one or something. Because the way Firefox works on default is really not convenient. I don't know why but when the cache is at its limit, it just kinda stops using what is stored on the pc or something. Like I said, I only use it for 2 games so I don't really have other cache on it and yet Firefox redownloads the whole game everytime once it reaches the limit. Is there a way to make Firefox behave this way? Or any other solutions other than regularly delete cache or increasing size?
FredMcD
  • Top 10 Contributor
4307 solutions 60472 answers

Chosen Solution

Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

'''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart.

Question owner

Hm...

I lowered my cache limit to 100Mb which was what I was currently near to, surfed around, tried to refresh that game page many times and it seems to have fixed the problem. I used to have to redownload the game whenever I refreshed the page.

Have no idea why this fixed the problem but anyway, thanks a lot!

Hm... I lowered my cache limit to 100Mb which was what I was currently near to, surfed around, tried to refresh that game page many times and it seems to have fixed the problem. I used to have to redownload the game whenever I refreshed the page. Have no idea why this fixed the problem but anyway, thanks a lot!
FredMcD
  • Top 10 Contributor
4307 solutions 60472 answers

Well . . . If it works, then it works. Good luck.

Well . . . If it works, then it works. Good luck.