X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Fuzzy and blurry text since Windows 8.1 installation.

Inserita

Some text on different websites appear blurry or distorted since I installed Windows 8.1. Passing the mouse cursor above the text or scrolling will usually solve the problem temporarily.

I'm starting a new thread on this because it appears to be associated with the new operating system and not any newer version of Firefox.

Any suggestions would be welcome.

Thanks.

Some text on different websites appear blurry or distorted since I installed Windows 8.1. Passing the mouse cursor above the text or scrolling will usually solve the problem temporarily. I'm starting a new thread on this because it appears to be associated with the new operating system and not any newer version of Firefox. Any suggestions would be welcome. Thanks.

Soluzione scelta

hello, it may be an issue with hardware acceleration - please try updating your graphics driver, or in case this doesn't solve the issue or there is no new version available at the moment, disable hardware acceleration in firefox > options > advanced > general.

Leggere questa risposta nel contesto 13

Dettagli aggiuntivi sul sistema

Plugin installati

  • Shockwave Flash 11.9 r900
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.20913.0
  • AppWorld NPAPI plugin
  • BlackBerry WebSL Browser Plug-In
  • VLC media player Web Plugin 2.0.6
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • A component of your photo software powered by RocketLife

Applicazione

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

Ulteriori informazioni

philipp
  • Top 25 Contributor
  • Moderator
5079 soluzioni 22517 risposte

Soluzione scelta

hello, it may be an issue with hardware acceleration - please try updating your graphics driver, or in case this doesn't solve the issue or there is no new version available at the moment, disable hardware acceleration in firefox > options > advanced > general.

hello, it may be an issue with hardware acceleration - please try [[Upgrade your graphics drivers to use hardware acceleration and WebGL|updating your graphics driver]], or in case this doesn't solve the issue or there is no new version available at the moment, disable hardware acceleration in ''firefox > options > advanced > general''.

Utente che ha posto la domanda

Thanks phillip! That did help, but I feel like I'm missing something by not having that hardware accelerator.

Thanks phillip! That did help, but I feel like I'm missing something by not having that hardware accelerator.
WickedGirl 0 soluzioni 13 risposte

Hi scotmail...I have the same exact problem as you, and I have spent the entire day researching and troubleshooting the issue. At the moment, uninstalling and reinstalling Firefox, Adobe Flash, and Java do nothing for the problem, so don't waste your time with those.

Using a clean FF profile has not given me a definitive answer. Do you use Norton by chance with the toolbars installed and enabled? I suspect Norton somewhat, but I am not sure.

Two possible solutions I have come across, besides disabling hardware acceleration, are going through the Clear Type adjustment set up in Windows control panel and also in Firefox, try pressing alt, View, Zoom, Reset (or CTRL + 0 for the short version). To go through clear type set up, go to Windows control panel and type adjust clear type in the search bar. Then go through that process. It really helped me, although I am not sure the problem is cured. Oops, never mind, it is not cured, though it does adjust itself out more quickly now. I will also try changing my font in Firefox next to Arial or something.

One last thing, I came across an add-on that I have not tried yet called Anti-Aliasing Tuner. If the clear type adjustment does not fix my issue, I will try the add-on next. Off loading my graphics onto my CPU instead of my GPU by disabling hardware acceleration is an absolute last resort for me because of the age of my laptop. Likewise, updating the video drivers. I have to use Microsoft's provided driver, because if I update, I can no longer play Adera for some weird reason.

Good luck!

Hi scotmail...I have the same exact problem as you, and I have spent the entire day researching and troubleshooting the issue. At the moment, uninstalling and reinstalling Firefox, Adobe Flash, and Java do nothing for the problem, so don't waste your time with those. Using a clean FF profile has not given me a definitive answer. Do you use Norton by chance with the toolbars installed and enabled? I suspect Norton somewhat, but I am not sure. Two possible solutions I have come across, besides disabling hardware acceleration, are going through the Clear Type adjustment set up in Windows control panel and also in Firefox, try pressing alt, View, Zoom, Reset (or CTRL + 0 for the short version). To go through clear type set up, go to Windows control panel and type adjust clear type in the search bar. Then go through that process. It really helped me, although I am not sure the problem is cured. Oops, never mind, it is not cured, though it does adjust itself out more quickly now. I will also try changing my font in Firefox next to Arial or something. One last thing, I came across an add-on that I have not tried yet called Anti-Aliasing Tuner. If the clear type adjustment does not fix my issue, I will try the add-on next. Off loading my graphics onto my CPU instead of my GPU by disabling hardware acceleration is an absolute last resort for me because of the age of my laptop. Likewise, updating the video drivers. I have to use Microsoft's provided driver, because if I update, I can no longer play Adera for some weird reason. Good luck!

Modificato da WickedGirl il

Anthoncon 0 soluzioni 4 risposte

I have exactly the same problem on several websites. This problem does not occur with IE 11. So it's a problem with my Firefox 24.0 and not with graphics driver.

I have exactly the same problem on several websites. This problem does not occur with IE 11. So it's a problem with my Firefox 24.0 and not with graphics driver.
NamevacFR 0 soluzioni 1 risposte

Risposta utile

Hello,

I Had the exact same issue, only with Firefox 24 (works on IE11 or Chrome)

  1. Tried to install the last (legacy) graphic drivers on my AMD HD4530 : NOK
  2. Created a new Firefox profile : NOK

Until I reached this thread dealing with the same problem : experiencing corrupt text in firefox

Did, as suggested: Try to set the gfx.content.azure.enabled pref to false [...] on the about:config page and leave hardware acceleration otherwise enabled. That way you still have the benefit from hardware acceleration, but may not suffer from rendering issues.

Works like a charm now ;)

Btw, If you want more informations about the Azure Project, you can check this link

Hello, I Had the exact same issue, only with Firefox 24 (works on IE11 or Chrome) #Tried to install the last (legacy) graphic drivers on my AMD HD4530 : NOK # Created a new Firefox profile : NOK Until I reached this thread dealing with the same problem : [https://support.mozilla.org/fr/questions/960661 experiencing corrupt text in firefox] Did, as suggested: Try to '''set the gfx.content.azure.enabled pref to false''' [...] on the '''about:config''' page and leave hardware acceleration otherwise enabled. That way you still have the benefit from hardware acceleration, but may not suffer from rendering issues. Works like a charm now ;) Btw, If you want more informations about the Azure Project, you can check this [http://blog.mozilla.org/joe/2011/04/26/introducing-the-azure-project/ link]
WickedGirl 0 soluzioni 13 risposte

Namevac, thanks so much for this info! I will try it out. I posted to that thread that you provided the following:

"...I would like to add my experiences so far. I am suffering from this exact problem as well. Firefox 24 and 24b10 both have the problem, and only since I upgraded to Windows 8.1. A full uninstall and reinstall of Firefox and clean profile troubleshooting does not help. I have noticed something, however, I think. This issue seems to only occur with Sans Serif or Serif type? MAYBE Times New Roman as well. I am still working on figuring this one out, but the reason I mention this is that the issue is especially noticable when posting in forum boxes where the default font used in Sans Serif. Anyone else? "

I like to use the lowest tweak necessary to achieve a desired result, in order to "touch" as few other settings as possible. With that in mind, if this can be reduced to a simple default font change in Firefox for now, I would love to do that instead of changing the gfx.content.azure settings.

I will also use your link to read up on Azure, since it seems it may ruin my Firefox experience?

Namevac, thanks so much for this info! I will try it out. I posted to that thread that you provided the following: "...I would like to add my experiences so far. I am suffering from this exact problem as well. Firefox 24 and 24b10 both have the problem, and only since I upgraded to Windows 8.1. A full uninstall and reinstall of Firefox and clean profile troubleshooting does not help. I have noticed something, however, I think. This issue seems to only occur with Sans Serif or Serif type? MAYBE Times New Roman as well. I am still working on figuring this one out, but the reason I mention this is that the issue is especially noticable when posting in forum boxes where the default font used in Sans Serif. Anyone else? " I like to use the lowest tweak necessary to achieve a desired result, in order to "touch" as few other settings as possible. With that in mind, if this can be reduced to a simple default font change in Firefox for now, I would love to do that instead of changing the gfx.content.azure settings. I will also use your link to read up on Azure, since it seems it may ruin my Firefox experience?
Anthoncon 0 soluzioni 4 risposte

NamevacFR,

Many thanks it worked perfectly. I did not need to enact your steps ! and 2. Changing the gfxcontent from true to false did the trick.

One wonders why Mozilla have not issued an update to avoid this niggling problem.

NamevacFR, Many thanks it worked perfectly. I did not need to enact your steps ! and 2. Changing the gfxcontent from true to false did the trick. One wonders why Mozilla have not issued an update to avoid this niggling problem.
moikk 0 soluzioni 1 risposte

Risposta utile

I have actually seen this problem on various applications (Chrome, Firefox, Yahoo Messenger, etc.) One easy solution is to right click the application icon and select properties. On the compatibility tab, check the option that says "disable display scaling on high DPI settings". The next time you open the application, the problem should be gone.

I have actually seen this problem on various applications (Chrome, Firefox, Yahoo Messenger, etc.) One easy solution is to right click the application icon and select properties. On the compatibility tab, check the option that says "disable display scaling on high DPI settings". The next time you open the application, the problem should be gone.

Modificato da moikk il

WayOutWest 0 soluzioni 1 risposte

Although moikk's solution will fix the problem, it's actually not the best option. If you turn disable display scaling on high DPI settings, you'll end up with websites looking very small in Firefox because they display at their native resolution (you'll also need to do it for all of your programs, which isn't ideal).

Microsoft introduced this feature to counteract this, and effectively zoom in on pages so they take up more of the browser window.

Unfortunately, they made the decision in Windows 8.1 to try to 'improve' the scaling of fonts, but this doesn't really work, so you need to turn that feature off.

To do this, right click on your desktop and choose Screen Resolution, then click 'Make text and other items larger or smaller', then check the box alongside 'Let me choose one scaling level for all my displays' and boom, problem solved. You'll notice all of your apps will return to their former glory, before the Windows 8.1 update.

Spread the word people.

Although moikk's solution will fix the problem, it's actually not the best option. If you turn disable display scaling on high DPI settings, you'll end up with websites looking very small in Firefox because they display at their native resolution (you'll also need to do it for all of your programs, which isn't ideal). Microsoft introduced this feature to counteract this, and effectively zoom in on pages so they take up more of the browser window. Unfortunately, they made the decision in Windows 8.1 to try to 'improve' the scaling of fonts, but this doesn't really work, so you need to turn that feature off. To do this, right click on your desktop and choose Screen Resolution, then click 'Make text and other items larger or smaller', then check the box alongside 'Let me choose one scaling level for all my displays' and boom, problem solved. You'll notice all of your apps will return to their former glory, before the Windows 8.1 update. Spread the word people.
Nehemoth 0 soluzioni 1 risposte

Follow both of these options but didn't work, installed this add on http://www.askvg.com/anti-aliasing-tuner-mozilla-firefox-4-0-add-on-to-fix-font-problem/

and choose the options Gamma 1800, Enhanced costrast 50%, ClearTyoe Level 50% and Anti-aliasing mode ClearType, the change was automaticaly, didn't even has to close Firefox.

Follow both of these options but didn't work, installed this add on http://www.askvg.com/anti-aliasing-tuner-mozilla-firefox-4-0-add-on-to-fix-font-problem/ and choose the options Gamma 1800, Enhanced costrast 50%, ClearTyoe Level 50% and Anti-aliasing mode ClearType, the change was automaticaly, didn't even has to close Firefox.
GowerMick 0 soluzioni 4 risposte

I have seen all the solutions posted so far, but none seem to have come up with a satisfactory resolution to the problem!

Issue seems to have been around since Firefox 24, yet we are now at Firefox 26 and still problem persists. If the third party fix works (anti-aliasing-tuner etc), why can't this be done within firefox itself, and an update issued. I certainly don't wish to apply unnecesary add-ons I'm not sure of.

I know the problem isn't of our making (thanks Redmond), but surely the firefox developers must have found a solution by now!

It was MS that caused me to go the Firefox, Thunderbird and Open Office route in first place. Please don't make me abandon Firefox.

I have seen all the solutions posted so far, but none seem to have come up with a satisfactory resolution to the problem! Issue seems to have been around since Firefox 24, yet we are now at Firefox 26 and still problem persists. If the third party fix works (anti-aliasing-tuner etc), why can't this be done within firefox itself, and an update issued. I certainly don't wish to apply unnecesary add-ons I'm not sure of. I know the problem isn't of our making (thanks Redmond), but surely the firefox developers must have found a solution by now! It was MS that caused me to go the Firefox, Thunderbird and Open Office route in first place. Please don't make me abandon Firefox.
WickedGirl 0 soluzioni 13 risposte

GowerMick...just so you know, NONE of the proposed fixes works, not even anti-aliasing tuner. The only thing that DOES work for me....changing to Pale Moon web browser. I find this curious, since Pale Moon is built on Firefox. So, when they stripped out all the extraneous crap from Firefox to build Pale Moon and make it behave like the old speedy FF, which part exactly did they remove that prevents this font display problem. In the meantime, I made the permanent switch, and I am happy that I did.

GowerMick...just so you know, NONE of the proposed fixes works, not even anti-aliasing tuner. The only thing that DOES work for me....changing to Pale Moon web browser. I find this curious, since Pale Moon is built on Firefox. So, when they stripped out all the extraneous crap from Firefox to build Pale Moon and make it behave like the old speedy FF, which part exactly did they remove that prevents this font display problem. In the meantime, I made the permanent switch, and I am happy that I did.
Anthoncon 0 soluzioni 4 risposte

I'm on Windows 8.1 and when I updated from FF27 to FF28 I got the fizzy text again. Previously I used this fix that worked OK:

"Did, as suggested: Try to set the gfx.content.azure.enabled pref to false [...] on the about:config page and leave hardware acceleration otherwise enabled. That way you still have the benefit from hardware acceleration, but may not suffer from rendering issues."

I've already got it enabled to false so what next?

I'm on Windows 8.1 and when I updated from FF27 to FF28 I got the fizzy text again. Previously I used this fix that worked OK: "Did, as suggested: Try to set the gfx.content.azure.enabled pref to false [...] on the about:config page and leave hardware acceleration otherwise enabled. That way you still have the benefit from hardware acceleration, but may not suffer from rendering issues." I've already got it enabled to false so what next?