Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

My in-page html links don't work in Firefox.

  • 6 risposte
  • 18 hanno questo problema
  • 21513 visualizzazioni
  • Ultima risposta di Kristina_A

more options

I've made som links within the same page in HTML, and they don't function in Firefox, though they work just fine in IE. I've already tried everything on this page: https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems?esab=a&s=links+don%27t+work+in+firefox&r=19&as=s

This has been a problem for years now. Why don't in-page anchor links work? I'm just using html with Wordpad to create my pages, not any CSS.

Soluzione scelta

House Rules at the top of the page.

<a href="#PCgen">Character generation</a>
<a name="#PCgen"><center> 
	<img src="KFR0 images/buts/bar swordcloth.gif" width=500 height=80>
</a></center>

This would be the correct manner. Dump the # and close that a name tag immediately.

 <a name="PCgen"></a> <center> 
	<img src="KFR0 images/buts/bar swordcloth.gif" width=500 height=80>
</center> 
Leggere questa risposta nel contesto 👍 1

Tutte le risposte (6)

more options

Do those hyperlinks conform to W3C standards?
http://www.w3.org/TR/html401/struct/links.html

Do you have an example webpage that we can view? One that doesn't require login credentials.

more options

It is possible that another element is covering the link.

What gets selected if you right-click a link and ope the built-in inspector (Inspect Element)?


Make sure that you do not include the # in the name or id where you define the anchor.

<a href="#anchor"> jump to anchor </a>

<div id="anchor">
<a name="anchor"></a>
more options

As far as I can tell, it conforms to the W3 standards... here's a link: http://2ndcycle.com/KFR0, look under House Rules.

When I use Inspect Element, it selects the first link. I haven't used < div id="anchor" >, is that what's wrong?

Modificato da Kristina_A il

more options

Are you referring to the archive links in the column at the right?

What do you expect to happen if you click those links?

I see one anchor in the page source and that name includes a "#": <a name="#intro">
To make a link to that anchor work you need to change the name to <a name="intro">

more options

Soluzione scelta

House Rules at the top of the page.

<a href="#PCgen">Character generation</a>
<a name="#PCgen"><center> 
	<img src="KFR0 images/buts/bar swordcloth.gif" width=500 height=80>
</a></center>

This would be the correct manner. Dump the # and close that a name tag immediately.

 <a name="PCgen"></a> <center> 
	<img src="KFR0 images/buts/bar swordcloth.gif" width=500 height=80>
</center> 
more options

Thank you, the-edmeister and cor-el! That appears to have solved it. Now I feel a little silly for not realizing that was the problem. :P

Cheers!