Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Interlinea Segnalibri

  • 21 risposte
  • 2 hanno questo problema
  • 135 visualizzazioni
  • Ultima risposta di g.sammartino

more options

Dopo averla sistemata tempo fa riportandola a "SINGOLA" - cambiando da "true" a "false" il valore di "browser.proton.contextmenus.enabled - l'INTERLINEA dei SEGNALIBRI e degli altri menu contestuali è tornata ad essere DOPPIA. Con necessità di continui scroll per la ricerca. Qualche soluzione è possibile? Grazie

NB. Il valore di "browser: ecc..." continua a essere "false". >Anche cambiandolo, la situazione non si modifica.

Soluzione scelta

Va attivato l'utilizzo del file come da punto 6 dell'articolo che ho postato: Praticamente apri about:config e accetti il rischio quando te lo chiede, cerchi la voce toolkit.legacyUserProfileCustomizations.stylesheets un doppio clic sopra e cambi da false a true. Chiudi e riapri firefox e dovresti essere a posto

Leggere questa risposta nel contesto 👍 2

Tutte le risposte (20)

more options

browser.proton.contextmenus.enabled era una proprietà temporanea nella fase di transizione tra la vecchia e la nuova interfaccia. E' stata disabilitata con Firefox 91

Può darsi che si possa ancora modificare intervenendo sul file userChrome.css Qui ci sono degli esempi, ma sono gestiti dai singoli utenti e non da Mozilla -> https://firefoxcss-store.github.io/index.html

Modificato da next il

È stato utile?

more options

Inserendo queste righe nel file userChrome.css la distanza è tornata decente:

/*** REDUCING VERTICAL SPACING IN MENUS ***/ menupopup > menuitem, menupopup > menu { padding-block: 3px !important; }

root {

–arrowpanel-menuitem-padding: 3px 6px !important; }

Trovato su Ghacks

Modificato da crazy.cat il

È stato utile?

more options

Non utile, anche se per colpa mia. Non riesco a trovare il file userChrome.css, non so come/dove eventualmente crearlo (tempo di fare casino). Leggo su vari forum (USA, in particolare) che moltissimi sono irritati (eufemismo) per questo cambio (non modificabile, come in passato, intervenendo sui valori dei vari *proton* (alcuni memmeno più disponibili). Sembra che gli sviluppatori abbiano pensato agli utilizzatori di telefonini (per cui la cosa può avere un senso, chissà) sbattendosene dei desktop users come me... E pazienza... Grazie comunque per averci provato  : )

È stato utile?

more options

Se avessi seguito il link...

È stato utile?

more options

crazy.cat ha detto

Inserendo queste righe nel file userChrome.css la distanza è tornata decente: /*** REDUCING VERTICAL SPACING IN MENUS ***/ menupopup > menuitem, menupopup > menu { padding-block: 3px !important; }
root {
–arrowpanel-menuitem-padding: 3px 6px !important; } Trovato su Ghacks

Grazie. Adesso, gentilmente, puoi dirmi dove trovo il file userChrome.css ??? GRAZIE!!!

È stato utile?

more options

Il file userChrome.css va creato come va creata la cartella chrome e abilitato l'uso del file css E' tutto spiegati qui (usa google translate se non ti sono chiari i passaggi) h**ps://www.userchrome.org/how-create-userchrome-css.html

È stato utile?

more options

Grazie. In primis per la tua titanica pazienza. Sono (eccezionalmente) riuscito a creare la cartella chrome nel profilo, em all'interno della stessa, il file userChrome.css. Nel file ho scritto (copia/incolla da tuo precedente post):

/*** REDUCING VERTICAL SPACING IN MENUS ***/ menupopup > menuitem, menupopup > menu { padding-block: 3px !important; }

   root { 

–arrowpanel-menuitem-padding: 3px 6px !important; }

Dovevo copiare qualcosa di meno? Devo attivare qualche opzione in FF perché vada a leggersi il mio nuovo .css allo startup? Te lo chiedo perché, riavviato FF, il problema delle interlinee doppie è ancora lì. Grazie

È stato utile?

more options

Soluzione scelta

Va attivato l'utilizzo del file come da punto 6 dell'articolo che ho postato: Praticamente apri about:config e accetti il rischio quando te lo chiede, cerchi la voce toolkit.legacyUserProfileCustomizations.stylesheets un doppio clic sopra e cambi da false a true. Chiudi e riapri firefox e dovresti essere a posto

È stato utile?

more options

Grazie davvero. Ora l'interlinea dei menu è tornata, come dicevi, decente. Ultima domanda (giuro...): se quel valore di "3px" che vedo nelle tue linee di codice suggerite (e funzionanti) lo riducessi a "2px"... a "1px".... l'interlinea si ridurrebbe ancora un po' (arrivando, per i miei gusti, all'ottimale) o verrebbe su un... ? In questo secondo caso, ovviamente, mi accontenterei di quel che ho  : ) Ancora grazie

È stato utile?

more options

Fai presto a cambiare e fai presto anche a tornare indietro. Questione di gusti, di monitor e di risoluzione. Prova.

È stato utile?

more options

Provato. Funziona (mi sono tenuto sui 2px). Benissimo. Ora la visualizzazione è idem (o comunque molto vicina) a come "prima di". Grazie mille.

È stato utile?

more options

Ringrazio tutti per i suggerimenti. Finalmente ho capito cosa devo fare e come. Finalmente ho il profilo con l'interlinea che piace a me.

Buon ferragosto. Sandro G.

È stato utile?

more options

Con la versione 92 Firefox è tornato a interlinea doppia anche con la cartella "chrome" e il file "userChrome.css"

Domanda: cosa devo fare affinché Firefox 92 torni a interlinea singola?

Grazie per la collaborazione. Sandro.

È stato utile?

more options

A me, anche con l'aggiornamento alla 92.0 è rimasto - almeno per ora - tutto a posto, con interlinea ridotto, ecc. La sola cosa che posso suggerirti (da "no knowledge user"...) è di aprire il tuo userChrome.css, cancellare tutto quello che c'è e sostituirlo con questo


/*** REDUCING VERTICAL SPACING IN MENUS ***/ menupopup > menuitem, menupopup > menu { padding-block: 1px !important; }

   root { 

–arrowpanel-menuitem-padding: 2px 4px !important; }


Poi, riavvia e vedi... Se funziona, bene. Se no... bisogna aspettare crazy.cat  : )

È stato utile?

more options

Grazie per la tua collaborazione, ma purtroppo non è servita. Tra parentesi il file che mi hai postato è praticamente uguale a quello che ho in uso.

speriamo che crazy cat sappia dirmi dove sbaglio.

Saluti Sandro

Modificato da James il

È stato utile?

more options

Ti ringrazio per la collaborazione, ma il tuo css è praticamente identico a quello che ho in uso.

Ho fatto delle prove e effettivamente senza il file userChrome.css la situazione peggiora notevolmente. Tuttavia non è identica a quella che avevo con la versione precedente alla 92. Chissa poi perché?

È stato utile?

more options

Sicuramente un miglioramento ma, pur provando addirittura con 1px 1px non riesco a ridurre ulteriormente l'interlinea. C'è modo di ridurlo ulteriormente?

Lo so che bisogna usare sottocartelle nei menu e lo faccio ma non sempre ciò è facile o conveniente, soprattutto per questa fastidiosa caratteristica per cui non si riesce a "bloccare" i sottomenu quando si navigano con il mouse. Per cui, provando a sistemare un sito come segnalibro trascinandolo nella posizione desiderata, bisogna stare attentissimi a non finire fuori dai suoi confini, pena la chiusura del sottomenu stesso!

Quindi un elenco lungo, in alcuni casi è utile. Ma non così interspaziato.

È stato utile?

more options

Se vuoi... A TUO RISCHIO E PERICOLO  : ) inserire nel tuo userChrome.css quanto segue...


  1. bookmarksMenuPopup menu,
  2. bookmarksMenuPopup menuitem {
 min-height: 12px !important;
 max-height: 12px !important;
 margin-top: 0px !important;
 margin-bottom: 0px !important; }

dovresti... DOVRESTI (?)... ritrovarti con un menu segnalibli che più minimale e compatto di così è impossibile. Lo avevo provato (con la versione precedente di FF)... e poi subito dismesso. Poi crazyat mi ha guidato verso una civiltà più ragionevole...

Ma se hai voglia di provare, chissà. Male che vada, torni indietro...

È stato utile?

more options

Grazie Gianni. provo anch'io questa soluzione, poi vi dirò se è fattibile o meno.

È stato utile?

more options

Gianni Valle ha detto

Se vuoi... A TUO RISCHIO E PERICOLO  : ) inserire nel tuo userChrome.css quanto segue...
  1. bookmarksMenuPopup menu,
  2. bookmarksMenuPopup menuitem {
min-height: 12px !important; max-height: 12px !important; margin-top: 0px !important; margin-bottom: 0px !important; } dovresti... DOVRESTI (?)... ritrovarti con un menu segnalibli che più minimale e compatto di così è impossibile. Lo avevo provato (con la versione precedente di FF)... e poi subito dismesso. Poi crazyat mi ha guidato verso una civiltà più ragionevole... Ma se hai voglia di provare, chissà. Male che vada, torni indietro...

Purtroppo a me non funziona

È stato utile?

  1. 1
  2. 2
Richiedi supporto

Bisogna accedere al proprio account per rispondere nelle discussioni. Se non si possiede ancora un account, inserire una nuova richiesta.