Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Videos on vimeo.com does not play when media.autoplay.enabled is set to false

  • 6 risposte
  • 9 hanno questo problema
  • 14 visualizzazioni
  • Ultima risposta di unhammer

more options

I have set the config media.autoplay.enabled to FALSE to prevent obnoxious websites from autoplaying movies when I visit. This has the unintended side effect that video playback on Vimeo.com doesn't work at all.

Reproduce: Visit Vimeo and play this video https://vimeo.com/channels/staffpicks/151799633 (or any other) Open About:config and set media.autoplay.enabled to FALSE. Reload the vimeo page and click the play button. IT does not play the video.

Tutte le risposte (6)

more options

You may have to click the play button twice to toggle the play state off/on. The JavaScript code may not detect the current state correctly when media.autoplay.enabled is false.

more options

cor-el said

You may have to click the play button twice to toggle the play state off/on. The JavaScript code may not detect the current state correctly when media.autoplay.enabled is false.

No, that is not the cause. The video does simply not play no matter how many times I click on the play button. Tested on both Windows 8, Windows 10. So it is not a machine specific setting I suspect.

more options

OK. I tried it with media.autoplay.enabled set to false and I can replicate it. It looks that setting media.autoplay.enabled to false causes problems here as well, so best is probably to leave this pref at its default value true for now.

more options

cor-el said

OK. I tried it with media.autoplay.enabled set to false and I can replicate it. It looks that setting media.autoplay.enabled to false causes problems here as well, so best is probably to leave this pref at its default value true for now.

The benefits of having media.autoplay.enabled to on far outweighs the disadvantages. I will leave it on. I merely reported it here if people where able to reproduce. Should it be submitted as a bug report_

more options

i find it amazing that between mozilla and vimeo they can not solve this detail.

so stupid.

do a google search for "vimeo does not play in firefox" and there are pages and pages of people with problems and some silly solutions.

both mozilla and vimeo are supposed to be "Alternative" !!!!

well, somebody is losing the plot.

and i am NOT enabling autoplay to let all these stupid websites start their videos in my face. no way.

so i run vimeo on Brave Browser and it works fine, i might go over to Brave full time.

more options

I believe the change happened because websites would start playing the video regardless of autoplay using some javascript, so the autoplay.enabled was changed to mean also that javascript couldn't start the playing, only clicking on the buttons provided by the browser could start playing. Since youtube hides the browser-button and uses javascript buttons, autoplay.enabled on youtube means no playing at all (if I understand correctly): https://bugzilla.mozilla.org/show_bug.cgi?id=659285


However, there is a solution! In about:config, set media.autoplay.enabled back to true, and then set media.block-play-until-visible to true. This won't give click-to-play behaviour, but at least it stops background tabs / bottom-of-the-page / other out-of-sight videos from playing, which at least for me is even better.