X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

force complete page refresh

Inserita

I would like to be able to completely refresh all scripts, images and code (absolutely everything on the page) when I click refresh for a tab. I am a web designer and firefox often serves up old content, regardless of whether I manually empty the cache or click refresh multiple times on a page. I tried some chanegs in the config file too which I saw for earlier versions of firefox but they don't seem to have helped. Any suggestions similar to cmd-shift-r that force a complete refresh of a page would be very much appreciated. Even if there is a way to turn caching off completely so that surfing the web was slower that would be preferable to be able to test site updates correctly. I use firebug so if there is an option in there for forcing full refresh of pages that could also help. I am using the most current version of firefox (43.0.4). Thanks

I would like to be able to completely refresh all scripts, images and code (absolutely everything on the page) when I click refresh for a tab. I am a web designer and firefox often serves up old content, regardless of whether I manually empty the cache or click refresh multiple times on a page. I tried some chanegs in the config file too which I saw for earlier versions of firefox but they don't seem to have helped. Any suggestions similar to cmd-shift-r that force a complete refresh of a page would be very much appreciated. Even if there is a way to turn caching off completely so that surfing the web was slower that would be preferable to be able to test site updates correctly. I use firebug so if there is an option in there for forcing full refresh of pages that could also help. I am using the most current version of firefox (43.0.4). Thanks

Soluzione scelta

Hi, you should be able to temporarily disable cache by doing the following:

  1. Open the developer toolbox (Ctrl+Shift+I or Cmd+Opt+I on Mac).
  2. Click the settings button (near the top right).
  3. Scroll down to the Advanced settings on the bottom right.
  4. Check the option "Disable Cache (when toolbox is open)".
  5. Refresh the page.

Please let me know if this solves your problem. Thanks!

Leggere questa risposta nel contesto 4

Dettagli aggiuntivi sul sistema

Plugin installati

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 15.009.20077
  • Creative Cloud Desktop Plugin.v_3_0_0_0
  • Provides information about the default web browser
  • Plugin for Wacom tablets.

Applicazione

  • Firefox 43.0.4
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:43.0) Gecko/20100101 Firefox/43.0
  • URL per il supporto: https://support.mozilla.org/1/firefox/43.0.4/Darwin/en-GB/

Estensioni

  • Adblock Plus 2.7 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Adguard AdBlocker 2.0.20 (adguardadblocker@adguard.com)
  • anonymoX 2.5.2 (client@anonymox.net)
  • Dashlane 3.6.0 (jetpack-extension@dashlane.com)
  • Firebug 2.0.13 (firebug@software.joehewitt.com)
  • FireFTP 2.0.26 ({a7c6cf7f-112c-4500-a7ea-39801a327e5f})
  • Hard Refresh 1.2.1-signed (hardrefresh@ttg.org)
  • Share Button for Pinterest 43.4.4 ({677a8f98-fd64-40b0-a883-b8c95d0cbf17})
  • Adobe Acrobat DC - Create PDF 15 (web2pdfextension@web2pdf.adobedotcom) (Inattiva)

Javascript

  • incrementalGCEnabled: True

Grafica

  • adapterDescription:
  • adapterDeviceID: 0x0fd5
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x10de
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • supportsHardwareH264: No;
  • webglRenderer: NVIDIA Corporation -- NVIDIA GeForce GT 650M OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Preferenze modificate

Varie

  • User JS: No
  • Accessibilità: No
Qantas94Heavy 4 soluzioni 13 risposte

Soluzione scelta

Hi, you should be able to temporarily disable cache by doing the following:

  1. Open the developer toolbox (Ctrl+Shift+I or Cmd+Opt+I on Mac).
  2. Click the settings button (near the top right).
  3. Scroll down to the Advanced settings on the bottom right.
  4. Check the option "Disable Cache (when toolbox is open)".
  5. Refresh the page.

Please let me know if this solves your problem. Thanks!

Hi, you should be able to temporarily disable cache by doing the following: # Open the developer toolbox (Ctrl+Shift+I or Cmd+Opt+I on Mac). # Click the settings button (near the top right). # Scroll down to the Advanced settings on the bottom right. # Check the option "Disable Cache (when toolbox is open)". # Refresh the page. Please let me know if this solves your problem. Thanks!

Utente che ha posto la domanda

Thanks! I've tested that briefly and it seems to help. Have a good day

Thanks! I've tested that briefly and it seems to help. Have a good day

Utente che ha posto la domanda

. . .

. . .

Modificato da eyetooth il

cor-el
  • Top 10 Contributor
  • Moderator
17588 soluzioni 159105 risposte

Risposta utile

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

"Clear the Cache":

  • Firefox > Preferences > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox > Preferences > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"
You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *Hold down the Shift key and left-click the Reload button *Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *Press "Command + Shift + R" (Mac) "Clear the Cache": *Firefox > Preferences > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox > Preferences > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"