Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I open firefox it automatically opens a new tab, how to get rid of this.

  • 3 replies
  • 22 have this problem
  • 4043 views
  • Last reply by cor-el

more options

My firefox opens to my home page but also opens a new tab with things to add to the new tab such as facebook, etc. How do i get rid of this new tab opening up.

All Replies (3)

more options

Hi there,

Thanks for contacting Mozilla Support. To get rid of the annoying tab:

  1. Close all browsers.
  2. Go to the Start menu.
  3. Select Control Panel → Uninstall a program (or Add/Remove Programs in Windows XP/Vista/7).
  4. Choose Mysearchdial and click the Uninstall/Change button.
  5. Wait for Mysearchdial to uninstall.
  6. Click the Firefox menu (top-left corner).
  7. Select Options.
  8. Under Home Page click the Restore to Default button→ click OK.
  9. Go back to the Firefox menu.
  10. In the menu select Add-ons→ choose the Extensions tab →click Remove on the right of any extensions mentioning "Mysearchdial".
  11. Move the mouse cursor inside the search box at the top right of the Firefox window and click the down arrow next to the provider's logo.
  12. From the dropdown list, select Manage Search Engines....
  13. Select "Mysearchdial".
  14. Click "Delete" or "Remove".

Hope this helps!

Curtis

Mozilla Support volunteer

more options

This uninstalled Mysearchdial but I still have the same problem.

more options

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.

You can check the home page setting:

Firefox supports multiple home pages separated by '|' (pipe) symbols.