X
Tap here to go to the mobile version of the site.

Support Forum

Enable Java in v. 27.0.1

Posted

I just had to do a fresh install on my laptop after my hard drive fried. I reinstalled Firefox, and apparently it gave me a new version. I am an online student, and I need Java to run my school's website. However, when trying to find the appropriate tick box in the Options/Content menu, it is not there. I need Java to be on at all times, not just for one site. I also do not see anything about a red plugin icon on these websites; I don't see a plugin icon anywhere. I need this fixed ASAP, so I would appreciate a quick response. I cannot get homework done without it.

I just had to do a fresh install on my laptop after my hard drive fried. I reinstalled Firefox, and apparently it gave me a new version. I am an online student, and I need Java to run my school's website. However, when trying to find the appropriate tick box in the Options/Content menu, it is not there. I need Java to be on at all times, not just for one site. I also do not see anything about a red plugin icon on these websites; I don't see a plugin icon anywhere. I need this fixed ASAP, so I would appreciate a quick response. I cannot get homework done without it.

Additional System Details

Application

  • Firefox 27.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0
  • Support URL: https://support.mozilla.org/1/firefox/27.0.1/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Microsoft Basic Display Adapter
  • adapterDescription2:
  • adapterDeviceID: 0x791f
  • adapterDeviceID2:
  • adapterDrivers: Unknown
  • adapterDrivers2:
  • adapterRAM: 0
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'10.6']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16384
  • driverDate: 6-21-2006
  • driverDate2:
  • driverVersion: 6.2.9200.16384
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'9.6']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'9.6']
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140212131424
  • browser.startup.homepage_override.buildID: 20140212131424
  • browser.startup.homepage_override.mstone: 27.0.1
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 27.0.1
  • font.name.monospace.x-western: Georgia
  • font.name.sans-serif.x-western: Georgia
  • font.name.serif.x-western: Georgia
  • font.size.fixed.x-western: 12
  • font.size.variable.x-western: 14
  • gfx.blacklist.direct2d: 3
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 77126
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
Diego Victor
  • Top 25 Contributor
  • Moderator
631 solutions 4024 answers

Try go to about:config search for plugin.state.java and change its valueto true, also go to Tools >> Addons >> Plugins and look for Java and change its option to Always active or Ask to active

Try go to '''about:config''' search for '''plugin.state.java''' and change its valueto '''true''', also go to '''Tools''' >> '''Addons''' >> '''Plugins''' and look for Java and change its option to '''Always active''' or '''Ask to active''' *[http://kb.mozillazine.org/About:config about:config]

Modified by Diego Victor

cor-el
  • Top 10 Contributor
  • Moderator
13070 solutions 119653 answers

In current Firefox releases you can enable and disable the Java plugin in "Firefox/Tools > Add-ons > Plugins"

Note that you can get a possibly colored Lego block icon on the left end of the location bar that indicates that Firefox is blocking a plugin.

You can check the Security tab Java Control Center in the Windows Control Panel to make sure that "Enable Java content in the browser" is enabled.

See also:

In current Firefox releases you can enable and disable the Java plugin in "Firefox/Tools > Add-ons > Plugins" Note that you can get a possibly colored Lego block icon on the left end of the location bar that indicates that Firefox is blocking a plugin. *https://support.mozilla.org/kb/why-do-i-have-click-activate-plugins *http://kb.mozillazine.org/Issues_related_to_plugins#Click_to_Play You can check the Security tab Java Control Center in the Windows Control Panel to make sure that "Enable Java content in the browser" is enabled. See also: *http://kb.mozillazine.org/Java