Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My new tab does not have the show and hide icon and no choices

  • 18 replies
  • 4 have this problem
  • 749 views
  • Last reply by jscher2000

more options

When I installed Firefox and clicked on the new tab I could see the hide icon. There were no choices as I had no history of picking a web sie. I I chose a site by using bookmarks and then closed Firefox and reopened firefox, the hide icon disappeared and no choces were available

All Replies (18)

more options

Hello h2obury26,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information.
Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

Thank you.

more options

It solved the problem initially and produced a tab with multiple url's. However when I exited and restarted the new version had the old tabs with no choice., It also had a different start page from the one that was produced after the reset

more options

You can use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

If you do not keep changes after a restart or otherwise have problems with preferences, see:

more options

Sometimes settings changes or settings being ignored is caused by an add-on.

Try disabling ALL nonessential or unrecognized add-ons on these two tabs (if in doubt, disable):

orange Firefox button (or Tools menu) > Add-ons > Plugins category
orange Firefox button (or Tools menu) > Add-ons > Extensions category

Usually a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

more options

I ran the add-on and then restarted and Firefox had still not saved the preferences. I also changed to Profile to not be "read-only" and that did not work. When I applied the folder change and then went back to the folder, the change was no longer there.

more options

I disabled all the plugins and extensions and it did not help. I might be having trouble with profiles

more options

I do not know if I already sent this to you.

I ran the add-on and then restarted and Firefox had still not saved the preferences. I also changed to Profile to not be "read-only" and that did not work. When I applied the folder change and then went back to the folder, the change was no longer there.

more options

Can you try to clarify with a screenshot what exactly you mean?

Use a compressed image type like PNG or JPG to save the screenshot.

more options

I have a jpg of the tab with not choices and the tab with choices. I do not know how to get them into the reply box. I clicked on add images and browsed to them and uploaded them and they are displayed just below the reply box. Let me know how to get them to you.

more options

I can't help thinking that AVG search bar has something to do with it. If you check in about:config, has an AVG URL taken over the page?

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) If it shows as "user set", double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

If it's not caused by an AVG extension, could you check for a user.js file as described in this article: How to fix preferences that won't save.

more options

You can start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
more options

If I go to Appdata.roaming.mozilla.firefox.profiles there is a folder, exhoox56. default-380657880. If I open the folder and delete the file, pref.js, and open Firefox, I get the tabs I am looking for. I have no idea what pref.js is. I think I need help from the Mozilla developers.

more options

I got the about:config and entered newtab. The only "user set" was "browser.newpage.storage.version. I could set it to other than one, but that did nothing. I went to "how to fix preferences that were not saved". It told me to make sure user.js was not "read only" I found pref.js and it was not marked "read only". If I delete it and then start Firefox I get the proper tab, but it goes away when I exit and restart. One interesting thing is that when I reset or start after deleting pref.js, the first tab is the Mozilla Firefox Start tab that appears when you first install Firefox.

more options

Hi h2obury26, prefs.js stores settings that you customize through the user interface, and some values computed automatically by Firefox, such as cache size.

Did you see a user.js file? That will override your changes saved in prefs.js. It would be in the same folder, as described in this article: How to fix preferences that won't save.

Did you figure out where that AVG search bar is coming from? I feel that it must be an extension, but maybe it is being injected after the first restart? Please check again after the problem reappears:

orange Firefox button (or Tools menu) > Add-ons

On the left side, click Extensions to list that category.

more options

there is no user.js in the profile. I do not see AVG search It might have been there earlier. It does appear with Internet Explorer.

more options

Hi h2obury26, are there any other extensions that might have AVG search bundled in as a feature?? I'm running out of ideas.

more options

I am not sure what an extension is. How do I examine them to look for AVG? I am having this problem with a new Dell I just purchased. It was advertised as one of the last I could buy with Windows 7. As I was setting it up I googled Firefox and downloaded it. I am not sure it was from the Mozilla Website. I remember some search stuff showing up on the first tabs. When I opened additional tabs they arrived with a site already chosen. I do not remember what it was, but there colored drawing s of people. It might have been AVG. I do remember "search". I then uninstalled and downloaded again. I think the fact that if I delete prefs.js from the profile and restart, the problem goes away, should be a clue. Why should a tab with no choice "icon" in the upper right corner be produced at all? I thought all the tabs for the new version would come with the choice icon. I would think a developer would know immediately what was wrong, but since Firefox is being produced as free software, there is no way to get such a question answered.

more options

Extensions are a kind of add-on. When you open the add-ons page, there are several categories on the left side. If you click Extensions, do you find anything there? Many add-ons may be found automatically on your system or, if you installed some kind of unofficial customized package, they may be embedded in your program folder.

You may want to do a Clean reinstall with the official installer.

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from http://www.mozilla.org/en-US/firefox/all/ (choose the desired language) and save the setup file to your desktop or other handy location.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu).
  3. Rename the Firefox program folder (you could delete it, but this way if you want to scrounge any files from it, you still have it handy):

    C:\Program Files (x86)\Mozilla Firefox

    For example, to:

    C:\Program Files (x86)\Bad Mozilla Firefox

  4. Now, go ahead and reinstall Firefox:
    • Double-click the downloaded installation file and go through the steps of the installation wizard.
    • Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

You may still need to update that new tab setting one more time, but at least you'll be working with the official software.