Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox constantly crashes

  • 12 replies
  • 53 have this problem
  • 2326 views
  • Last reply by jscher2000

more options

I have completed several suggestions by Mozilla to stop crashing but to no avail. I am using the latest version 23.0 and have had crashes for months now.

All Replies (12)

more options

We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash ID's to help us learn more about your crash.

  1. Enter about:crashes in the address bar (that's where you enter your website URL) and press Enter. You should now see a list of submitted crash reports.
  2. Copy the 5 most recent crash ID's that you see in the crash report window and paste them into your response here.

Thank you for your help!

More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

more options

Can you post some of your recent crash IDs as described in this article: Firefox crashes - Troubleshoot, prevent and get help fixing crashes.

more options

Thanks everyone:

bp-3ba99ade-6a85-410d-b49a-707eb2130821
e787186d-8338-4eb9-a2e2-e8c99ca03f8f
bp-002c783c-e3f6-421c-89ea-08d242130820
bp-d23ea6c3-7850-4b05-b8d9-9c6442130820
bp-26f7b122-c7f5-4811-bb21-6f1f52130819
90498cd3-5f51-445e-8be2-85ce20636c58
bp-603c92df-702f-4a2d-a717-ee4482130819

Modified by cor-el

more options

Hi Zekeman2299, I took a look at the crash reports and did not see any obvious quick solution for you.

There was a suggestion in one of the bug reports that some crashes may be due to the built-in PDF viewer. This article describes how to disable it and use a different viewer: View PDF files in Firefox or choose another viewer.

You might also disable all plugins other than Flash, PDF, and anything you use more than once a day.

orange Firefox button (or Tools menu) > Add-ons > Plugins category


How often do the crashes occur? If you have more than one a day, could you try running in Firefox's Safe Mode for a day?

Unfortunately, Safe Mode disables all extensions, so that functionality will be missing. Alternately, you could try disabling all extensions except RoboForm, assuming you use that one daily.

  • orange Firefox button (or Tools menu) > Add-ons > Extensions category
more options

Try to disable hardware acceleration in Firefox.

more options

Cor-El thanks for the suggestion, but it is already disabled..

more options

Here's one fix that worked for me: I just started having this problem, severely...... so I checked the video .dll files (my card is an ATI so I looked at all of the .dll files starting with "ati") in Windows > "System 32" folder, AND the Windows > System 32 > "dllcache" folder. After I looked at each ATI video .dll file's Properties I found the same named .dll files did not match!! I simply found the most current ones, then copied those and replaced the older ones.

Problem fixed!! It was crashing sometimes in seconds from opening Firefox OR Internet Explorer. Flash Player was constantly crashing too if the pages stayed open long enough for that to even run. Not anymore!!

more options

Follow my crash ID's

bp-b5d891f7-0204-44b3-9b72-de650213120606/12/201302:34 p.m.bp-72a68216-c9eb-46cc-bd45-86b3f213120505/12/201303:53 p.m.bp-45cae63d-6627-4825-a3b6-50a17213120505/12/201303:47 p.m.bp-70d6efc3-90be-4939-ac11-f75cd213112929/11/201304:01 p.m.bp-23f170e8-a3ff-48cd-a0d2-d3cb6213112929/11/201303:41 p.m.

more options

Hi taguato1, your five crash reports all show Firefox 23.0.1. Can you update to Firefox 25.0.1? You can do that using either:

Modified by jscher2000

more options

Hi taguato1

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
more options

Im getting many crashes a day Report ID Date Submitted bp-f0349c98-448e-40fb-9843-7a3bd2140126 1/26/2014 1:24 PM bp-cbea3db9-2858-4049-8988-ac1892140126 1/26/2014 1:14 PM bp-381e1e4c-6006-46cf-8d62-586b92140126 1/25/2014 7:52 PM bp-8c8428c1-11de-444a-9008-8765d2140125 1/25/2014 1:14 PM d4b514d3-054e-4e90-9e95-8952d8b7b042 1/23/2014 5:32 PM bp-7f780ec0-a610-4be2-bc9d-b96812140123 1/22/2014 7:44 PM bp-b220596e-8c34-4ba3-850e-3e18b2140123 1/22/2014 7:42 PM e660c255-7b47-4497-bf31-4a2708c1ca5d 1/22/2014 7:37 PM bp-beac81ca-86ee-47d1-8a0b-9b4cc214012

more options

Hi bac12476, your reports all refer to a crash in an Nvidia driver. Do you recall updating your graphics card drivers software recently? Sometimes an update will reveal a previously undiscovered incompatibility in Firefox.

As a workaround, try disabling Firefox's use of hardware acceleration for graphics.

orange Firefox button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

Edit: This doesn't take effect until after you exit and restart Firefox.

If Firefox will not stay up long enough to changes settings, make the change in Firefox's Safe Mode. To start Firefox in its Safe Mode, hold down the Shift key when starting Firefox.

Then, in the small dialog that appears, click "Start in Safe Mode" (not Reset)

To return to normal operation after making the changes, exit Firefox and start without holding down the Shift key.

Any improvement?

Modified by jscher2000